SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-27-2007, 04:24 PM   #1
Salsa88
Member
Salsa88 is on a distinguished road
 
Salsa88's Avatar
 
Join Date: Oct 2007
Posts: 96

1999 SC1
Attention Horn not working hlp plz!

So I took my car to get inspected and it failed because my horn want work. I thought it was just a blown fuse so when i got home i checked and the fuse was just fine. i tested a new fuse and still nothing with the horn. What could it be? i heard it could be the relay but i have no idea how or where to check the relay.

REWARD EXCELLENCE!

Add to Salsa88's Reputation
Rate the quality of this post and help Salsa88 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Salsa88 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-27-2007, 04:35 PM   #2
asdf
Advanced Member
asdf is on a distinguished road
 
Join Date: Aug 2005
Posts: 897

1996 SC2
1995 SC2
Default Re: Horn not working hlp plz!

This is for your '99? Just unplug the horn, and test for voltage when someone pushes the button.

If there is voltage, you get a new 96+ horn from the junkyard.

The horn in my '96 didn't work when I got it. Drove me nuts. Some of the pins were corroded from the plug, but once I fixed that still didn't work, the horn was bad.

And yeah, if there is no voltage, and you don't hear a click from the relay when you press the button, its probably either the relay or switch.

REWARD EXCELLENCE!

Add to asdf's Reputation
Rate the quality of this post and help asdf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
asdf is offline   Reply With Quote
Old 12-27-2007, 04:37 PM   #3
bobfather99
Member
bobfather99 is on a distinguished road
 
Join Date: Mar 2007
Location: NW Indiana
Posts: 468

1994 SL1
Default Re: Horn not working hlp plz!

Could be the relay, or something as simple as a loose connection or ground.
I had a Ford Truck that had a loose mounting point; horn didnt work until I cleaned up the bolt and tightened it down.

REWARD EXCELLENCE!

Add to bobfather99's Reputation
Rate the quality of this post and help bobfather99 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bobfather99 is offline   Reply With Quote
Old 12-27-2007, 04:46 PM   #4
asdf
Advanced Member
asdf is on a distinguished road
 
Join Date: Aug 2005
Posts: 897

1996 SC2
1995 SC2
Default Re: Horn not working hlp plz!

and actually, what you can try first is just switching the horn relay under the hood with the A/C relay, or whatever you know works.

and then just leave the known good relay there for until you find the other problem, in case 2 things are bad.

...or you can just put the horn relay in the A/C and see if the A/C still works

REWARD EXCELLENCE!

Add to asdf's Reputation
Rate the quality of this post and help asdf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
asdf is offline   Reply With Quote
Old 12-27-2007, 06:08 PM   #5
Salsa88
Member
Salsa88 is on a distinguished road
 
Salsa88's Avatar
 
Join Date: Oct 2007
Posts: 96

1999 SC1
Default Re: Horn not working hlp plz!

where are the relays?

REWARD EXCELLENCE!

Add to Salsa88's Reputation
Rate the quality of this post and help Salsa88 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Salsa88 is offline   Reply With Quote
Old 12-27-2007, 06:10 PM   #6
asdf
Advanced Member
asdf is on a distinguished road
 
Join Date: Aug 2005
Posts: 897

1996 SC2
1995 SC2
Default Re: Horn not working hlp plz!

Those plastic cubes. Just look under the cover of the underhood fuse panel, the map will tell you what's what.

REWARD EXCELLENCE!

Add to asdf's Reputation
Rate the quality of this post and help asdf reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
asdf is offline   Reply With Quote
Old 12-27-2007, 06:21 PM   #7
Salsa88
Member
Salsa88 is on a distinguished road
 
Salsa88's Avatar
 
Join Date: Oct 2007
Posts: 96

1999 SC1
Default Re: Horn not working hlp plz!

Thanks i thought so I just didnt want to start pulling things without 100% nowing what i was pulling on

REWARD EXCELLENCE!

Add to Salsa88's Reputation
Rate the quality of this post and help Salsa88 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Salsa88 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cooling fans quit working again???? plz help. TheGreenOne S-Series Tech 3 03-24-2008 07:51 PM
Sunroof leaking, hlp plz SimPlyxTriPPiN S-Series Tech 6 02-14-2008 07:51 PM
Horn not working, which fuse is it? bankerbob S-Series Tech 2 08-14-2006 01:48 PM
horn help plz ILMsl1 S-Series Tech 5 07-04-2005 04:04 PM
Horn not working gunny S-Series Tech 10 08-28-2002 01:52 PM


All times are GMT -4. The time now is 06:13 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.