SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-08-2018, 09:40 PM   #1
dreamrunner69
Junior Member
dreamrunner69 is on a distinguished road
 
Join Date: Jun 2014
Posts: 17
Default crazy trans problem

04 lw300, service wrench comes on intermittently sometimes once a day and sometimes five times a day. hard shift in every gear. turn car off for a minute and problem goes away and sometimes is fine rest of the day. sometimes comes back on within five minutes. i have a worn out ignition switch that was rekeyed to the old key and will let the key be removed while running. when key is removed the wrench light will come on and it will shift hard. also dash lights will flicker or go out at night when driving if hi/low switch for headlights is activated.could that be ignition switch related? i have read everything on the shift and wrench issues that i can find and answers range from maf, to o2 sen, to pressure solenoid, to fluid and filter change, fluid lvl and on and on... the intermittent issue that ranges from once a day, to five times a day to not happening for a week is what has me stumped. also could a worn or broken trans mount cause this issue? i have noticed over last couple of times driving thar when making a left hand turn it feels like the frontend is shuddering almost as if skipping through the turn. maybe also a mount?to late to look at now but going to give it all a good once over in the daylight. any help or suggestions are appreciated and i will also post what i find so it may help others......

REWARD EXCELLENCE!

Add to dreamrunner69's Reputation
Rate the quality of this post and help dreamrunner69 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dreamrunner69 is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
crazy problem with friends view, need help asap crazymjb Vue Tech 7 11-06-2014 02:02 PM
Crazy car starting problem, please advise!!! gusmandave L-Series Tech 2 08-03-2012 04:49 PM
help! crazy electrical problem slosaturn S-Series Tech 6 09-04-2006 09:11 AM
idle & vent problem?? makin me crazy!! shaner123 S-Series General 7 11-17-2005 02:02 PM
Crazy Electrical Problem myoung Miscellaneous Tech 3 03-12-2003 08:35 AM


All times are GMT -4. The time now is 11:42 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.