SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-23-2017, 05:37 PM   #1
Ravioli684
New Member
Ravioli684 is on a distinguished road
 
Join Date: Aug 2017
Posts: 1
Default Multiple codes detected, completely stumped

Hi, first i would like to thank you for any help, this is my first post here and i have visited this site numerous amounts of time since I've had my Saturn Sl2, and its has always pointed me in the right direction. Ok, lets get to it - i have a 99 Saturn Sl2, about 167000 miles, i have a california emissions test coming up soon, but i have multiple codes coming up:

P0405
P0401
P0410
P1404

I have changed my EGR, I also did a full cleaning of the throttle where the carbon build up was (Richpin video), I've also changed my O2 sensor and cleaned the metal pipe piece above it from which the diverter goes into the engine block.

Now, i have finally noticed the secondary air pump is not coming on whatsoever. It does work when connected directly to a battery. This wasn't a problem about 3 months ago, but since then i have replaced the EGR. I checked the fuse, the relay and connectors, they all seem fine and in working order. The connector to the air pump doesnt seem to be getting any power, i have a multimeter (im not very inclined on the electrical part of cars, sorry) and to the best of my seeing when connected with the meter, nothing happens on my screen when the leads are against the metal pins. This test was conducted a few times at cold start ups.

I'm not sure if all the codes are related to one another, I know its all emmisons related and I have to pass by next month. Any and all help is appreciated, and i hope did this right on the forum.

REWARD EXCELLENCE!

Add to Ravioli684's Reputation
Rate the quality of this post and help Ravioli684 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Ravioli684 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-23-2017, 07:38 PM   #2
toggenburg
Master Member
toggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to beholdtoggenburg is a splendid one to behold
 
toggenburg's Avatar
 
Join Date: Apr 2010
Location: Beautiful Blue Ridge Mountains of Bedford, Virginia
Posts: 2,358

2001 SL1
Default Re: Multiple codes detected, completely stumped

Sounds like your EGR sensor is shorted to ground somewhere...skinned wire touching bare metal maybe.

REWARD EXCELLENCE!

Add to toggenburg's Reputation
Rate the quality of this post and help toggenburg reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
toggenburg is offline   Reply With Quote
Old 08-24-2017, 11:51 AM   #3
alordofchaos
Super Member
alordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to beholdalordofchaos is a splendid one to behold
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 11,153
 

1998 SL2
1997 SL2
Default Re: Multiple codes detected, completely stumped

Sorry if I misunderstood - you've done the EGR per the richpin video, but have you done his p0410 troubleshooting? Haven't watched it in a while but he covers some of the electric issues, I think

https://www.youtube.com/watch?v=dIrmkxj6wJE

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 124k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple CEL Codes - Multiple problems? Mystic_Cobra S-Series Tech 4 05-05-2016 03:32 PM
Random - Multiple Misfire Detected donaldr Aura General 3 11-20-2015 10:51 PM
Multiple SES codes quickster S-Series Tech 7 05-28-2014 09:53 PM
Multiple Codes...again Welljl01 S-Series Tech 1 06-28-2012 12:42 PM
Multiple Codes vince776 S-Series Tech 4 08-26-2011 11:06 AM


All times are GMT -5. The time now is 11:25 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.