SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Sky > Sky Red Line
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 08-12-2017, 01:05 PM   #1
sbcomposer
New Member
sbcomposer is on a distinguished road
 
Join Date: Aug 2017
Posts: 2
Default Just Wont Start WIth New Battery

Just two days ago I noticed when starting my 2007 Redline it was as if it wasn't going to turn over - really weak turn but then it would start. Got worse as they day progressed.

When I got home and turned off the car I thought I would check. And I got the famous dead battery clicking sound. At least I made it home!

So yesterday I bought a new battery. Put it in. Now I get nothing but a click, a few lights, and then just an icon that looks like a pump. I tested the new battery with a Digimeter and its at 12.1 volts.

I am trying the security reset now however the lock icon has not been staying lit. I am only trying this because I have no idea what else to look for at this point.

A note to this: When I try and start it I hear what sounds just like a CD trying to eject from the player but its not the CD. This sound actually comes from the passenger side engine compartment.

REWARD EXCELLENCE!

Add to sbcomposer's Reputation
Rate the quality of this post and help sbcomposer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
sbcomposer is offline   Reply With Quote
SaturnFans.com Sponsored Links
 



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wont start gas+starter+battery gammag69 Ion General 1 01-05-2016 06:34 PM
Replaced Battery Cable, Car wont start marmitage Ion General 4 06-27-2015 08:39 PM
Battery died now car wont start babygirlnes Ion Tech 11 01-15-2013 06:46 PM
My 2000 SL2 wont start- battery dead.. Ursaturngirl S-Series Tech 7 05-20-2012 03:30 PM
car wont start. battery? gapessos S-Series Tech 10 01-09-2012 04:06 PM


All times are GMT -5. The time now is 12:16 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.