SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-03-2017, 03:08 AM   #1
vikasevan
Member
vikasevan has a spectacular aura aboutvikasevan has a spectacular aura about
 
vikasevan's Avatar
 
Join Date: Jan 2013
Location: Lakewood WA
Posts: 350

2001 SL2
2004 VUE 3.5L
Roll Eyes 2004 automatic 3.5 awd

2004 Saturn automatic 3.5L AWD 177K

Vue is showing red low oil pressure light on dash....

Oil is not low ....it has full oil...so we can think of oil pressure sensor could be bad but here is what happens...

In idle it does show low oil pressure light but engine does not shut off but when driving for about 10 minutes light is still there but engine shut off ...

If Oil pressure sensor is bad ...won't it shut off engine in idle as well?
Why it shuts off only while driving for about 10 minutes..

REWARD EXCELLENCE!

Add to vikasevan's Reputation
Rate the quality of this post and help vikasevan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vikasevan is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-03-2017, 08:52 AM   #2
billysvue
Master Member
billysvue is a jewel in the roughbillysvue is a jewel in the roughbillysvue is a jewel in the rough
 
Join Date: Aug 2012
Location: san diego
Posts: 4,355

2005 VUE 2.2L
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by vikasevan View Post
If Oil pressure sensor is bad ...won't it shut off engine in idle as well?
Why it shuts off only while driving for about 10 minutes..
"Shuts off" means what?
- no power whatsoever, all electrical goes dead( lights radio, etc...) and you coast to a stop? Or what exactly?

Maintenance history/odo is???????

OIl is how old? Synthetic?
C.E.L. code?

...
'05 ,2.2L, FWD,5-speed stick with transaxle death rattle is history,,,
'17 Suby Forester

245216 mi. VUe is off to the dealer auction
I'm a secondhand vegetarian.
Cows eat grass, I eat cows.

REWARD EXCELLENCE!

Add to billysvue's Reputation
Rate the quality of this post and help billysvue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
billysvue is offline   Reply With Quote
Old 06-03-2017, 01:12 PM   #3
atikovi
Member
atikovi is just really niceatikovi is just really niceatikovi is just really niceatikovi is just really nice
 
Join Date: Oct 2004
Location: Suburban Washington DC
Posts: 330
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by vikasevan View Post
Vue is showing red low oil pressure light on dash....

Oil is not low ....it has full oil.
The oil light is for pressure not level. I wouldn't drive it 10 seconds let alone 10 minutes with that light on.

REWARD EXCELLENCE!

Add to atikovi's Reputation
Rate the quality of this post and help atikovi reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
atikovi is offline   Reply With Quote
Old 06-03-2017, 02:20 PM   #4
vikasevan
Member
vikasevan has a spectacular aura aboutvikasevan has a spectacular aura about
 
vikasevan's Avatar
 
Join Date: Jan 2013
Location: Lakewood WA
Posts: 350

2001 SL2
2004 VUE 3.5L
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by atikovi View Post
The oil light is for pressure not level. I wouldn't drive it 10 seconds let alone 10 minutes with that light on.
But oil pressure sensor can be bad which is why it could show false indication on dash?

REWARD EXCELLENCE!

Add to vikasevan's Reputation
Rate the quality of this post and help vikasevan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vikasevan is offline   Reply With Quote
Old 06-03-2017, 02:34 PM   #5
atikovi
Member
atikovi is just really niceatikovi is just really niceatikovi is just really niceatikovi is just really nice
 
Join Date: Oct 2004
Location: Suburban Washington DC
Posts: 330
Default Re: 2004 automatic 3.5 awd

Either test the pressure or put in a new sensor before driving unless you feel lucky.

REWARD EXCELLENCE!

Add to atikovi's Reputation
Rate the quality of this post and help atikovi reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
atikovi is offline   Reply With Quote
Old 06-03-2017, 02:50 PM   #6
vikasevan
Member
vikasevan has a spectacular aura aboutvikasevan has a spectacular aura about
 
vikasevan's Avatar
 
Join Date: Jan 2013
Location: Lakewood WA
Posts: 350

2001 SL2
2004 VUE 3.5L
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by atikovi View Post
Either test the pressure or put in a new sensor before driving unless you feel lucky.
How do I check oil pressure ...I have obd2 adapter but android app 'torque' does not show oil pressure check option

REWARD EXCELLENCE!

Add to vikasevan's Reputation
Rate the quality of this post and help vikasevan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vikasevan is offline   Reply With Quote
Old 06-03-2017, 03:36 PM   #7
atikovi
Member
atikovi is just really niceatikovi is just really niceatikovi is just really niceatikovi is just really nice
 
Join Date: Oct 2004
Location: Suburban Washington DC
Posts: 330
Default Re: 2004 automatic 3.5 awd

You need to remove the sensor and connect a test gauge like http://www.tooltopia.com/otc-tools-5..._95RoCIv3w_wcB If the sensor is pretty cheap, you can just replace it instead.

REWARD EXCELLENCE!

Add to atikovi's Reputation
Rate the quality of this post and help atikovi reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
atikovi is offline   Reply With Quote
Old 06-04-2017, 04:05 AM   #8
vikasevan
Member
vikasevan has a spectacular aura aboutvikasevan has a spectacular aura about
 
vikasevan's Avatar
 
Join Date: Jan 2013
Location: Lakewood WA
Posts: 350

2001 SL2
2004 VUE 3.5L
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by atikovi View Post
You need to remove the sensor and connect a test gauge like http://www.tooltopia.com/otc-tools-5..._95RoCIv3w_wcB If the sensor is pretty cheap, you can just replace it instead.
Thanks,
Remove oil pressure sensor and put test gauge there ...or I have make a T with an adapter? also there are two right next to each other ...one is sensor and other is sender ...which one I should remove and install the test gauge?

REWARD EXCELLENCE!

Add to vikasevan's Reputation
Rate the quality of this post and help vikasevan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vikasevan is offline   Reply With Quote
Old 06-04-2017, 05:36 AM   #9
atikovi
Member
atikovi is just really niceatikovi is just really niceatikovi is just really niceatikovi is just really nice
 
Join Date: Oct 2004
Location: Suburban Washington DC
Posts: 330
Default Re: 2004 automatic 3.5 awd

You didn't mention it also has a gauge. If the gauge reads normal but the light is on, it's almost always a bad sensor for the light. Read up at http://www.saturnfans.com/forums/sho...d.php?t=229989

REWARD EXCELLENCE!

Add to atikovi's Reputation
Rate the quality of this post and help atikovi reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
atikovi is offline   Reply With Quote
Old 06-04-2017, 01:19 PM   #10
vikasevan
Member
vikasevan has a spectacular aura aboutvikasevan has a spectacular aura about
 
vikasevan's Avatar
 
Join Date: Jan 2013
Location: Lakewood WA
Posts: 350

2001 SL2
2004 VUE 3.5L
Default Re: 2004 automatic 3.5 awd

Quote:
Originally Posted by atikovi View Post
You didn't mention it also has a gauge. If the gauge reads normal but the light is on, it's almost always a bad sensor for the light. Read up at http://www.saturnfans.com/forums/sho...d.php?t=229989

Car does not have gauge ...I bought mechanical gauge ..not sure where to hook it up? there are two ports which are occupied...one has green connector other has black...which port I should hook my oil pressure tester gauge to?

in other words one sensor is for light and other is for actual oil pressure ?
I am confused...

on Rockauto when I found AIRTEX/WELLS 1S7668 {#12582260, PS592} Info
Oil Pressure Switch; with Gauge and other says oil flow control switch with gauge AIRTEX/WELLS 1S7596 {#12582261, PS593} Info
Oil Flow Control Switch; with Gauge

so one says oil flow control switch which is green connector ...should I remove that and install my mechanical gauge to check pressure or I should remove the other one?

Last edited by vikasevan; 06-04-2017 at 01:31 PM..

REWARD EXCELLENCE!

Add to vikasevan's Reputation
Rate the quality of this post and help vikasevan reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
vikasevan is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Vue Automatic Loc issue oxfordbrent Vue Tech 3 04-14-2016 01:22 PM
2004 Ion Coupes with a 5 speed automatic? FnKVn Ion General 19 08-29-2013 09:31 PM
What mileage should I change the automatic trans fluid 2004 ion2 SC Saturn Owner Ion General 9 01-14-2010 02:09 PM
2004 Ion 2 or 2004 Vue? (or taking advice from complete strangers) kennywhy General Saturn Discussion 11 12-28-2004 12:30 PM
2004 Ion 5 speed Automatic Transmission fredrick Ion General 2 10-22-2004 11:13 AM


All times are GMT -5. The time now is 06:54 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.