SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Outlook > Outlook General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 05-02-2017, 04:51 PM   #1
tvanhaitsma
New Member
tvanhaitsma is on a distinguished road
 
Join Date: Apr 2017
Posts: 2
Default C0045 code after bearing and sensor replaced

2007 Saturn Outlook XR AWD, replaced left rear wheel bearing and wheel speed sensor. Getting C0045 code. Have tried two different bearings and sensors... Any ideas how to fix it? Reset code, goes through self check after startup and throws code again. There was no code before we replaced the wheel bearing.

REWARD EXCELLENCE!

Add to tvanhaitsma's Reputation
Rate the quality of this post and help tvanhaitsma reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tvanhaitsma is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-02-2017, 05:45 PM   #2
pierrot
Master Member
pierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud of
 
pierrot's Avatar
 
Join Date: Jun 2012
Location: Glendora, CA
Posts: 2,959
 

2000 L-Series 2.2L Sedan
Default Re: C0045 code after bearing and sensor replaced

Welcome to SaturnFans, tvanhaitsma! There aren't as many Outlook owners here since the vehicle had only four model years of production and the last was abreviated, so there's not a great deal of familiarity with it for the rest of us.

I apologize in advance for asking what may be a dumb question:
was it absolutely necessary to replace the speed sensor when replacing the L/R wheel bearing?
What brand, or brands, of sensors (ABS Sensors, I presume) have been used?
Do you still have the original sensor to use for comparative purposes?
What type/brand of code reader are you using?
Very few members in SaturnFans have code readers that can access C Series (Chassis) DTC's.

...
276,000 miles-it keeps on rolling!
The blessings of liberty erode in my country.
Gov't's grown bigger, but a chance exists that it will be reduced. I'm cautiously hopeful.

REWARD EXCELLENCE!

Add to pierrot's Reputation
Rate the quality of this post and help pierrot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
pierrot is offline   Reply With Quote
Old 05-02-2017, 10:48 PM   #3
tvanhaitsma
New Member
tvanhaitsma is on a distinguished road
 
Join Date: Apr 2017
Posts: 2
Default Re: C0045 code after bearing and sensor replaced

Thanks for the response.

It is recommended that when changing the hub assembly you pull out the abs sensor to avoid damage. However, it broke when I pulled it out so I was forced to replace it. I used Moog bearing assemblies with both a BWD sensor and a NAPA sensor. The two new sensor and the original sensor all look almost identical. There is a slight difference in the way the sensor latches to the factory harness but it does still snap into place.

It has to be an electrical issue so I am going to try and find a schematic and start troubleshooting next.

I use the Blue Driver from Lemur Monitors which pairs to my Android phone. I have been very happy with it.

REWARD EXCELLENCE!

Add to tvanhaitsma's Reputation
Rate the quality of this post and help tvanhaitsma reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tvanhaitsma is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
intermediate shaft bearing replaced lord_varon Vue General 9 05-31-2017 02:48 PM
replaced my a/c pulley bearing trock859 S-Series Tech 16 06-05-2015 09:55 PM
Replaced O2 sensor.....code reset? LIGuy Ion General 1 10-26-2011 03:16 PM
P0141 Code, Replaced the O2 Sensor and still throws it? saborstorm S-Series Tech 1 09-06-2009 04:39 PM
Vehicle Speed sensor replaced and still throwing code. Triggamane S-Series Tech 11 05-17-2009 03:06 PM


All times are GMT -5. The time now is 10:41 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.