SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Sky > Sky General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 10-22-2014, 06:54 PM   #1
performancebowl
New Member
performancebowl is on a distinguished road
 
Join Date: Oct 2014
Posts: 2
Default No heat

My 07 sky won't switch over to heat. When I turn the temp knob to heat, I hear a grinding noise in the dash but no heat. Same sound occurs when I switch back to cool/ac. I suspect an issue with the blend door but not sure where to start. Any ideas would be greatly appreciated. Btw, I do have a new control panel I can install if necessary.

REWARD EXCELLENCE!

Add to performancebowl's Reputation
Rate the quality of this post and help performancebowl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
performancebowl is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-22-2014, 07:49 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,216
 

2003 L-Series 3.0L Sedan
Default Re: No heat

Try observing each actuator for movement before deciding on whether or not one is broken.
Attached Images
File Type: jpg Sky hvac.jpg (71.1 KB, 10 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 10-24-2014, 10:28 AM   #3
performancebowl
New Member
performancebowl is on a distinguished road
 
Join Date: Oct 2014
Posts: 2
Default Re: No heat

Thanks for the suggestion. I will do that. Any idea how difficult it is to remove the dash to see them or have access to the removal diagram?

REWARD EXCELLENCE!

Add to performancebowl's Reputation
Rate the quality of this post and help performancebowl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
performancebowl is offline   Reply With Quote
Old 06-25-2015, 09:50 PM   #4
MikeNW
Master Member
MikeNW is just really niceMikeNW is just really niceMikeNW is just really niceMikeNW is just really niceMikeNW is just really nice
 
MikeNW's Avatar
 
Join Date: Apr 2008
Location: Lower Alabama= God's country, if God wanted mosquito and red ant bites, and to be covered in mildew
Posts: 3,244
 

1997 SL
Default Re: No heat

I don't know about the Sky in particular, but dash INSTALLATION takes minutes at the factory But any car I've worked on in my life was a living nightmare if it needed dash work....

...
97 SL. Born 6/5/97, bought 7/7/97
08 Burgman 400
02 Haro MTB- can't kill it, still trying though

The Schofield Kid: Yeah, well, I guess they had it coming.
Will Munny: We all got it coming, kid.

REWARD EXCELLENCE!

Add to MikeNW's Reputation
Rate the quality of this post and help MikeNW reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MikeNW is offline   Reply With Quote
Old 07-08-2015, 06:04 AM   #5
Begather
New Member
Begather is on a distinguished road
 
Join Date: Jun 2015
Posts: 2
Default Re: No heat

Quote:
Originally Posted by fdryer View Post
Try observing each actuator for movement before deciding on whether or not one is broken.
Agreed with you here.

REWARD EXCELLENCE!

Add to Begather's Reputation
Rate the quality of this post and help Begather reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Begather is offline   Reply With Quote
Old 03-26-2017, 08:15 PM   #6
macantley
Junior Member
macantley is on a distinguished road
 
Join Date: Mar 2017
Posts: 17
Default Re: No heat

yep, i agree, most likely the actuator motor or arm has failed.

REWARD EXCELLENCE!

Add to macantley's Reputation
Rate the quality of this post and help macantley reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
macantley is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no heat/lack of heat problem mr18436572 S-Series Tech 7 04-16-2015 10:01 PM
'04 Vue heat problems (no feet heat) PatrickMcD Vue Tech 5 01-24-2014 04:49 PM
"Heat shield rattle" without a heat shield Modding_out S-Series General 2 01-15-2014 10:58 PM
No Heat in my SC2 Sweetcheeks4565 S-Series Tech 3 01-25-2012 02:22 PM
No Heat in SW2 bluebunny524 S-Series Tech 4 10-18-2006 09:52 PM


All times are GMT -5. The time now is 06:38 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.