SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-27-2017, 09:54 AM   #1
nstewart1984
New Member
nstewart1984 is on a distinguished road
 
Join Date: Jan 2017
Posts: 2
Mad Transmission issue

Hi everyone Im a little late to the party but im hoping people are still looking on this forum.

I bought an 02 SL2 and when driving up a hill between 35-40 the car starts to jump around doing hard up and down shifting bad. If i drive in 3 instead of D it is perfect. Afriend told me I needed to replace my solenoids in the valve body and i did yesterday I just saw that there is a relearn process but I am not sure how to go about starting the process. any and all help would be amazing guys thank you in advance.

REWARD EXCELLENCE!

Add to nstewart1984's Reputation
Rate the quality of this post and help nstewart1984 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
nstewart1984 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-27-2017, 10:09 AM   #2
trottida
Senior Member
trottida is a glorious beacon of lighttrottida is a glorious beacon of lighttrottida is a glorious beacon of lighttrottida is a glorious beacon of lighttrottida is a glorious beacon of lighttrottida is a glorious beacon of light
 
trottida's Avatar
 
Join Date: Oct 2005
Location: North of North of Toronto, Northern Ontario, Canada
Posts: 1,771
 

1999 SL2
2001 SL1
Default Re: Transmission issue


...
Current rides
2001 SL1 MT (403,500 km @ 04/2017)
1999 SL2 MT (240,500 km @ 04/2017)
2005 Suburban Z71 (290,500 km @ 04/2017)

:canada:

REWARD EXCELLENCE!

Add to trottida's Reputation
Rate the quality of this post and help trottida reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
trottida is offline   Reply With Quote
Old 01-27-2017, 01:25 PM   #3
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,878

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Transmission issue

Disregard that Step 1 re: mode switch - I think that was eliminated in '98.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 01-27-2017, 08:42 PM   #4
gveinot
Member
gveinot is a jewel in the roughgveinot is a jewel in the roughgveinot is a jewel in the roughgveinot is a jewel in the rough
 
gveinot's Avatar
 
Join Date: Mar 2012
Location: Hammonds Plains
Posts: 290
 

2000 SL2
2000 SL2
Default Re: Transmission issue

you are supposed to remove the PCM B fuse and re-insert it to erase the memory in the engine computer. Once done the engine computer will re-learn the shift points and after a few drives the shift points will smoothen out. If you keep driving it as is the engine computer will re-learn the shift points, it just takes a little longer. I suggest you drive it easy until the shifts smoothen out. There are other posts giving more specifics on the re-learn. Just search PCM B fuse.

Last edited by gveinot; 01-27-2017 at 08:48 PM..

REWARD EXCELLENCE!

Add to gveinot's Reputation
Rate the quality of this post and help gveinot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gveinot is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission issue ManiXSC2 S-Series General 14 04-28-2015 01:29 PM
sl1 transmission issue evilavatar S-Series General 10 03-25-2012 12:21 PM
transmission issue Senior Aura General 5 05-29-2011 12:17 PM
Transmission issue, please help The Woodpecker S-Series Tech 4 06-06-2007 10:54 AM
Transmission Issue? 95_SC2_Guy Miscellaneous Tech 2 12-11-2002 12:53 AM


All times are GMT -5. The time now is 06:10 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.