SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Site Information > Community Center > Introductions & Greetings
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-10-2016, 11:41 AM   #1
SpaceVagon
Junior Member
SpaceVagon is on a distinguished road
 
Join Date: Sep 2016
Location: MD
Posts: 26
 

1999 SW2
Default Me and my newly running SW2

Hi, I'm hailing from Maryland and I just got a 99 SW2 running after swapping out a blown head. So far it's a nice little car, lots of room, and lots of work to keep me busy. 205k miles on it and hopefully many more to come.

So far my plans are to clean up the interior, find a new wheel cover to replace the missing one (or find some factory rims), remove the stickers, and install some OEM foglights.

I also would like to fix the peeling clearcoat, so if anyone has any tips on how to do this, I'd really appreciate it.

I'd post some pics but apparently I'm not allowed to post links yet lol. Hopefully soon.

REWARD EXCELLENCE!

Add to SpaceVagon's Reputation
Rate the quality of this post and help SpaceVagon reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SpaceVagon is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-10-2016, 12:47 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,317
 

2003 L-Series 3.0L Sedan
Default Re: Me and my newly running SW2

Welcome to Saturnfans! Read the stickies at the top of the S-series tech forums to have first hand info on things that fail with simple solutions. You'll find the remaining issues from many threads repeating the same problems from wear and tear for a wealth of free info second to none on any forum. Some here say better than dealers (none willingly reveal why things break).

As to pictures, links aren't needed. You may create your own picture album unless there's a delay until more posts are made (new member restrictions) or simply add them as thumbnails (the paperclip icon). A fair warning though - file size is restricted to 150 kb and easily exceeded by most digital cameras and cell phones with multiple megabyte pics failing to upload. The simple work around is to resize picture files and reformat to jpeg. I've had no trouble posting a megabyte size picture in JPEG format as thumbnails with many new members doing the same. "Size matters", resizing and formatting seems to work. Once done, previewing before posting ensures editing for grammar and pics are accepted will verify whatever a member wants to show.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-10-2016, 01:57 PM   #3
SpaceVagon
Junior Member
SpaceVagon is on a distinguished road
 
Join Date: Sep 2016
Location: MD
Posts: 26
 

1999 SW2
Default Re: Me and my newly running SW2

Thanks. I uploaded a couple resized photos to the gallery that I took this morning on a whim. However when I tried to post them on this thread it still said that I was linking to another site and that wasn't allowed.

VdShDWk - Imgur (1).jpg

J8Y4RnM - Imgur.jpg

QN1SOAf - Imgur (1).jpg


However using the paperclip seems to have worked

REWARD EXCELLENCE!

Add to SpaceVagon's Reputation
Rate the quality of this post and help SpaceVagon reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SpaceVagon is offline   Reply With Quote
Old 09-10-2016, 09:23 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,317
 

2003 L-Series 3.0L Sedan
Default Re: Me and my newly running SW2

Nice pics! Let this thread die and post a new one in the S-series tech forums with your questions. Members there are more likely to reply.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-10-2016, 11:18 PM   #5
SpaceVagon
Junior Member
SpaceVagon is on a distinguished road
 
Join Date: Sep 2016
Location: MD
Posts: 26
 

1999 SW2
Default Re: Me and my newly running SW2

Thanks, I will. You've been really helpful.

REWARD EXCELLENCE!

Add to SpaceVagon's Reputation
Rate the quality of this post and help SpaceVagon reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SpaceVagon is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newly found awesome u-pull it near me... MetalMatty S-Series General 11 09-15-2014 09:14 PM
Newly acquied 2000 LS1 ag_ghost Introductions & Greetings 0 02-13-2011 11:33 AM
Questions on my newly purchased Vue scott2683 Vue General 10 01-13-2009 08:50 AM
30K service on a newly owned 2000 SC2 Bigsmoker S-Series Tech 2 11-15-2002 12:01 PM
Tracking a newly shipped L300 2001SilverBlueL300 L-Series General 1 04-15-2001 04:01 PM


All times are GMT -5. The time now is 11:44 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.