SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-30-2016, 05:42 PM   #1
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Code P0733 - Shifting Problem - SL2 2002

2002 Saturn SL2

I've been browsing around this site looking for a possible solution to the shifting problem my car is currently exhibiting. Some of the posts sound similar to what my car is doing, but not exactly. Any advice you can offer would really be appreciated.

Current problem: harsh/jerky shift at 10 mph; then revs up and finally harsh/jerky shift again at 20 mph. Also, a little harsh shifting into reverse.

Previous similar problem: similar to the symptoms listed above, but the shifting was more of a BANG! It felt and sounded like the transmission was going to fall out right on the road. That problem was fixed by replacing the Pressure Control Solenoid (PCS).

What I've done so far:
-checked the fuses in the box under the hood
-checked the resistance on each of the 5 solenoids. They all registered 4.6 ohms, so I concluded that replacing the PCS wasn't going to fix the problem this time.
-took the car to the dealer for a diagnostic. Code P0733 Incorrect 3rd Gear Ratio (I guess that is what the revving up is about. That wasn't a symptom the last time). The dealer recommended replacing the PCS.
-replaced the solenoid connector plate instead (since the solenoids already tested as good, I thought the failed audible check could have been due to a damaged buss plate).
-cleaned connector harness with 99% isopropyl alcohol (I didn't have any contact cleaner, and there was quite a bit of fluid on the connector)
-replaced the battery (it was old, and one of the posts mentioned that an inconsistent connection to ground may degrade shift quality).

None of my actions has made a difference so far. I'm not sure what to do next. These are some ideas I have from reading the posts on this site. Please let me know your thoughts on my next steps.

1-Clean the connector harness again with proper contact cleaner (I'm going to buy WD-40 Specialist Electrical Contact Cleaner Spray. It's listed as safe on plastic, rubber, and metal).
2-Clean the Vehicle Speed Sensor (VSS)
3-Clean Transmission Temperature Sensor (TTS)
4-Get a used connector harness from the junkyard to replace the contaminated one
5-Buy a new Line Pressure Control Solenoid (it appeared to be good, but the dealer said this is the problem)
6-Replace the Valve Body (maybe from a dealer on eBay)

Thanks in advance for any advice you can provide.

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-02-2016, 10:08 AM   #2
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Welcome aboard - good job with the research. Since you have experience opening the VB, I would first try swapping the LP and 3rd Gear Solenoids with 2 of the others to see if anything changes.

Btw - ATF on that connector doesn't usually cause a problem - you are mostly concerned with overheated/burned contacts that are not making good contact.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 05-02-2016, 11:44 AM   #3
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Re: Code P0733 - Shifting Problem - SL2 2002

Thank you, Chazberry, for responding.

This weekend, I went to the junkyard and pulled a valve body assembly off of a 2002 SL series. I figured I could use the solenoids rather than buy new ones, or just swap that VB with mine. I haven't done anything with that yet.

I also read about pulling the PCM-B fuse, then driving through the gears a bit to reset. I thought I'd give that a try (I only changed the connector plate but thought that might require a reset since I didn't see any improvement after changing the plate).

Now I'm really worried. While out on my 45-minute drive through the neighborhood, accelerating and slowing to get through all the gears, I started hearing a grinding/scratching metal kind of sound during the harsh shift. Have I done irreparable damage, or could changing the solenoids or valve body still fix the problem?

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
Old 05-02-2016, 12:09 PM   #4
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Quote:
Originally Posted by MAC206 View Post
I also read about pulling the PCM-B fuse, then driving through the gears a bit to reset. I thought I'd give that a try (I only changed the connector plate but thought that might require a reset since I didn't see any improvement after changing the plate).
Pulling that fuse will not reset the "Adaptives" that the PCM learns . . .
http://www.saturnfans.com/forums/att...1&d=1328229444

If nothing changed with the Bus Plate swap, the original was probably OK, especially since your resistance readings were consistent.

Quote:
Originally Posted by MAC206 View Post
Now I'm really worried. While out on my 45-minute drive through the neighborhood, accelerating and slowing to get through all the gears, I started hearing a grinding/scratching metal kind of sound during the harsh shift. Have I done irreparable damage, or could changing the solenoids or valve body still fix the problem?
It's probably fixable. How many miles on this tranny? Has the ATF/Filter been maintained?

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 05-02-2016, 12:38 PM   #5
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Re: Code P0733 - Shifting Problem - SL2 2002

The transmission has 83,500 miles on it.

The fluid is nice and pink. I've taken the car to the dealer for all routine maintenance since I bought the car new in 2002, so I assume the fluid and filter have been maintained.

I've only resorted to DIY because the estimate from the dealer was way too high.

I'm about to go out and do a little work on the car this morning. Would you recommend...
1) swapping the LP and 3rd Gear Solenoids with 2 of the others,
2) swapping the solenoids from the junkyard valve body, or
3) replacing the valve body with the one from the junkyard?

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
Old 05-02-2016, 01:42 PM   #6
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Quote:
Originally Posted by MAC206 View Post
I'm about to go out and do a little work on the car this morning. Would you recommend...
1) swapping the LP and 3rd Gear Solenoids with 2 of the others,
2) swapping the solenoids from the junkyard valve body, or
3) replacing the valve body with the one from the junkyard?
I think I would take the 2nd and 4th Gear Solenoids from the JY VB and use those to replace your LP and and 3rd Solenoids. If that doesn't do it, then I would swap the whole VB.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 05-02-2016, 02:23 PM   #7
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Re: Code P0733 - Shifting Problem - SL2 2002

One thing I forgot to mention is a loose TCC solenoid. When I pulled the connector plate off to replace it, the TCC solenoid pins remained attached to the plate and the solenoid lifted out along with the plate. The other solenoids remained firmly seated in the valve body.

Is this anything to be concerned about?

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
Old 05-02-2016, 02:35 PM   #8
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Quote:
Originally Posted by MAC206 View Post
Is this anything to be concerned about?
Not really - but I think I would replace that Solenoid also.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 05-02-2016, 10:15 PM   #9
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Re: Code P0733 - Shifting Problem - SL2 2002

Thank you for your helpful advice.

I removed the 2nd, 3rd, and 4th gear solenoids from the junkyard valve body and put them in the LP, TCC, and 3rd gear slots on my valve body.

Test drive was smoother. No more scratching metal sound, no more hard shifts, just a little surge going into 3rd around 20 mph, but the rpms only got up to maybe 2200. Most of the other shifts happened around 2000 rpms.

I also added about a pint of Valvoline Dex/Merc transmission fluid. I didn't realize I needed fluid. Every time I checked the level, the dip-stick came out with fluid all over it, so I couldn't really tell how much was in there. I finally noticed 2 little holes near the end of the stick. The lower hole had fluid in it, but the higher hole didn't. I added fluid about 1/3 cup at a time until I noticed fluid filling the 2nd hole within the hash mark area.

I read my owner's manual, and I discovered that 100,000 miles is when the ATF and filter change are recommended. However, I drive mostly in stop-and-go city traffic, and I rarely go over 45 mph. I also live at the bottom of a hill, so my car climbs the hill every time I leave the house. The owner's manual states that under those conditions, the ATF and filter should have been changed at 50,000 miles. Reading through all of my service invoices, it doesn't look like this has ever been done, just topped off.

Next steps:
1) have ATF and filter changed at the dealer

Need further advice on what to do about the surge that has replaced the slip into 3rd gear. Any ideas?

Last edited by MAC206; 05-02-2016 at 10:27 PM..

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
Old 05-02-2016, 11:21 PM   #10
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Quote:
Originally Posted by MAC206 View Post
Need further advice on what to do about the surge that has replaced the slip into 3rd gear. Any ideas?
See if it goes away with a fluid change and some relearn.

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 05-04-2016, 01:44 PM   #11
MAC206
New Member
MAC206 is on a distinguished road
 
Join Date: Apr 2016
Location: Washington State
Posts: 6

2002 SL2
Default Re: Code P0733 - Shifting Problem - SL2 2002

Thanks again, Chazberry. Everything's back to normal.

I had the transmission fluid and filter changed this morning. Then I drove around gently for ~25 miles. The car is driving smoothly again.

I appreciate your help.

REWARD EXCELLENCE!

Add to MAC206's Reputation
Rate the quality of this post and help MAC206 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MAC206 is offline   Reply With Quote
Old 05-04-2016, 01:47 PM   #12
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,887

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: Code P0733 - Shifting Problem - SL2 2002

Quote:
Originally Posted by MAC206 View Post
Thanks again, Chazberry. Everything's back to normal.
Good to hear! Pretty low cost fix, I guess?

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 SL1 with P0733 code Beast of Busco S-Series Tech 0 12-01-2012 06:51 PM
trans fault p0733 not shifting 3rd gear johnyrrr S-Series Tech 1 09-12-2012 01:04 PM
2002 sl1 code P0733 ffunluving S-Series General 2 01-17-2011 05:25 PM
Shifting problem with my 2002 SC2. LOTYBOY S-Series Tech 7 01-07-2011 10:25 AM
Help with code P0733 acemolandsgal S-Series Tech 5 08-05-2009 08:17 PM


All times are GMT -5. The time now is 01:21 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.