SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 03-12-2012, 08:12 PM   #1
matthew123
New Member
matthew123 is on a distinguished road
 
Join Date: Feb 2012
Posts: 8
Default 94 Saturn SL2 won't accelerate over 40 mph

So my sl2 had its fuel filter, ICM, engine coolant temp sensor and the crankshaft sensor all replaced but just recently it started to accelerate really sluggishly and and won't accelerate at all over 40 mph. Its also burning through fuel and running rich. I tried pulling out the O2 sensor but no change. I tried replacing the ignition coils but now it idles rough and still has the same problem.

REWARD EXCELLENCE!

Add to matthew123's Reputation
Rate the quality of this post and help matthew123 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
matthew123 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-13-2012, 10:35 AM   #2
chong
Member
chong is on a distinguished road
 
Join Date: Mar 2012
Location: Ann Arbor, MI
Posts: 124

2002 SL2
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

I had similar symptoms on an 01 Monte Carlo. For me it turned out to be a plugged cat.

REWARD EXCELLENCE!

Add to chong's Reputation
Rate the quality of this post and help chong reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
chong is offline   Reply With Quote
Old 03-13-2012, 10:42 AM   #3
BV22
Master Member
BV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of light
 
Join Date: Feb 2011
Location: Texas
Posts: 2,048

2002 SC1
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

Please clarify a couple of things. Did you remove the "front" O2 sensor and drive the car with it out? Did you replace the 2 wire coolant sensor, not the single wire one? Where does your temperature gauge read when the car is warmed up?

...
BV22
2002 SC1 5M
294k 07/17

REWARD EXCELLENCE!

Add to BV22's Reputation
Rate the quality of this post and help BV22 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BV22 is offline   Reply With Quote
Old 03-13-2012, 01:56 PM   #4
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

'94 has only the front O2 sensor.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 03-13-2012, 02:40 PM   #5
BV22
Master Member
BV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of light
 
Join Date: Feb 2011
Location: Texas
Posts: 2,048

2002 SC1
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

Oops - '94 is indeed pre-OBDII.

...
BV22
2002 SC1 5M
294k 07/17

REWARD EXCELLENCE!

Add to BV22's Reputation
Rate the quality of this post and help BV22 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BV22 is offline   Reply With Quote
Old 03-13-2012, 03:04 PM   #6
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,231
 

1998 SC2
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

Quote:
Originally Posted by matthew123 View Post
So my sl2 had its fuel filter, ICM, engine coolant temp sensor and the crankshaft sensor all replaced but just recently it started to accelerate really sluggishly and and won't accelerate at all over 40 mph. Its also burning through fuel and running rich. I tried pulling out the O2 sensor but no change. I tried replacing the ignition coils but now it idles rough and still has the same problem.
How old are the ignition wires and what brad of plugs and how old?

It does sound like a seriously restricted exhaust.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Old 03-13-2012, 03:42 PM   #7
matthew123
New Member
matthew123 is on a distinguished road
 
Join Date: Feb 2012
Posts: 8
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

I did drive it with the O2 sensor out, no improvement. Just replaced the spark plugs and wires and also checked the coolant sensor wire which seems fine. The temp gauge reads normal as the car warms up, no different then it was before when the car was fine. I've been hearing a lot that it is a plugged cat, i'll try the hammer test tonight and see. Thanks for the help.

REWARD EXCELLENCE!

Add to matthew123's Reputation
Rate the quality of this post and help matthew123 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
matthew123 is offline   Reply With Quote
Old 03-13-2012, 04:06 PM   #8
BV22
Master Member
BV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of lightBV22 is a glorious beacon of light
 
Join Date: Feb 2011
Location: Texas
Posts: 2,048

2002 SC1
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

If the cat were plugged, the car should have run better with the O2 sensor removed - it provides an alternate path for the exhaust to escape. I think I'd check the fuel pressure at the test port near the rail and see if you get odd readings before condemning the cat. Hammer test is harmless though, and might tell you something.

...
BV22
2002 SC1 5M
294k 07/17

REWARD EXCELLENCE!

Add to BV22's Reputation
Rate the quality of this post and help BV22 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BV22 is offline   Reply With Quote
Old 03-13-2012, 05:46 PM   #9
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,231
 

1998 SC2
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

The removal of an O2 sensor is not a definitive test. It is only an indicator. The problem could also be a collapsed muffler or resonator.

Do not use a hammer on the cat, just hit it with the palm of your hand and this test only finds a broken up cat block.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is online now   Reply With Quote
Old 05-31-2015, 01:29 PM   #10
scottie
New Member
scottie is on a distinguished road
 
Join Date: May 2015
Posts: 2
Default Re: 94 Saturn SL2 won't shift or go over 34 its doing the same as the last swap

ok i have a saturn that is made in 11/93 and the vin is 1g8zh5598rz198110
i parked the car originally because it slipped in 3rd and thats where the heartache came in i bought i bought 2 trans and put them in and it wont go over 35 when i take it off the stands but on the stands i can get it to shift perfectly one time then it loses power andfalls back to 25 and will not shift again unless i erase the codes and cut it off then it will once again do it please help me i built the motor and its a wonderful car

REWARD EXCELLENCE!

Add to scottie's Reputation
Rate the quality of this post and help scottie reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
scottie is offline   Reply With Quote
Old 06-01-2015, 03:59 AM   #11
2NDSOUT
Master Member
2NDSOUT is a jewel in the rough2NDSOUT is a jewel in the rough2NDSOUT is a jewel in the rough2NDSOUT is a jewel in the rough
 
2NDSOUT's Avatar
 
Join Date: Sep 2000
Location: Cincinnati, Ohio
Posts: 7,092
 

1994 SL2
1999 SL
Default Re: 94 Saturn SL2 won't accelerate over 40 mph

Is the transmission in the cars a manual transmission? That has not been clarified in any posts so far. If it is a manual transmission and you are shifting through all the gears and only getting up to 35-40 mph...the clutch is worn out. I had a similar issue a few years back, along with a burning brake type smell and the clutch and pressure plate were completely worn.

...
Bryan

94SL2 HCE, "Pearl"

99 SL

94SL2 260K Miles
1/15

97SW2 266K Miles
2/15

Always
94SC1 340,501 Miles
Org. Engine/Auto Trans
2/97-10/08
Gone 3/12

92SL1
05VUE
91SC

REWARD EXCELLENCE!

Add to 2NDSOUT's Reputation
Rate the quality of this post and help 2NDSOUT reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
2NDSOUT is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 sl2 won't accelerate over 40 mph matthew123 Support Forum for Canadian Saturn Owners 12 09-27-2012 05:43 PM
2008 Saturn Aura Won't Accelerate pop.delgadio Aura General 11 01-03-2012 02:44 PM
2001 Saturn L200 - Loss of power-bogs out when attempting to accelerate. matousek L-Series Tech 13 09-27-2011 03:51 PM
GM to Accelerate Saturn Shutdown to This Year If No Buyer Found Charlie General Saturn Discussion 0 04-27-2009 10:25 PM
does not accelerate! carlspees Ion Tech 2 11-25-2007 08:14 PM


All times are GMT -5. The time now is 09:45 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.