SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-25-2014, 06:21 PM   #1
lvlsabovesecret
New Member
lvlsabovesecret is on a distinguished road
 
Join Date: Nov 2014
Posts: 4

2001 SL2
Dizzy sl2 won't fire up

Hello all!
I'm new here but been lurking for a while. I bought a 2001 sl2 5 speed with 144,000 miles on it from a guy for 50 bucks because he said it was running rough.checked and and replaced the ects and sure enough the old one looked like it went 10 rounds with rocky (not rocky in the latest movie but the in shape rocky) immediately after replacing and attempting to start it up I got the clikity click from the starter so I replaced that a few days later. I tried to start it after that and it cranks nice and strong but fails to start. Before starter replacement I could hear fuel pump priming and now I can't. Security light stays on. Doesn't flash or anything. My only key is very worn and have to shake key and steering wheel to get it to turn. Tried the 30 min relearn thing but got nothing maybe I did it wrong but I had cluthch n and let it crank once before letting sit in run for 10 min. Just need some help with this. Getting new key from dealer tomorrow but wanna know what to do if that won't fix my issues. I use to be a mechanic before I join the army so don't be afraid to lay down the details.

REWARD EXCELLENCE!

Add to lvlsabovesecret's Reputation
Rate the quality of this post and help lvlsabovesecret reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lvlsabovesecret is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-25-2014, 10:26 PM   #2
littlejohn2458
New Member
littlejohn2458 is on a distinguished road
 
Join Date: Nov 2014
Posts: 4
Default Re: sl2 won't fire up

This is what i did and itworks wonders.

Step 1. Turn key to the ON (do not crank) position till the security light goes off. (10 mins)

Step 2. Turn the key to the off position (wait 5 sec)

Step 3. Turn key to the ON position (DO NOT CRANK ENGINE) and wait for security light to go off. (10 Mins)

Step 4. Repeat steps 1 and 2 one more time.. 30 mins total. Then it should start up.


easy peasy nice and easy

REWARD EXCELLENCE!

Add to littlejohn2458's Reputation
Rate the quality of this post and help littlejohn2458 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
littlejohn2458 is offline   Reply With Quote
Old 11-25-2014, 11:06 PM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,001
 

2003 L-Series 3.0L Sedan
Default Re: sl2 won't fire up

Somewhere in your troubleshooting, the first time you tried the 30 minute relearn procedure, it failed requiring a second try. Successfully performing a 30 minute relearn procedure is crucial to performing the electronic synch functions required to allow Passlock (GM's factory immobilizer/theft deterrent system) to operate correctly. You were patient enough to perform a second attempt and succeeded.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-26-2014, 04:39 PM   #4
lvlsabovesecret
New Member
lvlsabovesecret is on a distinguished road
 
Join Date: Nov 2014
Posts: 4

2001 SL2
Default Re: sl2 won't fire up

Okay so i m pretty sure I figured out what I did wrong on the relearn procedure and got the security light to go away. I am still gonna get a new key to be safe cause something about taking the key out while driving doesn't seem right lol. But I also discovered I may have a battery drain somewhere so I'm gonna get the battery tested first and start hunting for a hot wire. Any common places to check first?

REWARD EXCELLENCE!

Add to lvlsabovesecret's Reputation
Rate the quality of this post and help lvlsabovesecret reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lvlsabovesecret is offline   Reply With Quote
Old 11-26-2014, 08:16 PM   #5
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,001
 

2003 L-Series 3.0L Sedan
Default Re: sl2 won't fire up

If its not too late to warn you, its been said to make new keys using the VIN and not copying an old worn out key that results in the same worn key pattern cut into a new key made from automated key cutting machines. GM can make new keys using your VIN.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-26-2014, 10:12 PM   #6
lvlsabovesecret
New Member
lvlsabovesecret is on a distinguished road
 
Join Date: Nov 2014
Posts: 4

2001 SL2
Default Re: sl2 won't fire up

Well I got security light to go off. Had to jump it and it cranked but am getting no fuel. Can't hear fuel pump priming engine either. Check fuses and they were all good from what I can tell. Checked valve on fuel rail and no fuel came out. Fuel pump was working fine before I replaced ects and reset the security. This is driving me nuts what the heck do I do now? The fuel pump should be good something just isn't engaging it.

REWARD EXCELLENCE!

Add to lvlsabovesecret's Reputation
Rate the quality of this post and help lvlsabovesecret reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lvlsabovesecret is offline   Reply With Quote
Old 11-26-2014, 11:52 PM   #7
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,001
 

2003 L-Series 3.0L Sedan
Default Re: sl2 won't fire up

Well, $50 bought a fixer upper and you're now knee deep in it. WIth 144k miles and an intermittent fuel pump problem, there may be several problems to eliminate. Hearing the pump run intermittently may indicate either a worn out pump or wiring. A quick way to see if powering the pump fails from either pump fault or wiring - temporarily wire a jumper across the pump relay terminal sockets 30 and 87 (as shown in the drawing below). This bypasses the entire ignition system, powers the fuel pump immediately regardless of ignition switch position, and allows troubleshooting the fuel system. Wiring between relay and pump never seems to be a problem but the pump and pump ground are two likely trouble items. Pump ground connection is the easier choice to check for severe corrosion, preventing pump operation. Bypassing the EFI system with a wire jumper allows pump troubleshooting. Pump ground is either in the right rear passenger quarter panel or rear brake wiring. A ground splice pack joins several ground wires together to strategic ground studs placed all around the chassis.

Be sure the pump fuse and relay are in good condition, swapping parts if in doubt.
Attached Images
File Type: jpg 87A relay pin outs.jpg (27.5 KB, 1 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 11-27-2014, 12:07 AM   #8
lvlsabovesecret
New Member
lvlsabovesecret is on a distinguished road
 
Join Date: Nov 2014
Posts: 4

2001 SL2
Default Re: sl2 won't fire up

Just used a jumper in place of the relay as suggested and I can hear the pump run the instant I plug in the jumper. So does this mean new relay? I tried the blower motor relay but no cigar.

REWARD EXCELLENCE!

Add to lvlsabovesecret's Reputation
Rate the quality of this post and help lvlsabovesecret reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lvlsabovesecret is offline   Reply With Quote
Old 11-27-2014, 12:57 AM   #9
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,001
 

2003 L-Series 3.0L Sedan
Default Re: sl2 won't fire up

Forgive me for not adding; if you hear the pump run, try starting as fuel pressure is now available for the EFI system to inject fuel. While a little hazardous this way with the pump running instead of shutting off when the engine is shut down, you can still disconnect the wire jumper before or after shutting off the engine. This way you know the engine will run with a temporary bypass on fuel pump wiring. What's left is troubleshooting the command signal from the pcm to turn on the pump, relay terminal 86. This command is used twice; a two second timer from the pcm commands the pump to run at ignition ON and again as the engine starts/runs. You can try measuring terminal 86 for the 12v signal each time ignition is turned ON. If not terminal 86, 85. Turning the ign switch with the starter cranking should also send the pump command signal.

Be sure all fuses are checked. And to ensure the EFI system is operating, try a spark test.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
still cant get it to fire :/ Cory S-Series Tech 10 04-08-2012 05:28 PM
Car Fire chris2121 S-Series General 7 04-03-2009 04:40 AM
Please help - before I set it on fire slik S-Series Tech 5 11-15-2008 11:05 AM
SPS is on fire! THX712517 Ion General 0 09-27-2003 01:00 PM
I just might set fire to my 92 SL2 xpence S-Series Tech 1 05-07-2002 12:45 PM


All times are GMT -5. The time now is 10:51 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.