SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-29-2013, 12:46 PM   #21
martensitic
Junior Member
martensitic is on a distinguished road
 
Join Date: Nov 2011
Location: Brooklyn, NY
Posts: 43

1996 SL1
Default Re: Recurring P0122 after dealer TPS replacement

Thanks, I guess I will dig out the PCM and take a look. Need to lift the dash pad for that correct? I did have a mouse chew through an ECTS wire under the hood a while back, if there's some half-chewed-through TPS wire somewhere I haven't seen it but who knows. Tugging at the wires and harness under the hood did not seem to cause a fault, or solve one once it started.

For the record, I cleaned the base of the ignition module and the secondary on each coil pack was an acceptable 8k ohms, seems fine.

Battery is 12v off, 13.6v at idle. The latter seems a bit low perhaps.

And my Sony stereo is bricked after 2 years on the job, harness is alive but receiver is not. 1 year warranty, figures.

...
1996 Saturn SL1 SOHC, A/T, 116k, NYC

REWARD EXCELLENCE!

Add to martensitic's Reputation
Rate the quality of this post and help martensitic reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
martensitic is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-16-2013, 04:14 PM   #22
martensitic
Junior Member
martensitic is on a distinguished road
 
Join Date: Nov 2011
Location: Brooklyn, NY
Posts: 43

1996 SL1
Default Re: Recurring P0122 after dealer TPS replacement

Well, my latest proddings seem to have put this to bed for now, though I did not find a specific culprit. Did the following:

-Removed TB and TPS, IAC, MAP, cleaned all.

-Repaired nascent vacuum leak at hard plastic hoses at top of TB. One was cracked and the other was spinning loose in the rubber manifold. Potted them into the manifold using a tape dam and hot glue, airtight. (I probably caused this during one of my TPS troubleshootings.)

-Back-probed all three TPS lines with straight pins up the rear of the connector housing. All seemed OK. The +5V line was more like +4.6V (key on engine off).

-Disconnected all harnesses from PCM under dash. Traced out the three TPS lines, and poked at the corresponding harness terminals to "re spring" them just a little. Reconnected.

Could be that last one improved a sketchy connection, maybe someone accidentally kicked at a PCM harness under there at some point. If a simple disconnect/reconnect of a connector inside the passenger compartment would have fixed the problem all this time, I'd rather not know.

Thanks all

...
1996 Saturn SL1 SOHC, A/T, 116k, NYC

REWARD EXCELLENCE!

Add to martensitic's Reputation
Rate the quality of this post and help martensitic reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
martensitic is offline   Reply With Quote
Old 10-16-2013, 05:13 PM   #23
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,262
 

1998 SC2
Default Re: Recurring P0122 after dealer TPS replacement

Yes, back probing can result in springing the blade slightly which fixes an intermittent connection.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacement flexplate from dealer only? rocketdog S-Series General 5 01-23-2011 08:41 PM
Need Help with Error P0122 Kas S-Series Tech 0 05-17-2010 11:05 PM
Error P0122 Kas L-Series Tech 1 05-17-2010 04:58 AM
OBDII code P0122? chickensaw Miscellaneous Tech 3 09-28-2004 10:55 PM
TPS code P0122 Spanky S-Series Tech 4 08-09-2003 07:18 PM


All times are GMT -5. The time now is 11:19 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.