SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-24-2013, 01:49 AM   #1
icy
New Member
icy is on a distinguished road
 
Join Date: Jun 2012
Posts: 7
Mad weird egr valve problem

Im not sure if i may have horrible luck but in one week i went through 3 brand new egr valves. They keep goving code p1404 egr valve pintle stuck open, but theres no carbon on them at all. Could it be possible the electric connector on the top is bad? It was exposed to a little water but i gave it 4 hours to dry before starting the car. If that sensor connector thingy is bad can i get one from autozone or would i have to go to the dealer. Also is there anything that can make an egr valve fail like another part? I tryed searching but cant find s similar problem. Its a 1998 saturn sl2 5 speed manual with 147500 miles each valve lasts about 10 key cycles before throwing codes and giving slight rough idle bounces from 750 rpms to 650ish then back up randomly except in cold weather then idles perfect.

REWARD EXCELLENCE!

Add to icy's Reputation
Rate the quality of this post and help icy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
icy is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-24-2013, 09:13 AM   #2
PlasticCarsRock
Master Member
PlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the rough
 
PlasticCarsRock's Avatar
 
Join Date: Dec 2005
Location: Brookline, MA
Posts: 4,317
 

1995 SL2
Default Re: weird egr valve problem

Have you tried cleaning and re-using your original OE valve? Some aftermarket products are notoriously unreliable, although it seems like there may be more to this.

If you pull the valve (gently) immediately after the code sets, is the pintle actually stuck open?

...
High compression build: .033" shaved/ported head, flat-faced valves; gen3 rods, pistons, tie-plate; OE header, custom CAI, SDA street cams with adjustable sprockets, WBO2, SAFCII, LSD. ASE A1-A8+L1

REWARD EXCELLENCE!

Add to PlasticCarsRock's Reputation
Rate the quality of this post and help PlasticCarsRock reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PlasticCarsRock is offline   Reply With Quote
Old 02-24-2013, 09:31 AM   #3
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,256
 

1998 SC2
Default Re: weird egr valve problem

Get a can of CRC QD-Electronics Connection Cleaner and spray out teh connector and socket. Reinstall the original valve. P1404 - EGR valve circuit performance - Actual greater than commanded. <--- copied from the 98 FSM Powertrain control section.

It is not stuck open, it is just not returning to the PCM learned full closed position as sensed by the PCM. This is determined by the PCM monitoring a changing resistance value as the valve closes or opens. Any dirty or loose connection will cause this code randomly. The connector is either shot or dirty. First thing to do is spray it out, let it dry and see what happens.

After cleaning and reconnecting valve Pull the PCM B fuse to clear out the previously learned position and any codes. Leave fuse out about 1 minute and then replace.

If it turns out to be a connector issue the cheap way to replace it is to go to the pick and pull and cut off a new one and just solder it into your car.

This P1404 is a common problem and is usually a connector issue if a new valve did not fix it.

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Old 02-24-2013, 09:54 AM   #4
icy
New Member
icy is on a distinguished road
 
Join Date: Jun 2012
Posts: 7
Default Re: weird egr valve problem

Thank you guys thats just another little part thats broke then. Ill have my mechanic change it monday.

REWARD EXCELLENCE!

Add to icy's Reputation
Rate the quality of this post and help icy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
icy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: Weird no-start-shift lock problem vstringbassist Ion Tech 8 12-09-2012 12:55 AM
Weird problem! johnk3332 S-Series General 13 04-15-2012 05:46 PM
Clacking under valve cover. Bad and weird sound - Please help! phonic S-Series Tech 3 08-17-2008 08:24 PM
Weird Problem SlimDan22 S-Series Tech 13 07-29-2008 02:54 PM
Weird problem sc2095 S-Series Tech 8 02-20-2004 04:04 PM


All times are GMT -5. The time now is 05:42 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.