SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Site Information > Community Center > Introductions & Greetings
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 02-09-2013, 10:41 PM   #1
Nazvil86
New Member
Nazvil86 is on a distinguished road
 
Join Date: Feb 2013
Location: Austin, Tx
Posts: 3

1998 SC2
Default New Frustrated Saturn Owner haha

Well my names Bobby- came across your site trying to diagnose some issues I'm having with a car I just recently purchased. First a lil aobut myself- I'm an "ex" Honda guy, Ive had my fair share of civics, integras, swapped motors, etc etc- had fun but was getting tired of worrying if my car would be in the parking lot when I got back. So I sold my 2000 Civic Si with a JDM Integra Type R swap, saw this 1998 Saturn "Wagon" for sale the next day, emailed the guy and got a speedy response. The car was automatic, had no "known" issues and was sworn the car would be a great commuter car- which was exactly what I needed.

Well not even a week later Ive started running into issues. First issue, about to leave work and noticed the light for "low coolant/transaxle fluid" light came on...freaked out but read all I had to do was pour in some coolant and turn the car back on- yep light went away. BUT as I was leaving work after my shift the car just died on me- completely, pulled over- popped the hood, there was gas, car wasn't over heating, nothing. i wiggled the battery cables and noticed they were loose...after I did that the car started up again, drove less then a mile then it shut down again. I left it there over night and got back earlier. Got some jumper cables- connected everything, car had power (all lights on, radio on, no dim lights at all) but the car just would NOT crank over. After pulling the cables off the car I tried cranking it over again and it just got weaker and weaker then wouldn't click over at all.

After doing a bit of reading on here I read it could be the ECTS? The "SES" light has come on since then- but, as luck would have it, about a week ago my girlfriends vehicle had the transmission give out on us haha oh its been a great couple of weeks. So its just been a frustrating - thinking I should have stayed with Hondas lol.

I honestly deserve what I'm getting, i bought it on impulse but had it checked locally and everything checked out. I do like it, its completely different from anything Ive owned previously and when it was working it was getting great mileage, and is pretty roomy and comfy inside- which is why I think I wanted a wagon in the first place. Anyways sorry for the novel- lol I have a bit of a problem with rambling.

btw- tried to post a picture of the car but apparently I need to wait til I hit 15 posts. hah

REWARD EXCELLENCE!

Add to Nazvil86's Reputation
Rate the quality of this post and help Nazvil86 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Nazvil86 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-10-2013, 12:15 AM   #2
Signmaster
Master Member
Signmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to allSignmaster is a name known to all
 
Join Date: Jan 2007
Location: Virginia Beach, VA
Posts: 5,900
 

1995 SL1
Default Re: New Frustrated Saturn Owner haha

Just pop into the S Series forums and your problems will be solved... just let everyone know what the problems are. And if it's a wagon, it's an SW2, not an SC2.

Most issues on the S Series cars are fairly easy to fix, and there are a lot of helpful people in the forums. Don't give up on the car until you sort it out, they are inexpensive commuters and fun cars.

REWARD EXCELLENCE!

Add to Signmaster's Reputation
Rate the quality of this post and help Signmaster reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Signmaster is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I put my Saturn on your roof running from the cops. HAHA! bobyjones S-Series General 7 01-08-2012 08:35 PM
code 22 haha rectifryer S-Series Tech 2 07-12-2006 05:13 PM
Haha! swzine L-Series General 4 12-07-2003 11:10 PM
HAHA! I figured it out! ProDarwin Miscellaneous Tech 12 09-17-2003 03:30 PM


All times are GMT -5. The time now is 12:27 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.