SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 05-11-2012, 08:02 PM   #1
madion34
New Member
madion34 is on a distinguished road
 
Join Date: May 2012
Posts: 2
Attention 2000 SC2 Issues

Hey everyone--

I have a 2000 SC2 with a couple of issues that are really concerning me. It rumbles REALLY bad if I'm at a stoplight or idling. It also has a bit of trouble accelerating. The service engine soon light just came on and I'm getting the codes P0506 -- P0303 -- P1404. About 2 months ago I had this exact same problem (rumbling etc). Got P0303 and after changing out the spark plugs the check engine soon light went away and ran fine til now. Any ideas of what the problem is now? It might be the spark plugs again, but I have a feeling it's a vacuum leak (among other things). All help is appreciated! Thanks!

REWARD EXCELLENCE!

Add to madion34's Reputation
Rate the quality of this post and help madion34 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madion34 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-11-2012, 08:16 PM   #2
Highmile
Senior Member
Highmile will become famous soon enoughHighmile will become famous soon enough
 
Highmile's Avatar
 
Join Date: Mar 2001
Location: St. Louis, Mo.
Posts: 1,033

1995 SL1
Default Re: 2000 SC2 Issues

What plugs did you put in?

Highmile
'95 SL1 483k and counting

...
Highmile
95 sl1 496k (rebuilt engine)

REWARD EXCELLENCE!

Add to Highmile's Reputation
Rate the quality of this post and help Highmile reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Highmile is offline   Reply With Quote
Old 05-11-2012, 08:33 PM   #3
madion34
New Member
madion34 is on a distinguished road
 
Join Date: May 2012
Posts: 2
Default Re: 2000 SC2 Issues

I just used factory replacements. I'm wondering if it might be the wiring to the spark plugs- maybe it's getting a bad connection on one of them??

REWARD EXCELLENCE!

Add to madion34's Reputation
Rate the quality of this post and help madion34 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madion34 is offline   Reply With Quote
Old 05-11-2012, 08:50 PM   #4
lil_buddy
Advanced Member
lil_buddy has a spectacular aura aboutlil_buddy has a spectacular aura aboutlil_buddy has a spectacular aura about
 
Join Date: Aug 2009
Location: san jose, ca
Posts: 637
 

1997 SC1
Default Re: 2000 SC2 Issues

go ahead and get new wires (if it has been a few years) and make triple sure they are connected to the coils right.

take off the icm/coils and clean all the metal parts. Switch the coils to see if the misfire code moves to a diff cylinder.

Clean throttle body with special attention to the IAC.

Clean egr.

At what rpm are you idling (hot & cold)?

REWARD EXCELLENCE!

Add to lil_buddy's Reputation
Rate the quality of this post and help lil_buddy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lil_buddy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 LS1 ignition/fan issues away8907 L-Series Tech 14 05-28-2012 08:14 PM
2000 LS1 ignition/fan issues away8907 S-Series Tech 3 04-07-2012 11:29 AM
2000 SC-1 Start Issues EddieEX S-Series Tech 3 07-12-2010 06:25 PM
2000 SL2 Start/Run Issues lxvgto S-Series Tech 16 07-18-2008 11:21 AM
2000 LS2 Milage Issues solomonsd21 L-Series Tech 9 01-15-2008 01:02 AM


All times are GMT -5. The time now is 09:49 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.