SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 05-06-2012, 08:55 PM   #1
robby562
Junior Member
robby562 is on a distinguished road
 
Join Date: Sep 2011
Posts: 17

2000 SL2
Default Horn not working

I have a 2000 Saturn SL2 and the horn has never worked since I got it used. Never needed it really but I thought I should look into it.

Horn doesn't work and when I push on the steering wheel, I heard a clicking noise coming from the horn relay located in the fuse box under the hood.

So would I need a new relay or horn?

REWARD EXCELLENCE!

Add to robby562's Reputation
Rate the quality of this post and help robby562 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
robby562 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-06-2012, 09:09 PM   #2
robby562
Junior Member
robby562 is on a distinguished road
 
Join Date: Sep 2011
Posts: 17

2000 SL2
Default Re: Horn not working

I read I can swap the horn relay with one of the other relays such as the AC to test it but I wasn't too sure if it was removable and didn't want to mess with it.

I'm not car savvy.

REWARD EXCELLENCE!

Add to robby562's Reputation
Rate the quality of this post and help robby562 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
robby562 is offline   Reply With Quote
Old 05-06-2012, 09:22 PM   #3
cityhawk
Senior Member
cityhawk has a spectacular aura aboutcityhawk has a spectacular aura aboutcityhawk has a spectacular aura about
 
cityhawk's Avatar
 
Join Date: Feb 2000
Location: Boston
Posts: 1,938
 

1993 SW2
2001 L-Series 3.0L Wagon
Default Re: Horn not working

Yes, you can swap the relays for testing purposes. I used the horn relay to test my cooling fan. I do know that the underhood relay/fuse box looks different on the later S-series than it does on my gen 1 1993. However, just find a relay that looks the same and try it out (on the gen 1's the horn and fan relays are interchangeable). They just pull out/unlplug with a little gentle wiggling. You shouldn't have to use too much effort.

...
Saturns:
1993 SW2 MT 135,000 hard Boston city miles
2001 LW300
Gone but not forgotten: 1999 SW2 MT
Project cars:
1966 Corvair Monza convertible
1928 Ford Model A Tudor Sedan

REWARD EXCELLENCE!

Add to cityhawk's Reputation
Rate the quality of this post and help cityhawk reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
cityhawk is offline   Reply With Quote
Old 05-06-2012, 11:08 PM   #4
PurdueGuy
Master Member
PurdueGuy is a jewel in the roughPurdueGuy is a jewel in the roughPurdueGuy is a jewel in the rough
 
PurdueGuy's Avatar
 
Join Date: Feb 2005
Location: Blackfoot, ID
Posts: 6,448

1999 SC2
1999 SC1
Default Re: Horn not working

I believe '00 was the first year they went back to the 2-wire horn, which is a good thing. Do you have keyless entry? If so, hitting lock repeatedly would normally honk the horn on the 2nd lock (though hitting it very rapidly might take several presses before it would honk). Just another way of testing the horn, in case the button on the steering wheel were broken. Do the relay swap & test. could be a bad horn, and since it's a 2-wire (unless I'm remembering the years wrong), you can use pretty much any aftermarket horn with little to no modification.

...
SaturnSeries.net owner

REWARD EXCELLENCE!

Add to PurdueGuy's Reputation
Rate the quality of this post and help PurdueGuy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PurdueGuy is offline   Reply With Quote
Old 05-08-2012, 12:55 PM   #5
robby562
Junior Member
robby562 is on a distinguished road
 
Join Date: Sep 2011
Posts: 17

2000 SL2
Default Re: Horn not working

Switched the relays and still didn't work, even when pressing the key fob you just hear a clicking noise so I'm guessing the horn is dead.

REWARD EXCELLENCE!

Add to robby562's Reputation
Rate the quality of this post and help robby562 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
robby562 is offline   Reply With Quote
Old 05-08-2012, 09:11 PM   #6
mattwithcats
Advanced Member
mattwithcats is on a distinguished road
 
Join Date: May 2011
Location: Portsmouth, Virginia
Posts: 838

2002 SL2
1998 SL2
Default Re: Horn not working

Replace with a Wolo Bad Boy,

Loud as heck, 120 db...

http://www.amazon.com/Wolo-Model-419.../dp/B000F5DQWY

REWARD EXCELLENCE!

Add to mattwithcats's Reputation
Rate the quality of this post and help mattwithcats reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mattwithcats is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horn Not working gdlvnman S-Series General 8 11-16-2011 12:30 PM
02 Vue Horn not working Andyec Vue General 1 03-28-2011 09:37 PM
Horn not working tom_94305 S-Series Tech 3 08-27-2010 01:05 PM
'02 VUE Horn NOT Working dpware Vue General 7 04-19-2010 01:27 PM
Horn not working hlp plz! Salsa88 S-Series Tech 12 12-27-2007 11:38 PM


All times are GMT -5. The time now is 07:32 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.