SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Sky > Sky Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-10-2012, 10:19 AM   #1
ToledoEngineer
Member
ToledoEngineer is on a distinguished road
 
ToledoEngineer's Avatar
 
Join Date: Oct 2005
Location: Toledo, Ohio
Posts: 239
 

2008 SKY Red Line
1992 SL1
Default Ecs off

So about two months ago I started having trouble with my Traction Control light coming on and stating that my ESC (Electronic Stability Control) was turning itself off. Which was something rather new top see. You can turn off the Traction Control, or turn it to Competitive (Track) Mode, but you cannot manually turn off your ESC. It would light up and then a moment later the light would go away, indicating that it was back on. We really didnt have much of a winter here. I think snow stayed on the ground for a total of one week this winter. Which is when I decided to get it in the shop. After that one week while it was acting up.

I take it in to my SASP and they determine that it is a faulty Steering Position Sensor. $395 out the window since it's not under warranty. But at least it's fixed. Next morning after bringing it home. Light pops back on. Then off, less than 10 seconds later. It does it twice more and so I call and get it back in to the dealership after work as they are closing. [It's a bit difficult being without a car and getting a ride home when your fiance has three kids and a baby to lug around between school, a massive amount of doctor's appointments, and everythign else. So it mostly goes in to the shop on weekends.] This time they determine that they just needed to reflash it and it's good. I pick it up the next day after work (again, as they are closing) and they say everythign works great.

Literally a half hour later I am running errands and the damn service light goes on again . I let it go till Monday and then call it in again. The guy up front that I deal with (and knows my name when I pull in by now) says that he's gonna have to give GM a call to see what they think is going on. A few days later he calls me back and says to bring it in that they want to check out some wires and harnesses. I take it in that same Thursday afternoon on lunch (plus they are open late that day). That morning, I also got my monthly OnStar report emailed to me. Brake System and Traction Control System show immediate service needed. On way to dealer, I give onstar a ring. They perform a scan and come back with a malfunction in the power steering that is affecting the brakes. Nothing of note in the traction control system at that time though (the light was off). I let the customer Service Rep at the dealership know about all this when I drop it off and he thinks that they are all connected.

The next afternoon, I get a call saying that they think that the Yaw Sensor is bad. Part will take till Monday to come in. I look this up and think...ok, maybe this is the problem. I have been sliding a bit more often when turning. Especially on dry pavement. I mention the fact that I am out $400 already due to a part that might not have actually been bad, being replaced. He says that he will try to care of the that visit for me. He ends up covering the cost when I pick it up Monday night.

Tuesday Morning the light comes back on . I'm pissed. Fiance is EVEN more pissed. She wants to be the one to talk to them the next visit. I consider my options of (1) calling up the dealership and *****ing out the GM to get this fixed, (2) calling up what is left of Saturn (or maybe GM) and reporting the ineptitude of the SASP, or (3) giving it one more shot to get fixed. I wait till the next Monday (yesterday) to see how much it acts up (enough...)and call to take it in. It is currently sitting in the dealership and I'm waiting to see what they'll come up with next.

Oh...on Sunday, my fiance drove the car to pick up her grandmother for Easter, and she mentioned having a gas cap warning on the DIC. I hadn't filled up with gas for probably a week before and it hadn't been touched since. She pulled over and checked it and said it was already tight, but that by the time she pulled over the light had already gone away. I let the Service Rep know about all of this. This was a different one this time, I think maybe the manager (who also knows me by name by now) even though the first guy is still handeling my case. He seemed to think that it was all interconnected...even with the gas cap. I trust him a little bit more. He's always gotten me results in the past when odd little things act up.

Anyone have any thoughts. I'm out of ideas. I've been over to the other Sky/Solstice fourms and in each of those similar cases it seems to have had a different outcome for the problem. Nothing I can take back to the dealership to show them what they COULD be checking. If this doesn't get corrected on this trip, I'm talking to the General Manager over there. I want my $395.18 back because replacing the Steering Position sensor obviously didnt fix anything.

...
"Education is the progressive realization of our own ignorance"

1992 SL1: 149k miles
2008 Sky RL: 35k miles

REWARD EXCELLENCE!

Add to ToledoEngineer's Reputation
Rate the quality of this post and help ToledoEngineer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ToledoEngineer is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-11-2012, 09:22 AM   #2
ToledoEngineer
Member
ToledoEngineer is on a distinguished road
 
ToledoEngineer's Avatar
 
Join Date: Oct 2005
Location: Toledo, Ohio
Posts: 239
 

2008 SKY Red Line
1992 SL1
Default Re: Ecs off

Well...I have to say I am rather speechless on the end result . They went over the car with a fine tooth comb checking every sensor and every wire and wire harness and couldn't find a thing wrong with any of it. So, they called up GM again. I guess now that MORE codes have been thrown, GM now has an answer. Apparently they have had a few cases where if one of the front tires has a thicker tread than the other front tire, and it throws off the steering position sensor just enough to F everything completely up. and apparently they have had this happen on enough cars that they documented it somewhere .

Recommendation from dealership is that they think I should wait till one of the tires is worn down enough that it could/should be replaced .

I have, through the course of nails and screws, replaced each of the four tires on this vehicle. I'll have to go back and check my records as to where the newest tire went. I think the majority of them went on the rear tires, as tehy were rotated. But, I do know that the dealership wouldn't rotate them last time as I had two R-rated tires up front and two Z-rated out back. I think one of the R's was just a cheaper tire that I could get that day instead of waiting three of four days without a car. But as for the other one, I have no idea where it came from. Perhaps that was the last one. Maybe I'll check my treads and see about picking up two identical tires for up front. I know you're supposed to replace them in 2s, but at 200+ per tire, that gets very hard to do.

...
"Education is the progressive realization of our own ignorance"

1992 SL1: 149k miles
2008 Sky RL: 35k miles

REWARD EXCELLENCE!

Add to ToledoEngineer's Reputation
Rate the quality of this post and help ToledoEngineer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ToledoEngineer is offline   Reply With Quote
Old 05-31-2012, 05:54 AM   #3
Acuosuo
New Member
Acuosuo is on a distinguished road
 
Join Date: May 2012
Location: Eritrea
Posts: 1

1991 Astra XE
1991 Astra XE
Default nothing else

thats Great thanks

REWARD EXCELLENCE!

Add to Acuosuo's Reputation
Rate the quality of this post and help Acuosuo reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Acuosuo is offline   Reply With Quote
Old 07-04-2012, 08:57 AM   #4
1993SC2
Advanced Member
1993SC2 is on a distinguished road
 
1993SC2's Avatar
 
Join Date: Jun 2002
Location: Grand Rapids, Michigan
Posts: 793

1993 SC2
Default Re: Ecs off

Geez, I'd love to turn the nanny off. In my younger days (I'm only 26, lol) I had a Pontiac that'd light the tires for about 1 1/2 seconds with "traction control off" before it mysteriously lost power. Hmmm...

...
Then: 1993SC2m
Now: 1996 Jeep XJ, 2007 Kawasaki Ninja 650

REWARD EXCELLENCE!

Add to 1993SC2's Reputation
Rate the quality of this post and help 1993SC2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1993SC2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 01:54 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.