SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 12-22-2010, 02:02 PM   #1
twelvewheels
New Member
twelvewheels is on a distinguished road
 
Join Date: Dec 2010
Posts: 2
Default Erratic Speedometer

My 1992 SL1 with approx. 120k miles is fairly new to me. When I got it the speedometer was working properly but the odometer wasn't. I replaced the two broken (expensive) gears in the odometer and everything was fine for a time.

Now the speedometer will peg at 110mph as soon as you start moving then after a time will settle at 75 to 85mph pretty much independent of actual speed. When stopped it will read either 0 or 110 mph. The odometer is still working properly.

I have disconnected and re-connected the instrument panel connector but no change. Has anyone run into this? Bad connections at speedo board? Bad board? Thanks, Tom

REWARD EXCELLENCE!

Add to twelvewheels's Reputation
Rate the quality of this post and help twelvewheels reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
twelvewheels is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 12-19-2011, 12:24 AM   #2
_Highliner
New Member
_Highliner is on a distinguished road
 
Join Date: Dec 2011
Posts: 5
Default Re: Erratic Speedometer

My speedometer only shows the correct speed or it shows zero even at speed. A couple of taps above the speedometer on the dashboard and it always pops back into place and shows the correct speed. I also had one of the dashboard lights start working again after I rapped the top of the dash a couple of times.
196,000 miles, 1.9L, 1994 Saturn SL. Rebuilt motor and transmission, 190lbs. compression.

REWARD EXCELLENCE!

Add to _Highliner's Reputation
Rate the quality of this post and help _Highliner reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
_Highliner is offline   Reply With Quote
Old 12-19-2011, 10:40 PM   #3
Midnight13
Senior Member
Midnight13 is on a distinguished road
 
Midnight13's Avatar
 
Join Date: Sep 2010
Location: N.Y.
Posts: 1,272

1998 SL
2005 VUE 3.5L
Default Re: Erratic Speedometer

Quote:
Originally Posted by _Highliner View Post
My speedometer only shows the correct speed or it shows zero even at speed. A couple of taps above the speedometer on the dashboard and it always pops back into place and shows the correct speed. I also had one of the dashboard lights start working again after I rapped the top of the dash a couple of times.
196,000 miles, 1.9L, 1994 Saturn SL. Rebuilt motor and transmission, 190lbs. compression.
Mine will show speed as i'm getting up to speed, then will drop down to zero even moving. If I lift up from behind the clutch and hold it there, it reads right again, I have no idea what's doing it. If I have long trips, it's a pain, but doesn't even bother me otherwise.

...
"Not for human consumption!" - Peas in the Pod

http://www.facebook.com/#!/pages/Peas-in-a-Pod/160649663950771

REWARD EXCELLENCE!

Add to Midnight13's Reputation
Rate the quality of this post and help Midnight13 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Midnight13 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transmission and Erratic Speedometer saturndaniel L-Series Tech 2 11-03-2010 08:26 PM
very erratic shifting bannasc1 S-Series Tech 6 10-28-2009 03:16 PM
Erratic Idle Tom64 S-Series Tech 2 12-02-2007 10:59 PM
Erratic Speedometer beensmoked L-Series Tech 0 09-19-2007 07:03 AM
Erratic Shifting 95 Sl2 jegg403 S-Series Tech 12 04-16-2007 11:05 PM


All times are GMT -5. The time now is 03:04 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.