SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-28-2011, 02:55 AM   #1
frienca
New Member
frienca is on a distinguished road
 
Join Date: Jul 2011
Location: Orlando, FL
Posts: 3

1999 SL2
Default Engine Idle When Stopped

Hello, I am new to the forums.
Well, I just registered, but have used the Saturn forums to learn how to work on things on my Saturn.

I have a 1999 Saturn SL2 and am having problems with a rough idle.
I checked out some threads started by others with similar problems, but I am not sure where to start. I recently had this problem about two months ago. My stepfather works on cars for fun and has a good amount of knowledge and recommended that I take the EGR valve off and thoroughly clean the inside for carbon buildup. I spent a good deal cleaning as much as I could and attached it back the way I found out.

Fast forward now to about two months later, maybe a month and a half, and my car jolted while I was at a red light, had a rough idle and then died on me. I turned off the car and waited for the light to turn green before I turned it on again and drove with a foot on the brake and on the accelerator, which got me home without it dying.

So long as I drive and keep applying gas, then it runs decently fine. It's when I start to apply the brakes and no power is going to it that it starts to have that rough idle.

The EGR valve was a little dirty, but I think it's still in decent condition to where I don't need another.

I am dirt poor and have a Haynes book to try to do everything myself, with the help from my stepfather. I don't really have a lot of money to spend, but I'll do what I can to get the parts that I need. Anyone have any suggestions?

Also, the first time this happened, the Service Engine light came on and I got it checked out and they told me something that I forgot. The engine light hasn't come on yet, but once it does I might take it out to Advance Auto Parts and have them check it so I could post it on here for further help.

I appreciate anything and everything.

REWARD EXCELLENCE!

Add to frienca's Reputation
Rate the quality of this post and help frienca reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frienca is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-28-2011, 05:08 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,031
 

2003 L-Series 3.0L Sedan
Default Re: Engine Idle When Stopped

Welcome to Saturnfans!

1-Read the How-to library's first few posts about the faulty coolant sensor. Basically, remove yours to see if its the original faulty round nosed plastic one - replace it immediately with a flat nosed brass one.

2-The real test for faulty egr valves is to make a temporary blocking gasket from a soda can, coins or sheet metal to cover the two ports underneath the egr valve. Use the egr vale to hold the gasket down. Temporarily blocking the exhaust flow to the intake manifold now either makes the stalling/hesitation/balking/stumbling go away or not. If it does go away then its the egr valve. Either clean it some more or find a junk yard replacement (no guarantees on j-y parts).

3-Get the error code(s) and write them down instead of memorizing. The code(s) will narrow it down instead of anyone guessing what to suggest.

There is a wealth of free information here waiting for anyone willling to spend the time reading. Almost every issue has been covered several times.
Attached Images
File Type: jpg cracked ects.jpg (39.1 KB, 10 views)

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is online now   Reply With Quote
Old 07-28-2011, 03:08 PM   #3
frienca
New Member
frienca is on a distinguished road
 
Join Date: Jul 2011
Location: Orlando, FL
Posts: 3

1999 SL2
Default Re: Engine Idle When Stopped

Thanks for your response fdryer.

3. I took the car to Advance Auto Parts, which was an adventure that required me to drive with two feet so that I could apply acceleration at all times to keep the vehicle running, and I had them check for codes.

The device gave three codes, two of which were the same. They are as follows:

P0108 (Got this code twice)
Manifold Absolute
Pressure or Barometric Pressure
Circuit High Input

P0404
Exhaust Gas Control Circuit
Range/Performance

These codes tell me nothing and the guy working couldn't tell me anything about them either.

-

1. I did some extensive reading on the Coolant Sensor and watched the video by richpin on how to remove it. I'm going to ride my bike up the street to the Advance Auto Parts and buy a replacement which is only $10.40
I'd check to see if the original is cracked, but I don't have any deep socket wrenches, so I am going to go and hopefully find an inexpensive set of them. I am not sure if it's possible to do without, but richpin in the video said to use one. Also, I need some of that Teflon Tape.

2. Thanks for the description for testing the EGR valve. I saw that richpin also has a video for this and I am going to replicate it, on top of your directions, and see if it is a direct result of the EGR valve.

I hope that this solves it and is as cheap of a fix as possible. I'll keep you all posted.

REWARD EXCELLENCE!

Add to frienca's Reputation
Rate the quality of this post and help frienca reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frienca is offline   Reply With Quote
Old 07-28-2011, 06:53 PM   #4
frienca
New Member
frienca is on a distinguished road
 
Join Date: Jul 2011
Location: Orlando, FL
Posts: 3

1999 SL2
Default Re: Engine Idle When Stopped

Alright, just an update.

I found that the P0404 code involves the EGR valve, so I took it off again and cleaned it as thoroughly as possible with break fluid and removing as much buildup around the opening as possible with a small flathead .

I tried that out, then placed a quarter over each opening (2) and used the EGR valve to hold them in place while I started my car. The car jumped up to 2k rpm and then leveled back down to 1 (where it usually idles) I let it run for a bit and there were no rough jerks going on or the engine trying to stall out.

I took the quarters off, cleaned the EGR valve some more, then placed it on and put everything back in place.

I turned on the car, engine jumped to 2k rpm, then back down to 1k rpm and things are running smoothly... for now.

Also, I bought another coolant temperature sensor and was in the process of replacing it until I took out my current sensor and noticed that it was brass tipped with no signs of a crack or wear. So, I kept the new one in the box and get to return it and get my $10.00 back, which is awesome.

Also, the service engine light went off.

Thanks so much for your help fdryer. I appreciate the suggestions.

REWARD EXCELLENCE!

Add to frienca's Reputation
Rate the quality of this post and help frienca reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
frienca is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slight Idle Miss, 650 RPM Stopped with A/C Off ndrone1 S-Series General 0 08-01-2010 02:13 AM
Rough idle when stopped and in Drive raiderfan S-Series Tech 4 07-21-2006 05:39 PM
Rough Idle Stopped in Drive thebidsnyper S-Series General 16 01-04-2006 06:06 PM
Problem with high idle when stopped luccrook S-Series Tech 3 04-18-2005 08:54 PM
Rough idle when stopped on an incline. Phrosty3 S-Series Tech 1 02-27-2002 12:19 PM


All times are GMT -5. The time now is 04:27 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.