SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 01-29-2010, 08:29 PM   #1
phoenixx
New Member
phoenixx is on a distinguished road
 
Join Date: Jan 2010
Posts: 6
Default Replaced EGR & ECTS - Still No Fix

I am new to the board and this is my first post. Let me say first that I am glad to have stumbled on this site.

I have a 97 SL that just last week turned 100k. I am sad to say that my problem has existed for about 6 months now but thought it would take more $ to fix.

I have replaced the EGR valve and just an hour ago put on a new brass ECTS but the following symptoms still remain.

When car starts cold it the temp gauge will immediately go to the 1/2 way point (it hasn't measured the actual temp in months) and then within about 1-3 miles the needle slams to COLD but will jump between the two for a couple of miles. The RPMs jump to about 2k-2.5k and will hard downshift while the RPMs jump during the downshift.

When it is warm I will have to turn the heat on for a few minutes then flood the engine to get it to start up again. I've had to keep the heat on high to keep it from overheating as well (even during summer).

It shows all the symptoms of a bad ECTS which is now new. I took it to Auto Zone and they put their reader on it and it showed no codes. The guy there said maybe a bad PCM.

I am at my wits end on this. Looking for anyone with a clue to what my Sat may be needing.

Will check back in the morning.

REWARD EXCELLENCE!

Add to phoenixx's Reputation
Rate the quality of this post and help phoenixx reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
phoenixx is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-29-2010, 08:44 PM   #2
johnny95sl2
Advanced Member
johnny95sl2 is on a distinguished road
 
johnny95sl2's Avatar
 
Join Date: Aug 2006
Location: Massachusetts
Posts: 962

1995 SL2
1995 SC2
Default Re: Replaced EGR & ECTS - Still No Fix

Did you change the connector for the ECTS?

REWARD EXCELLENCE!

Add to johnny95sl2's Reputation
Rate the quality of this post and help johnny95sl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
johnny95sl2 is online now   Reply With Quote
Old 01-29-2010, 10:05 PM   #3
bluesl2
Senior Member
bluesl2 is a jewel in the roughbluesl2 is a jewel in the roughbluesl2 is a jewel in the roughbluesl2 is a jewel in the rough
 
bluesl2's Avatar
 
Join Date: Jul 2005
Posts: 1,699
Default Re: Replaced EGR & ECTS - Still No Fix

My guess is a bad ect connector or corrosion in the socket.

REWARD EXCELLENCE!

Add to bluesl2's Reputation
Rate the quality of this post and help bluesl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
bluesl2 is offline   Reply With Quote
Old 01-29-2010, 10:44 PM   #4
phoenixx
New Member
phoenixx is on a distinguished road
 
Join Date: Jan 2010
Posts: 6
Default Re: Replaced EGR & ECTS - Still No Fix

I'd rather clean it before I replace it. Money's tight. Is there a cleaner that you can recommend?

Update: I've googled, I've eBayed, I've Amazoned but can't even find a supplier for the connector. I'll check out Auto Zone, NAPA, & O'Reily's tomorrow.

Any thoughts just in case that doesn't do the job?

Oh, by the way... I did disconnect the battery for about 5 minutes to reset the PCM, but didn't pull the fuse. Is that something I should do also?

Last edited by phoenixx; 01-29-2010 at 10:59 PM..

REWARD EXCELLENCE!

Add to phoenixx's Reputation
Rate the quality of this post and help phoenixx reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
phoenixx is offline   Reply With Quote
Old 01-29-2010, 11:25 PM   #5
fdryer
Super Member
fdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant futurefdryer has a brilliant future
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 29,793
 

2003 L-Series 3.0L Sedan
Default Re: Replaced EGR & ECTS - Still No Fix

The two-wire connector is faulty; the temp needle going to the 1/2 mark is indicating an open/failed connection and then when it does connect it sends incorrect signals to the pcm, messing with the computer. Either try cleaning it (someone mentioned baking soda solution?) or replacing it with the intake air temperature connector from a junked car. You can always use a two-pin pc connector and splice the wires onto the harness. Then silicone the connections for a waterproof seal.

The coolant sensor works on signals less than 5v so any corrosion on the electrical connections will skew the signals to the pcm. You already see that in the temperature needle in the wrong place. Although cleaning the connections isn't recommended (because of the very small terminals), you can try as a last resort before replacing the connector.

Repair the ects connections as the next suggestion may help things overall.

When the ects is fixed and you see a good temperature indication/improved starting, if the temp needle stays near the 1/4 mark, replace the thermostat. They wear out by runnning cooler. Buy the 195F one. You'll also be rewarded with a hotter heater for the winter.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is online now   Reply With Quote
Old 01-30-2010, 09:48 AM   #6
DonP
Master Member
DonP will become famous soon enoughDonP will become famous soon enough
 
Join Date: Jun 2006
Location: VA
Posts: 3,580
 

1995 SL2
Default Re: Replaced EGR & ECTS - Still No Fix

Electrical contact cleaner may work for you depending on how bad the connector is messed up. If you do replace the connector, be sure to solder the connections to ensure good contact.

If all else fails you could substitute the IAT connector from you car, and use the PC-type connector for the IAT.

Note it is possible (but not likely) that you got a new but defective sensor.

If you replace the ECTS with a 220 ohm resistor you should see the temp gauge read around 3/8 scale. With a cold engine (room temperature) the ECTS should measure around 2500 ohms, higher if it is colder.

Last edited by DonP; 01-30-2010 at 09:55 AM..

REWARD EXCELLENCE!

Add to DonP's Reputation
Rate the quality of this post and help DonP reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DonP is offline   Reply With Quote
Old 01-31-2010, 02:54 PM   #7
phoenixx
New Member
phoenixx is on a distinguished road
 
Join Date: Jan 2010
Posts: 6
Default Re: Replaced EGR & ECTS - Still No Fix

Well, I cleaned the ECTS connector and even rotated it 180 degrees to see if by chance there was a difference as to how it connected, disconnected the battery again to reset the PCM, and viola... oops - no difference.

I even pulled the PCM B fuse up under the hood just in case - but no luck.

I don't want to modify the connector with a different part so I guess I will visit the junk yard and see if I can cut one there and take my soldering iron and put it on.

Will update when it's complete.

REWARD EXCELLENCE!

Add to phoenixx's Reputation
Rate the quality of this post and help phoenixx reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
phoenixx is offline   Reply With Quote
Old 01-31-2010, 09:37 PM   #8
Greg1
Senior Member
Greg1 is on a distinguished road
 
Greg1's Avatar
 
Join Date: Jul 2001
Location: Thousand Oaks, CA
Posts: 1,189
 

1997 SW2
1998 SL2
Default Re: Replaced EGR & ECTS - Still No Fix

The intake temp. sensor and the ECTS have identical connectors so getting the intake one is the best way to go.

...
97 SW2 5-Sp 273k -mine
02 SC2 5-Sp 67k - best friend's

REWARD EXCELLENCE!

Add to Greg1's Reputation
Rate the quality of this post and help Greg1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Greg1 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced ECTS and now... Insulator S-Series Tech 3 04-04-2009 09:03 AM
Replaced my ECTS.. Infinitrium S-Series General 2 11-01-2008 11:21 PM
Replaced ECTS, Now What? aa4lr S-Series General 6 10-03-2008 10:58 PM
Replaced ECTS, now what? Derekleu S-Series Tech 15 12-06-2005 07:05 PM
replaced ects... etbardensc2 S-Series General 3 03-08-2005 06:04 PM


All times are GMT -5. The time now is 11:40 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.