SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Aura > Aura General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-05-2017, 10:58 AM   #1
HoagieSL21994
New Member
HoagieSL21994 is on a distinguished road
 
Join Date: Aug 2013
Posts: 5
Question 2008 XE AC issue

Hi, I currently own a 2008 XE 3.5 with 164k on it that is experiencing an AC issue that happened quickly. While my son was driving the car he switched the AC fan down from full high to low when the AC just stopped blowing cold. He had it inspected and found a blown 10 amp fuse which he replaced but it blew out immediately, car was hot. The next morning he replaced the fuse again, AC came back on for a few minutes but then the fuse blew again. He has also noticed that the radiator cooling fan is not coming on either.. Any ideas before I go and spend money to have this looked at? I seems like it would be a simple fix if someone can point me in the right direction.

REWARD EXCELLENCE!

Add to HoagieSL21994's Reputation
Rate the quality of this post and help HoagieSL21994 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
HoagieSL21994 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-05-2017, 01:08 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,029
 

2003 L-Series 3.0L Sedan
Default Re: 2008 XE AC issue

Is this 10 amp fuse labeled for the AC system (compressor power) or blower motor inside the car? If its for compressor power, try removing the AC diode near the fuse - its labeled as a white arrow with a line across the point. The fuse box should have labeling to show which way the arrow points when replacing it. This diode acts as a one way electrical valve; voltage and current flows in one direction and cannot flow in the opposite direction. It protects the AC relay electrical contacts from arcing when ac is turned off. Diodes sometimes fail by shorting internally and allows current to flow in the wrong direction resulting in instant fuse blowing. When its removed, ac works. Replacement from junk yard (maybe any diode from any car with similar dimensions) or auto store/online.

The cooling fan turns on immediately when ac is used but only if the compressor runs.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 09-05-2017, 07:30 PM   #3
HoagieSL21994
New Member
HoagieSL21994 is on a distinguished road
 
Join Date: Aug 2013
Posts: 5
Dizzy Re: 2008 XE AC issue

Thank you for your quick feedback. I came home from work and tried your solution but unfortunately it didn't work. The 10 amp that keeps blowing is the ac clutch fuse. Any suggestions?

REWARD EXCELLENCE!

Add to HoagieSL21994's Reputation
Rate the quality of this post and help HoagieSL21994 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
HoagieSL21994 is offline   Reply With Quote
Old 09-05-2017, 09:16 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,029
 

2003 L-Series 3.0L Sedan
Default Re: 2008 XE AC issue

Remove the diode in the fuse box, replace the fuse and try again. Follow the rest of the previous post.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RVS Issue on 2008 Saturn Aura saturnaura08 Aura General 3 04-07-2016 12:15 PM
2008 Aura XE 3.5 Error Code Issue Tajee Aura General 6 05-19-2015 12:51 PM
2008 Astra XR Electric issue Sleeper 64 Astra Tech 0 08-21-2010 07:02 PM
2008 Outlook Transmission Issue Smee Outlook General 2 04-21-2008 07:22 AM
2008 Sky Redline Issue Lemon42 Sky Red Line 8 04-08-2008 12:11 PM


All times are GMT -5. The time now is 01:52 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.