SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-17-2017, 02:31 PM   #1
700+SL2
Member
700+SL2 is on a distinguished road
 
700+SL2's Avatar
 
Join Date: Oct 2013
Location: North of Boston
Posts: 194

1995 SL2
1993 SW2
Default Ground issue or BCM?

So this randomly happened.
01 LW300.
http://vid1243.photobucket.com/album...pswsnedz75.mp4
I hope that link works.
I pulled the BCM out and all looks good. I swapped in the BCM from my LS2 and the lights flashed the same. I didn't start it, just checked to see what happens.
Seems to run and drive fine. A few times after using the directionals the tach would pop on then off again.
What do you guys think. Hoping for a bad ground somewhere.
Thanks

...
Ressurecting a 1995 SL2 mileage unknown.
...and a 95 SW2 207K
...and a 93 SW2 140K
...and a 00 LS2 95K
...and a 01 LW300 112K

99 SW2 parts wagon
94 SW2 parts wagon

REWARD EXCELLENCE!

Add to 700+SL2's Reputation
Rate the quality of this post and help 700+SL2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
700+SL2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-17-2017, 03:58 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,330
 

2003 L-Series 3.0L Sedan
Default Re: Ground issue or BCM?

Since bcm swapping didn't change the flickering lights, there may be one of several possibilities. A guess might be either poor grounds (battery has two main grounds - battery to chassis and engine block) and ignition switch.

Battery negative cable connections to chassis and engine block are easier to check than ignition switch.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-17-2017, 08:43 PM   #3
02 LW300
Member
02 LW300 has a spectacular aura about02 LW300 has a spectacular aura about
 
02 LW300's Avatar
 
Join Date: May 2015
Location: Willamette Valley, Oregon
Posts: 234
 

2002 L-Series 2.2L Sedan
2002 L-Series 2.2L Sedan
Default Re: Ground issue or BCM?

I used Photobucket for years with good success. I can no longer say that as they have killed all of the photos posted there. Sad really it has destroyed several tutorials on my previous Geo Metro adventures. The mods here have modified their system so now we can post pictures here. Thank You.
The bcm controls the lighting and the dash, so if changing the bcm didn't fix your issues maybe you have a failing dash cluster.

...
2002 L200/5 loaded, loving my stick shift car finally on the road!
2002 L200 grandson's car now
2002 LW300 sold.

REWARD EXCELLENCE!

Add to 02 LW300's Reputation
Rate the quality of this post and help 02 LW300 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
02 LW300 is offline   Reply With Quote
Old 07-17-2017, 09:49 PM   #4
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,330
 

2003 L-Series 3.0L Sedan
Default Re: Ground issue or BCM?

^ Yes, I've noticed this awhile back when searching threads and seeing broken links. Its the only reason I try to explain posting images here instead of using a host site that can break for whatever reason they feel fit. The time to resize and reformat images for posting here as thumbnails counters lost links.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 10-03-2017, 03:56 PM   #5
700+SL2
Member
700+SL2 is on a distinguished road
 
700+SL2's Avatar
 
Join Date: Oct 2013
Location: North of Boston
Posts: 194

1995 SL2
1993 SW2
Default Re: Ground issue or BCM?

Sorry to have dropped this and now picking it back up but life got busy and the L kindly **** itís tank straps and has been sitting since.
So today I decided to hit my head against the wall and work on the L.
Orig BCM, dash lights flicker like crazy and gauges donít work except for sporadic flashes.
Swapped in a BCM from a 00 LS2 with known broken odometer, same results.
Orig BCM and cluster from 00 LS2 and same flickering.

I ran out of time today before checking battery grounds. Iíll clean them tomorrow.
Anything else I should look at?
Thanks.

...
Ressurecting a 1995 SL2 mileage unknown.
...and a 95 SW2 207K
...and a 93 SW2 140K
...and a 00 LS2 95K
...and a 01 LW300 112K

99 SW2 parts wagon
94 SW2 parts wagon

REWARD EXCELLENCE!

Add to 700+SL2's Reputation
Rate the quality of this post and help 700+SL2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
700+SL2 is offline   Reply With Quote
Old 10-03-2017, 06:36 PM   #6
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 39,330
 

2003 L-Series 3.0L Sedan
Default Re: Ground issue or BCM?

Did you check for blown fuses?

I removed three bcm fuses in the engine bay, anticipating bcm disconnection when replacing a faulty blower speed control module in the hvac box. Once the blower speed module was replaced I needed to test it before reassembling the glove box. I forgot to replace the fuses and when I turned on ignition, the instrument panel flashed quietly until I realized the missing fuses and turned off ignition. After replacing the bcm fuses, everything returned to normal with blower speeds restored except for an error code (or more) turning on the SES light. Presuming it was for the bcm, I didn't decode it. Two or three engine cycles later the SES light went off on its own.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BCM, Alternator, Ground or ECM Issue? Snowden L-Series Tech 12 07-31-2016 08:39 PM
Brake light ground issue Murphys_ghosy S-Series Tech 3 01-18-2016 03:28 PM
Vue bcm possible ground or going bad? Megine Vue Tech 0 07-30-2014 06:45 PM
Repeated wheel bearing failure, possible ground issue? pimpin88 S-Series Tech 3 02-08-2011 11:04 PM
Electrical issue? bad ground? I'm @ my wits end with this POS! '98GoldSL1 S-Series Tech 38 11-10-2006 02:45 PM


All times are GMT -5. The time now is 10:30 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.