SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-17-2011, 06:57 PM   #1
Joe S
Member
Joe S is on a distinguished road
 
Join Date: Nov 2010
Location: Ottawa
Posts: 153

2001 SC1
Default URGENT: Old Nuc I need help!

Hi
So here's what I did with the car today, what happened, all sorts of good info. I'm lookin for some help...

So installed the Napa fuel filter, replacd oil and tranny fluid and both filters. I also swapped out my belt tensioner. Fluid levels are good. Tank was basically empty. A 40 some odd liter tank and I put in 40L...Car started and ran with no issues

So drove about 10 km to gas station, filled up. Have used this gas station many times with no problems.

Got on highway. Gentle driving, no gunning it. After about 100kmh or so, the accelerator pedal got stuck while I was accelerating. I gave it a bit of a kick and it unstuck...however, car started shuddering and loosing power. Pulled over, and ya, crazy misfire! Engine light ended up flashing at me, so I shut it off and just towed it back to my workspace...

Now...I don't have ym scanner so I can't pull the codes. I am going to check spark, my plugs, as well as do a compression test. Any ideas? I can't rally do any intensive diag on it till next weekend...but it almost sees like I lost a valve. So far I basically just checked over the work I did...fuel filter isn't leaking, all fluids good, belt and tension are good.

Will I see anything by pulling off the valve cover? Anything else I can do tonight? Any possibilities?

Thanks...I'm hoping I just need to tp up my blinker fluid or somethin...

REWARD EXCELLENCE!

Add to Joe S's Reputation
Rate the quality of this post and help Joe S reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joe S is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-17-2011, 07:35 PM   #2
Joe S
Member
Joe S is on a distinguished road
 
Join Date: Nov 2010
Location: Ottawa
Posts: 153

2001 SC1
Default Re: URGENT: Old Nuc I need help!

So I changed my mind...I'm not checkin anything today.I'm tire and freezing...I'm just going to deal with the car later. Feel free to point me in a direction though

REWARD EXCELLENCE!

Add to Joe S's Reputation
Rate the quality of this post and help Joe S reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joe S is offline   Reply With Quote
Old 04-17-2011, 09:04 PM   #3
PlasticCarsRock
Master Member
PlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the roughPlasticCarsRock is a jewel in the rough
 
PlasticCarsRock's Avatar
 
Join Date: Dec 2005
Location: Brookline, MA
Posts: 4,317
 

1995 SL2
Default Re: URGENT: Old Nuc I need help!

The fact that this happened immediately after an issue with the throttle sticking open could be a bit more than a coincidence. Is there any way that a piece of plastic or anything else could have ended up in your air intake? If something were to get in there (piece of plastic broken off from the air intake, screw, etc) it could have become lodged in the throttle body until you "kicked" it, allowing it to go through until it got stuck in a valve. If it's just plastic, it will probably melt within a few seconds to a minute if you can keep the engine running. If it's metal, it might do some serious damage...

I had a similar issue a few months ago--aftermarket cone filter started disintegrating from the inside out (little pieces of plastic were breaking off). They hung up in the valves causing horrible misfires for 5-40 seconds until they went through (not only do you lose one cylinder, but the exhaust gas chokes the other cylinders if an intake valve hangs open). I didn't notice it until a whole section of the filter disappeared (after replacing two sets of coils, an ICM, spark plugs, wires, etc).

...
High compression build: .033" shaved/ported head, flat-faced valves; gen3 rods, pistons, tie-plate; OE header, custom CAI, SDA street cams with adjustable sprockets, WBO2, SAFCII, LSD. ASE A1-A8+L1

REWARD EXCELLENCE!

Add to PlasticCarsRock's Reputation
Rate the quality of this post and help PlasticCarsRock reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
PlasticCarsRock is offline   Reply With Quote
Old 04-18-2011, 12:00 PM   #4
manualman
Senior Member
manualman is on a distinguished road
 
Join Date: Jul 2001
Location: Chicagoland
Posts: 1,077

1995 SL
Default Re: URGENT: Old Nuc I need help!

You do know that only ONE aftermarket fuel filter is any good on these cars, right? I forget the #, but it's a Wix. Search for it.

REWARD EXCELLENCE!

Add to manualman's Reputation
Rate the quality of this post and help manualman reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
manualman is offline   Reply With Quote
Old 04-18-2011, 01:21 PM   #5
Joe S
Member
Joe S is on a distinguished road
 
Join Date: Nov 2010
Location: Ottawa
Posts: 153

2001 SC1
Default Re: URGENT: Old Nuc I need help!

The Napa filter is a Wix filter. I have already confirmed it.

REWARD EXCELLENCE!

Add to Joe S's Reputation
Rate the quality of this post and help Joe S reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Joe S is offline   Reply With Quote
Old 04-18-2011, 02:04 PM   #6
OldNuc
Super Member
OldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant futureOldNuc has a brilliant future
 
Join Date: Apr 2008
Location: Far Southwestern Iowa
Posts: 63,233
 

1998 SC2
Default Re: URGENT: Old Nuc I need help!

Fuel pressure. With the car off does the throttle operate smoothly? Stuck shut is common but stuck open is very unusual. I would suspect that a component has failed mechanically, such as TPS. I would be looking at the TB closely and attempting to cause the failure while engine is off. There is the possibility of lifter guides failing or becoming dislodged but that makes much noise also. When the throttle stuck did the engine hit the rev limiter?

REWARD EXCELLENCE!

Add to OldNuc's Reputation
Rate the quality of this post and help OldNuc reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
OldNuc is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent question 01SL1SATURN S-Series General 10 11-02-2008 10:57 AM
Urgent problem SC Saturn Owner Ion General 3 07-05-2008 08:11 PM
Urgent!! Starter ??? The Critic S-Series Tech 12 06-03-2007 09:58 PM
URGENT: Key stuck paulygon S-Series General 16 01-17-2006 11:30 AM
Urgent Girafro S-Series Tech 8 12-06-2004 12:43 PM


All times are GMT -5. The time now is 02:55 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.