View Single Post
Old 12-15-2012, 04:07 PM   #10
robul
New Member
robul is on a distinguished road
 
Join Date: Nov 2012
Posts: 9
Default Re: 95 sl2 wont start , just replaced timing chain

Quote:
Originally Posted by PlasticCarsRock View Post
When I said straight up, I meant 12 o'clock (just like the cam gears). There is no such thing as 180 degrees off (unless it was actually at 6 o'clock...). It is true that the crank rotates twice for every single rotation of the cams, however, it doesn't matter which rotation it is in, because the same thing happens each time it turns. As long as the dots on the cam gears lined up, and the double marked links were directly opposite the crank key, it doesn't matter how anything was oriented. The procedure for lining everything up (crank at 3 o'clock, line up the cams, then turn crank counter-clockwise to 12 o'clock) is just to prevent the valves from hitting the pistons while you're installing and turning the cams (the 3'oclock position puts all pistons in the middle of their bores, so nothing will interfere). As long as all the colored marks lined up, that's all that matters; there is no possible way to have it wrong, if the links line up (assuming you bought the chain from a reputable company, and the links are marked correctly--I haven't heard of any that aren't, but stranger things have happened with foreign companies).



It's unlikely for both coils to fail at once. It should still attempt to run, on two cylinders. Also, if the coils are good enough to consistently jump the gap between the towers, they should be able to jump the much smaller plug gaps, even under the higher cylinder pressure. A weak, but still firing, coil will typically show up as a misfire under load (much higher pressure), not a no-start condition.

If the fuel pressure is insanely high, I suppose it could flood immediately; it's worth checking, but it's unlikely. An ICM failure is possible, but unlikely. If you have spark and fuel, it's definitely doing something right... Assuming you don't have an oscilloscope to test it, your best bet is typically to get a "coil pack" from a junkyard, which typically includes both coils and the ICM (they're not common failure parts, so junkyard parts are usually pretty safe, and aftermarket parts are known for being unreliable and even defective right from the start).

Have you tried disconnecting the battery, or pulling the PCM B fuse, to reset the computer (quick and easy, and will rule out any incorrect adaptation caused by the timing chain problem)?
Yes I have done that multiple times including leaving the battery unplugged for days at a time. Also pulled the pcm b fuse a number of times.

REWARD EXCELLENCE!

Add to robul's Reputation
Rate the quality of this post and help robul reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
robul is offline   Reply With Quote