View Single Post
Old 08-26-2010, 11:19 AM   #2
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 12,845
 

2002 SC2
1998 SL2
Default Re: SL2 Coolant Issue

Quote:
Originally Posted by Thrashplayhere View Post
my mechanic said my fan wasn't coming on and he replaced the fan motor.
Has the Engine Coolant Temperature Sensor (ECTS) ever been replaced?

It's a $10-15 part that tells your PCM (computer) the engine temp - the original resin-tipped one tended to crack and give low readings to the PCM. As a result, the temp gauge would read low (typically around 1/4 scale), the engine runs a little rich (can cause stalling or hard starts/restarts) and... the PCM does not turn the fan on because it thinks the engine is still cold.

The How To library has both the How To as well as links to richpin's videos on youtube showing how to find it and replace it.

The other likely possiblity is that the reservoir cap is no longer holding pressure. you could try a new or junkyard one, they are pretty cheap.

Welcome to saturnfans... sit a spell. soon, you will be saying "holy crap, there is a lot of good info here"

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote