View Single Post
Old 08-12-2018, 10:17 PM   #1
SlushWagon
Junior Member
SlushWagon is on a distinguished road
 
Join Date: Aug 2018
Location: Huntsville Tx
Posts: 12
 

1994 SW2
Default TAAT or Speed sensor issue help

Hello everyone, I've been a long time fan of the site and finally joined now that I have a big problem lol. Last year I bought a 94 sw2. No major issues till about 2 months after my speedometer did a "dance" when on the highway around 60mph, jumping between 40-70 for a few seconds before settling back to 60. At this point it would do it at random about once every 2 weeks, also started to get a rare reverse gear slam.
Apart from it's odd dance it didn't effect drivability so I got used to it. Last week I parked my car on Friday and started it up Monday morning to get down the road and noticed the speedometer is out of wack completely, jumping wildly all over and my MP7 lost it's marbles too. No shifting at all or at random. I may have 1st-4th and then loose gears all the way into 2nd, full redlining it with no upshift on it's own or by gear slection. Car bucks like crazy if I'm even barely into the throttle and engine is down on power, feels like a sohc now.
Have been looking into what I need to do, I'm down to the valvebody-speed sensor-throttle position senor as areas of possibility. Any ideas on what I should get changed out first?

REWARD EXCELLENCE!

Add to SlushWagon's Reputation
Rate the quality of this post and help SlushWagon reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
SlushWagon is offline   Reply With Quote
SaturnFans.com Sponsored Links