View Single Post
Old 06-16-2011, 09:43 AM   #13
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 12,774
 

2002 SC2
1998 SL2
Default Re: The Daily Driver Project

Quote:
Originally Posted by Blacktree View Post
You see, when I first bought the car, I degreased the engine pretty thoroughly. That was over a month ago. The only part of the engine that has oil on it now is the back end of the oil pan. Everywhere else is clean and dry.
Great job on that Really isolates the problem.

Might be worth checking the oil galley plugs and oil pressure sender back there. Also a quick wipe over the top of the drain plug; something funky about the washer set up. I've had brand new aftermarket drain plugs leak oil; ditto with an OEM plug and an aftermarket washer (not the fiber ones that OldNuc recommends, store was out). Drain plug leak was finally fixed with an OEM plug out of an oil pan I picked up for another saturn.

You need 15 posts to upload a photo directly or post a link, just two away

...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
7/2010 Craigslist white 1997 SC2 project
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles

REWARD EXCELLENCE!

Add to alordofchaos's Reputation
Rate the quality of this post and help alordofchaos reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
alordofchaos is offline   Reply With Quote