View Single Post
Old 11-05-2018, 06:19 PM   #6
MRundell
New Member
MRundell is on a distinguished road
 
Join Date: Jul 2018
Posts: 4
Default Re: Electrical issue

Quote:
Originally Posted by fdryer View Post
MRundell, does your Vue startup? Can it be driven? Are battery cables clean, free of corrosion, tightly connected to cables?

DJHMOCHA, are both battery cable connections clean, free of corrosion and tightly connected? A boost from another car can help and usually never harms the electrical system as long as red goes to red and black goes to black. Better yet - red to red, black to engine block.
It starts up just fine, until this morning when I tried to leave for work (had to replace the battery). The terminals and connections are all clean.

Minor update: the windshield wipers work but will not turn off, they just run constantly. I had to pull the fuse for my wipers. So now my list of problems;

Turn signal/high beam switch doesnít work
Wiper switch doesnít work
Door lock switch on drivers door doesnít work
Headlight switch on dash doesnít work
Traction control switch doesnít work

My DRLís work fine and all exterior lights turn on at night. My rear hatch wonít open either but Iím not sure if thatís related to the electrical problem or not.

REWARD EXCELLENCE!

Add to MRundell's Reputation
Rate the quality of this post and help MRundell reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MRundell is offline   Reply With Quote