View Single Post
Old 01-26-2017, 02:02 PM   #12
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,452
 

2003 L-Series 3.0L Sedan
Default Re: No brake lights working..all others work..need help!

Quote:
Originally Posted by tyeayo View Post
All Saturn's have led brake lights...

The running lights light the brake lights, and when you step on the brakes, its lights those led brake lights brighter....this is the normal operation...if you go check yours, you'll see that the brake lights are an led strip, and when your running lights are on, the brake lights light up, but when you press the brakes, they light up brighter
Are you sure of this? Saturn as a brand isn't a high end vehicle where LED lighting is costlier in factory installations. My L300 uses plain incandescent lamps. One way to know which lamps are used - going online and visiting AutoZone, Advance Auto, NAPA, etc., and looking up replacement tail lights. The previous owner may have modified lighting to accommodate LEDs, resulting in this problem along with losing the third brake light. Most custom wiring may use wire taps, cut and splice, and leaving loose wiring not resembling factory configurations with electrical tape unraveling after a few years. Custom wiring tends to stand out.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote