View Single Post
Old 01-08-2020, 04:12 PM   #12
trottida
Master Member
trottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud of
 
trottida's Avatar
 
Join Date: Oct 2005
Location: North of North of Toronto, Northern Ontario, Canada
Posts: 2,739
 

1999 SL2
2001 SL1
Default Re: 365,000 plus just died

Quote:
Originally Posted by Reliabilityman View Post
Yes called my mechanic today to see the status. Needless to say they haven't tried very hard. I am short of calling them idiots. They looked at the mileage and passed on any real diagnosis. They haven't even tried looking for any codes. Looks like I will be figuring this out and fixing it myself like I always have over the years. To answer your question:
1) It was an engine whine, at first thought it sounded like a gear low on oil, (I know that was not the issue but I am describing the sound)
2) The injectors have never been replaced. With blowing the nylon fuel lines several times and hard venting when opening the gas tank, Im thinking its fuel pressure related.
3) Have to press the gas pedle to the floor only when the car starts blowing black smoke
4) Fuel pressure was not tested by mechanics but was tested by me last summer and it was within the norm (34 or so PSI) Im leaning toward bad fuel regulator possibly.
5) regular maintenance has been performed on the car and the spark plugs have been replaced every 36k
6) Fuel filter replaced more than 100k, was replaced 6 months ago when the fuel filter line ruptured.
7) Yes still has the original exhaust system, minus several mufflers.
1) It was an engine whine, at first thought it sounded like a gear low on oil, (I know that was not the issue but I am describing the sound) . No comment
2) The injectors have never been replaced. With blowing the nylon fuel lines several times and hard venting when opening the gas tank, I'm thinking its fuel pressure related. I agree
3) Have to press the gas pedle to the floor only when the car starts blowing black smoke. When starting the car, pressing the gas pedal to the floor shuts down fuel as I understand it; so to me this makes sense as a running rich fuel related problem. I'm not sure if this is the case for an already running car though.
4) Fuel pressure was not tested by mechanics but was tested by me last summer and it was within the norm (34 or so PSI) Im leaning toward bad fuel regulator possibly. I'd start here however you'd have to get pressures while the issue is presenting.
5) regular maintenance has been performed on the car and the spark plugs have been replaced every 36k What is the status of the ECTS and its electrical connector? Replaced with a brass tipped one or still resin? They are known to make the S Series run rich.
6) Fuel filter replaced more than 100k, was replaced 6 months ago when the fuel filter line ruptured. What about the fuel pump? History? Can't fully recall GEN1 but isn't the fuel pressure regulator integrated into the fuel pump?
7) Yes still has the original exhaust system, minus several mufflers. No comment

...
1999 SL2 MT (287,130 km @ 10/2019)
2012 Ford Focus SEL HB MT
2011 Suburban LT

Past Saturns
2001 SL1 MT (438,500 km 11y)
1993 SW2 AT (10y)
2001 LW200 MT (3.5y)
1992 SL2 MT (5y)

:canada:

REWARD EXCELLENCE!

Add to trottida's Reputation
Rate the quality of this post and help trottida reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
trottida is offline   Reply With Quote