View Single Post
Old 02-16-2010, 05:48 PM   #3
Someclown
Member
Someclown is on a distinguished road
 
Someclown's Avatar
 
Join Date: Nov 2008
Location: Ontario Canada
Posts: 461
 

2002 VUE 3.0L
Default Re: Timing belt & Water Pump part #??

Quote:
Originally Posted by Chazberry View Post
Those are the exact items I ordered and had no problem (I didn't bother replacing the Cam Cover Seals). Also, I don't remember if the Water Pump came with the O-ring - I ordered Fel-Pro # 35665 just to be safe.
Thanks a lot Chazberry much appreciated buy yourself a drink on me.I had issues with the PCV valve hose freezing at sub zero temps. because of poor design and low spots, which in turn pressurized the engine so oil blew by the seals (what a mess in the engine compartment, but good oil spray for the undercarriage lol) I will change them while I'm there
I have O-ring kits so I will be alright there. I am only doing this job because its a stupid belt instead of a chain, other wise, I wouldn't do it. My 98 Sierra 300000+Kms and 97 Cutlass 200000+km are OEM chains ,not a knock, tick, or noise of any sort in those and still full of p i s s & vinegar. +1 on the Mobil Syn. oil & 10,000km/3month oil changes 5,000km oil filter changes

Last edited by Someclown; 02-16-2010 at 05:55 PM..

REWARD EXCELLENCE!

Add to Someclown's Reputation
Rate the quality of this post and help Someclown reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Someclown is offline   Reply With Quote