View Single Post
Old 09-22-2010, 08:25 PM   #12
David 93 SL2m
Master Member
David 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the rough
 
David 93 SL2m's Avatar
 
Join Date: May 2000
Location: 12 miles north of Rockville, Maryland
Posts: 3,594
 

2004 VUE 2.2L
2007 ION-3 Sedan
Happy Re: Changed 4-cylinder engine oil, now have ticking noise

Oh, I just remembered something! A few months ago I had an idiot light come on and the code indicated the upper oxygen sensor was failing. I reset the code and after a few weeks the idiot light came back on. After doing this another two times, I replaced the upper oxygen sensor on the back of the engine at the exhaust manifold under the heat shield (and reset the code). No more idiot light.

I will check the heat shield above the exhaust manifold, the 3 bolts that hold it in place, and the new oxygen sensor. It could be that I disrupted something while changing the oxygen sensor. For whatever it is worth I loosened the old O2 sensor and tightened the new O2 sensor with a flare-nut wrench. It wasn't too hard to do, just a bit of a stretch from above due to its location.

I just think it is odd this diesel-like engine noise came out of the blue and coincided with the oil change.

...
As of Oct 2017
∙ 2002 SL1 128K
∙ 2004 VUE 120K
∙ 2007 ION3 108K
...
Past
∙ 1993 SL2 212K
∙ 1993 SC2 140K
∙ 1996 SC2 157K
∙ 1996 SC2 126K
∙ 2001 SC2, 145K
∙ 2002 L200 20K
...

REWARD EXCELLENCE!

Add to David 93 SL2m's Reputation
Rate the quality of this post and help David 93 SL2m reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
David 93 SL2m is offline   Reply With Quote