View Single Post
Old 05-19-2013, 02:17 PM   #1
gsbevli
Junior Member
gsbevli is on a distinguished road
 
Join Date: May 2013
Posts: 17
Default 2002 L300 Many Problems

Hi Everyone!

I have been a Saturn owner for 13 years (SL2 - The Greatest Car!) and based on my past experience I bought a used 2002 L300. It looked good and drove well. I checked and there were no trouble codes but I figured any that might arise might not be too troublesome. The AC was not cooling and I thought it might be a simple/cheap fix. Big Big Mistake.

Soon after the registration process was completed the service engine light popped up. In the meantime I showed it to a mechanic whom I trusted but in hindsight I realized was not exactly competent. The trouble code that popped up was P0128 - coolant temp below thermostat temp. They figured the problem with the AC was that the cooling fan wouldn't turn on when the AC was switched on (the compressor always did and we checked the freon levels - they were OK). So they figured the relay unit that was supposed to operate the fan was bad. We changed that, still nothing, so we changed the fan. Still nothing but by then I had realized my mistake and took it to the dealer. They said it was the compressor. So we changed that and the AC works fine now. The dealer said I would have to replace the thermostat and that would get rid of the code. I haven't done it yet but will be doing so soon.

So here is the current problem. Whenever the car has been driven sufficiently long to reach normal operating temp, if it is stopped for a moment, the engine dies. Basically the RPM reaches just at about the 600 rpm mark and then it dies. It starts up easily and if I rev it, it stays on but if I release the throttle, it dies again. Now, if I switch on the AC (which automatically increases the RPM) then it doesn't shut off. So I figured, after reading fdryer's posts that it probably is not the cps. It generally doesn't shut off while driving but it has happened on occasion when the AC is off and I slow down sufficiently for the engine to be running at idling speed. Most recently it happened, I also heard a chime, so I checked the trouble codes again and now in addition to the earlier code (P0128) there was another code: P0102 (Mass / Volume air flow circuit low input).

As I mentioned earlier, I do intend getting the stat replaced but I just want to find out if the experts out there (fdryer?!!) have some advice regarding the actual problem that might be causing the engine shut down.

PS: I forgot to mention that on a recent trip from LA to San Jose the AC air flow reduced considerably. After a short stop, it was fine again. Then again, after a while, the air flow slowed down to a trickle. I figured (in my infinite wisdom) that the the compressor is not being turned off once the car cools down (as I think it should) and that is probably forming ice around the evaporator coils that prevents free air flow (that happened to me once - in another car). So I started manually switching off the AC periodically and that solved the problem. Once we got to San Jose I checked that the compressor actually does not shut off even after the temperature of the air coming out of the vents is 30F. I don't know if that is by design or a fault and if it is related to the whole thermostat issue.

Any advice/opinion/commnets would be very welcome.

REWARD EXCELLENCE!

Add to gsbevli's Reputation
Rate the quality of this post and help gsbevli reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
gsbevli is offline   Reply With Quote
SaturnFans.com Sponsored Links