View Single Post
Old 09-28-2017, 06:04 PM   #2
lord_varon
Advanced Member
lord_varon is a glorious beacon of lightlord_varon is a glorious beacon of lightlord_varon is a glorious beacon of lightlord_varon is a glorious beacon of lightlord_varon is a glorious beacon of lightlord_varon is a glorious beacon of light
 
lord_varon's Avatar
 
Join Date: Nov 2013
Location: West Virginia
Posts: 700
 

2008 VUE 3.6L
Default Re: 2004 vue 3.5L v6

Thecwb,
How many miles on the car? Also, what plugs did you use? The Honda power plants like Honda recommended parts. I did use Autolite iridium plugs in mine and it seemed okay with those. Just go back through and ensure that all the plug wires are firmly seated and screwed down tight, the gap is right, and nothing is loose. Also go through and check all the ground cables for corrosion and tightness.
On a different note, do at least one drain and fill on the transmission, with Honda DW-1. I can tell you very definitely from personal experience, the transmission HATES non-Honda transmission fluid. The Honda transmission will give you a stuttering feeling around the 35-55 mark in town due to the lock up torque converter and the computer programming. There was a TSB, about doing a computer reprogramming to help with this, but not sure if it is still being done.

John

...
aka
Lord_Varon
07 Vue V6 AWD LOADED!!! aka SUPER CRITTER!!! Sadly gone, and definitely missed.
08 Equinox Sport 3.6 6 spd auto, AWD, even more loaded. And the jury is still out on it.

REWARD EXCELLENCE!

Add to lord_varon's Reputation
Rate the quality of this post and help lord_varon reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
lord_varon is offline   Reply With Quote