View Single Post
Old 10-26-2004, 02:41 AM  
sierrap615
Master Member
sierrap615 is on a distinguished road
 
sierrap615's Avatar
 
Join Date: Aug 2003
Location: Downers Grove, Illinois
Posts: 2,538
 
Wrench P0340/P0341 Troubleshooting S-Series

Most of this came from TSB 98-T-49A, and a few of my tips thrown in.

Both P0340 and P0341 both relate to the Camshaft Position Sensor(I will just call it Cam sensor from now on), the only problem is that the S-Series engines don't have a Cam sensor, not a typical one at least. instead, the DIS module watches when the #4 spark plug fires on the compression cycle and fakes a Cam sensor signal from it. the tricky part is that on a DIS waste spark system, spark plugs fire with their mated cylinders(1/4 and 2/3 in 4 cylinder engines) every time the cylinder is at TDC, regardless of weather the cylinder is on exhaust or compression. However, it takes far more voltage to fire a spark plug on the compression stroke then on the exhaust stroke, due to the compressed air(more air molacules, more air the spark needs to jump, more resistance to spark). The increased voltage needed on the compression stroke is detected by the "#4 sensing circuit" inside the DIS module for the Cam sensor signal. if the resistance of the secondary system is not in the proper range or something else is affecting the voltage draw, the "#4 sensing circuit" will be unable to work properly.

In short, anything worng with the ignition system, bad Cam sensor signal.

Next for the diagnositic, i'm converting this from a graphic map to a text format, so bear with me...

Step 1: remove secondary wires from spark plugs, keep the wires on the coil. measure resistance from #1 wire to #4 wire and then #2 wire to #3 wire. resistance should be 11k ohms to 45k ohms(YIKES thats a wide range)

If resistance is in specs, go to step 2, if not in specs, go to step 3


Step 2: remove secondary wires from the coil packs. check for corrosion on the towers and wires.

If there is corrosion, go to step 4

If not, go to step 5


Step 3: remove secondary wires from the coil packs. check for corrosion on the towers and wires.

If there is corrosion, go to step 4

If not, go to step 6


Step 4: Replace or clean coils and/or wires as nessaciry. Retest to confirm.


Step 5: Remove spark plugs. Check for carbon or abnormal wear and proper gap(0.040 in)

If plugs check out good, go to step 8.

if the plugs are bad, replace as needed and retest to confirm.


Step 6: Measure resistance of individual secondary wires. specs are 1.5k ohms to 15k ohms ( thats what this chart says, but my knowage says 8k ohms is normal, greater then 12k ohms should be replaced)

If wires are in spec, go to step 7

If wires are bad, replace as needed and retest to confirm


Step 7: Measure resistance from tower to tower on the coil packs (hold tight for good reading). Spec is 8K to 15K.

If coils are in spec, go back up to step 5

If coils are bad, replace as needed and retest to confirm


Step 8:(90% of the time i bet the problem is solved by now) Start engine. Perform underhood visual inspection of the ignition system, check for arcing(best done in a dark area, if you are inside a garage, besure the exhaust is vented). Wet DIS module, coils, and secondary wires with salt water to provide optional ground path.(arcing from the wire boot to the valve cover is possible, but would be hidden)

If arcing is present, replace wires or coils as needed and retest to confirm.

If not, go to step 9.


Step 9: Turn ignition off, backprobe J3D03 (Circuit 633, brn/wht wire) at PCM with voltmeter. connect other lead to ground. Turn ignition on, engine off. Measure voltage.

less then 4.5 volts, go to step 10
4.5-5.5 volts, go to step 12
more then 5.5 volts, go to step 11


Step 10. Check connections in circult 633, repair short to ground, retest to confirm


Step 11. Repair short to voltage in circuit 633, retest to confirm.


Step 12. Start engine, at idle observe voltmeter

less then 2.0 volts, replace DIS module, retest to confirm
2.0 - 4.0 volts, problem intermittent
4.0 - 5.5 volts, go to step 13
more then 5.5 volts, go back up to step 11


Step 13. Turn ignition off, backprobe circuit 633 at DIS module with voltmeter, other lead to ground. check voltage.

4.0 volts or less, repair open/high resistance in circuit 633, retest to confirm.
greater then 4.0 volts, go to step 14


Step 14: Inspect terminal on DIS module for looseness or poor connection.

If terminal is bad, repair it
If terminal is good, replace the DIS module.



thats all of the diagnoistic chart, anybody who has done this in the past feel free to throw in your tips/opinons. I would like to add three things:

1. Check the grounding bolt on the DIS module for corrosion.
2. besure the secondary wires are fully seated, you should feel/hear a click
3. use dielectric grease on the coil towers

...
Formerly - Saturn of Downers Grove Parts Department
Current - Castle Chevy in Villa Park Parts Department

EPA 608 Certification
EPA 609 Certification

REWARD EXCELLENCE!

Add to sierrap615's Reputation
Rate the quality of this post and help sierrap615 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
sierrap615 is offline