View Single Post
Old 10-05-2017, 12:40 PM   #8
Kaspar7
Junior Member
Kaspar7 has a spectacular aura aboutKaspar7 has a spectacular aura aboutKaspar7 has a spectacular aura about
 
Join Date: Jun 2017
Location: Durham, NC
Posts: 17

1999 SW1
Default Re: 19999 SW1 temp gauge behaving oddly after radiator replacement

Quote:
Originally Posted by underthehood View Post
First and foremost pressure test the cooling system. If you don't you're just pi$$ing into the wind. Once you affirm the system can hold pressure buy a new pressure cap for the coolant tank. Cheap insurance. Properly bleed the cooling system to be sure all air is out.
Odds are (other than the hissing) it's now just operating normally now that the ECTS is fully covered in coolant and there is no air leak into the system
Replacing the cap seems like a smart idea. Don't have tool/know-how to test the pressure. when the car gets really hot (>7/8) some coolant gets past the recovery tank cap.

I replaced the ECTS 2 days after I got the car ~3 months ago. the one I bought was defective - ugh - so I bought another one. Temp gauge normalized at ~1/4 and the DTC for the ECTS cleared.

When hot, the upper & lower hoses get hot.

Plenty of heat from the heater core; tested that with temp lever all the way up and fan on high. We're talking blast furnace here, with good air flow.

REWARD EXCELLENCE!

Add to Kaspar7's Reputation
Rate the quality of this post and help Kaspar7 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Kaspar7 is offline   Reply With Quote