SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 30
Search took 0.05 seconds.
Search: Posts Made By: sbr65nj
Forum: S-Series Tech 04-30-2012, 05:48 PM
Replies: 12
Views: 2,056
Posted By sbr65nj
Re: Front end frame rust 2000 SL2

Put some epoxy putty on it while I find a welding shop nearby. Yes that was one of my kids toys. Car was not suspended over unsuspecting traffic.. sigh...
Forum: S-Series Tech 04-20-2012, 10:11 AM
Replies: 12
Views: 2,056
Posted By sbr65nj
Front end frame rust 2000 SL2

While inspecting front end of my 2000 SL2 I noticed some what I consider sever frame rust right under the ball joint. I am really attached to this car but am wondering if it pays to have a front end...
Forum: S-Series Tech 10-07-2011, 09:00 AM
Replies: 2
Views: 626
Posted By sbr65nj
Dizzy creaking from rear 2000 sl2

I have a weird sometimes loud creaking from the rear of my 2000 SL2 with 175K miles. It is much worse just after the rain. I can get that noise even when the vehicle is stopped by pressing hard on...
Forum: S-Series Tech 10-01-2011, 12:43 PM
Replies: 13
Views: 2,405
Posted By sbr65nj
Re: Help! P0341 Car stalling intermittently

I had the same issue on my 2000 SL2 AT 145K miles three years ago. It was the EGR valve. As soon as I replaced it the issue went away. What clued me in to your situation was both the code you...
Forum: S-Series Tech 08-14-2010, 03:46 PM
Replies: 6
Views: 651
Posted By sbr65nj
Re: 1997 electrical issues

How would I perform a load test? Never done one...
Forum: S-Series Tech 08-14-2010, 03:44 PM
Replies: 6
Views: 651
Posted By sbr65nj
Re: 1997 electrical issues

My question is can there be a cause of these burning out? Can a possible short somewhere be causing the burn out. Also the mileage on this car has been abysmal compared to my 2000 sl2. Regularly only...
Forum: S-Series Tech 08-13-2010, 01:14 PM
Replies: 14
Views: 957
Posted By sbr65nj
Re: Fan Motor Replaced, Now Running Hotter??

Beg to differ. On both my Saturns (1997 and 2000) the fan comes on when the A/C is powered on. When I was having a problem with my ects I would use this technique to cool down the engine. Seems to be...
Forum: S-Series Tech 08-13-2010, 01:02 PM
Replies: 6
Views: 651
Posted By sbr65nj
Dazed 1997 electrical issues

Here's my situation.

1997 SL2 125k Miles

Replaced alternator in 2002 and again in 2007. 2007 alternator had a short in it so I replaced again in July of 09. Now this one seems to have the...
Forum: S-Series Tech 08-13-2010, 12:50 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Cool Re: Engine mount bolts snapped much oil!!

End of story...

1) The EBay part fit perfectly. was about $45 or so with shipping. Seller even cleaned it somewhat before shipping.
2) replaced all engine mounts except the top mount which is OEM...
Forum: S-Series Tech 08-13-2010, 12:43 PM
Replies: 12
Views: 1,665
Posted By sbr65nj
Re: 99 SL miss at idle only

Re my 2000 SL2

I replaced the intake manifold gasket on mine as well. It had been replaced as a SUPPOSED warranty repair in/around 2003. Well it seems that the dealership left a few remnants of...
Forum: S-Series Tech 07-29-2010, 12:56 AM
Replies: 11
Views: 1,594
Posted By sbr65nj
Re: how do i change the muffler/exhaust on my 94 sl2?

I did both my 97 and 00 SL2s myself with only my drive up lifts and jacks. I found it easier to also jack up the front. It took some struggling but I managed to get it over and around the rear axles...
Forum: S-Series Tech 07-23-2010, 02:08 AM
Replies: 7
Views: 1,508
Posted By sbr65nj
Re: Front Rotor Replacement on 99 SL1

I had that problem on my wifes 2002 Toyota Sienna. I tool a long wood clamp and clamped it to the rotor. I then hit the clamp with a mallet and it lossened right up. The leverage did the trick it...
Forum: S-Series Tech 07-23-2010, 01:54 AM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

All the parts won't be in till beginning of next week. Sooo it will remain where it is leaking oil and on its wood blocks supporting the engine. Hopefully neighbors wont give me dirty looks. Will get...
Forum: S-Series Tech 07-22-2010, 02:20 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

FYI all. The engine mount is still intact!!,and it is not an aftermarket unit. I mounted it into my 97 SL2 (2nd car) to see and it was still aligned and was not collapsed and it worked like new. As...
Forum: S-Series Tech 07-21-2010, 11:18 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

I was able to remove the stud stubs from the engine block with a vise grip. All three are out. Here is a picture of the valve cover. As much as you fine folks may suspect I did not shoot my car!!!
Forum: S-Series Tech 07-20-2010, 11:54 PM
Replies: 12
Views: 1,665
Posted By sbr65nj
Dizzy Re: 99 SL miss at idle only

Having the exact exact same issue with my 2000 sl2. Please let me (us) know how the intake manifold gasket replacement went and if that does indeed solve this issue. On my car is sounds like a "put...
Forum: S-Series Tech 07-20-2010, 11:26 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

found some valve covers on Ebay. Hopefully the better reputed sellers will supply me with a non-bent or warped specimen. Will let you all know how it turns out...
Forum: S-Series Tech 07-20-2010, 09:39 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

You were absolutely right!!! Nice big crack over there. I guess tomorrow I get on the phone with some junk yards and see what I can find. Crack is there clear as day!!! Boy I feel stupid...
Forum: S-Series Tech 07-20-2010, 08:02 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

all three bolts have snapped. The center one is missing altogether...:cry::cry:
Forum: S-Series Tech 07-20-2010, 06:48 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Re: Engine mount bolts snapped much oil!!

Here are some pics of the affected area. If you will notice bolts (studs) are snapped clean off!!!
Forum: S-Series Tech 07-20-2010, 06:20 PM
Replies: 18
Views: 1,634
Posted By sbr65nj
Engine mount bolts snapped much oil!!

Well same story that I have read in other posts. My 2000 SL2 has the two bolts that attach to the engine snapped clean off. There is alot of oil in that part of the engine as well. I noticed that...
Forum: S-Series Tech 01-31-2010, 07:17 PM
Replies: 15
Views: 7,877
Posted By sbr65nj
Re: 98 SW2: Wipers won't stop!

I found this post on Cardone's site on this issue. It looks like a simple solution without a major cash outlay.
Forum: S-Series Tech 01-31-2010, 07:09 PM
Replies: 15
Views: 7,877
Posted By sbr65nj
Re: 98 SW2: Wipers won't stop!

I am having a similar problem with my 2000 SL2. Everything electrical works except that the windshield wipers will not turn off eight away. What I have been doing that seems to work well for now is...
Forum: How-To Library 08-12-2009, 11:05 PM
Replies: 24
Views: 34,076
Posted By sbr65nj
Dizzy Re: Strut Replacement With Pictures on a 2000 SW2

OK, boy am I embarrassed and feel stupid. My houses garage fell down in the 1970s well before I bought it. As such I work in the street in front of my house. The result of this is that I usually work...
Forum: How-To Library 08-11-2009, 01:26 PM
Replies: 24
Views: 34,076
Posted By sbr65nj
Mad Re: Strut Replacement With Pictures on a 2000 SW2

I have hit a bit of a snag. After installing the rebuilt strut I can not seem to install the assembly into the steering knuckle. No matter how hard I push it down it will not seem to install...
Showing results 1 to 25 of 30

 
Forum Jump

All times are GMT -4. The time now is 03:45 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.