SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 14 of 14
Search took 0.01 seconds.
Search: Posts Made By: bachands
Forum: S-Series General 05-18-2014, 05:44 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Note how the Westar solid-type mount looks just like an OEM. Appearances can be deceiving.
Forum: S-Series General 05-18-2014, 05:41 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

The frowny-style top mount was almost gone.
Forum: S-Series General 05-18-2014, 04:45 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Just for kicks I took some pictures of the mounts that came off my car.

That trans mount was just gone.
Forum: S-Series General 05-17-2014, 05:58 PM
Replies: 33
Views: 2,089
Posted By bachands
Happy Re: Motor mount changed, still vibrates hard.

I finally got the extra money to buy the OEM mounts....cost me $120 total from www.gmpartsnow.com including shipping for both the trans and top motor mounts.

Upon arrival, I inspected both mounts....
Forum: S-Series General 04-27-2014, 06:03 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

In an attempt to explain my vibration problem better, I have looked at ALL my mounts. I actually removed the pass. side dogbone to inspect it, and I visually looked at the ones on the trans side.
...
Forum: S-Series General 04-26-2014, 07:14 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Success! The threads are now repaired with the 20mm helicoil insert...job was quite simple and straight-forward. Thanks to everyone for the info. To anyone else doing this job, I highly recommend...
Forum: S-Series General 04-24-2014, 12:16 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Great info to have...I will be using it soon.

So at this point I have the helicoil kit that I mentioned in an earlier post and the longer studs as well. My plan is to practice using this kit a...
Forum: S-Series General 04-21-2014, 01:50 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Yeah, that sounds about right. If there are any step by step written instructions for installing the top mount on a 2nd generation Saturn, being sure to re-tighten the studs into the timing cover...
Forum: S-Series General 04-21-2014, 10:08 AM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Okay, so here's what I've gathered so far....

I read this thread (mainly posts #8 & #9): http://www.saturnfans.com/forums/showthread.php?t=180143&highlight=timing+cover+stripped+threads

So the...
Forum: S-Series General 04-20-2014, 11:27 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

This looks to be the best way to fix the threads without replacing the timing cover. Thanks for your input.

As I'm watching videos on how this is done, the only thing I'm concerned about is the...
Forum: S-Series General 04-20-2014, 08:28 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

Okay, so that's 2 suggestions for heli coil. Honestly, I am unaware of what this is. What am I looking at here?
Forum: S-Series General 04-20-2014, 06:57 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

^^^^^^^^^^^^^^^^^^^^^^^

Good info from everyone.....it's been noted. But I was still convinced something wasn't right about this....and I found it!!

The threads in the timing cover...
Forum: S-Series General 04-18-2014, 11:20 PM
Replies: 33
Views: 2,089
Posted By bachands
Re: Motor mount changed, still vibrates hard.

I wasn't sure this particular mount needed longer studs until I installed it. Do the OEM mounts require longer studs as well?
Forum: S-Series General 04-18-2014, 09:29 PM
Replies: 33
Views: 2,089
Posted By bachands
Motor mount changed, still vibrates hard.

So I was getting vibration in my cabin at start up and warm-up and figured I'd replace the top mount to get rid of it. I followed the instructions by Richpin via his youtube video and all went very...
Showing results 1 to 14 of 14

 
Forum Jump

All times are GMT -4. The time now is 08:00 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.