SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 10 of 10
Search took 0.09 seconds.
Search: Posts Made By: Hagane
Forum: S-Series Tech 08-28-2011, 07:13 PM
Replies: 0
Views: 1,122
Posted By Hagane
Looking for 2000 Saturn SL2 Alignment Specs

Anybody have them? I'd really appreciate it. My thanks in advance. :D
Forum: S-Series Tech 06-01-2011, 09:00 AM
Replies: 3
Views: 680
Posted By Hagane
Re: A/C relay in a 2000 SL2?

Yes, it does come with the a/c option. That's why I'm wondering why there is no relay in the box. Didn't see a listing for it on Autozone's website, either. The a/c has been poor since day one when I...
Forum: S-Series Tech 05-30-2011, 08:57 PM
Replies: 3
Views: 680
Posted By Hagane
A/C relay in a 2000 SL2?

I was just checking the fuse box under the hood, and was wondering if my system is supposed to have an ac relay in it? I saw the fuse box cover with a designation on the underside of the cover. I've...
Forum: S-Series Tech 05-12-2011, 09:33 PM
Replies: 3
Views: 1,118
Posted By Hagane
Re: 2000 SL2 with no-start situation, resolved. Now running rough.

Cleaned up the IAC, as well as the throttle body/butterfly. It was still running high, but took readings in the 20K range on the IAC pins, and they read at 0.040. Replaced that, and she's running...
Forum: S-Series Tech 05-10-2011, 11:56 AM
Replies: 3
Views: 1,118
Posted By Hagane
Re: 2000 SL2 with no-start situation, resolved. Now running rough.

I believe I just answered my own question. I didn't notice the the throttle cable coming up onto the switch earlier. Can't post pics directly, apparently.... :/
Forum: S-Series Tech 05-10-2011, 10:31 AM
Replies: 3
Views: 1,118
Posted By Hagane
2000 SL2 with no-start situation, resolved. Now running rough.

Flooded my engine with water, cleared it out, cleaned plugs, drained and replaced oil. She's running with high rpms, (1500 while idling) and running rough while idling. A little bit of sputtering,...
Forum: S-Series Tech 05-08-2011, 12:41 AM
Replies: 8
Views: 2,222
Posted By Hagane
Re: 2000 SL2 with no-start situation. Need extra brains on this!!!

Oh yeah, that little puddle had me fooled most certainly. Everyone else that had passed me on the other side of the road made it through. Leave it to me to find the only hole in the road... *facepalm*
Forum: S-Series Tech 05-07-2011, 08:54 PM
Replies: 8
Views: 2,222
Posted By Hagane
Re: 2000 SL2 with no-start situation. Need extra brains on this!!!

Well, pulled the plugs and tried to crank her over again. Nothing but water gushing out! I drained the oil out, and gave her a few intermittent cranks. I managed to catch the residual water with...
Forum: S-Series Tech 05-04-2011, 11:30 AM
Replies: 8
Views: 2,222
Posted By Hagane
Re: 2000 SL2 with no-start situation. Need extra brains on this!!!

I did turn it in the clockwise direction. It's been raining too hard to pull those plugs just yet, but will do first chance I get.
Forum: S-Series Tech 05-04-2011, 09:33 AM
Replies: 8
Views: 2,222
Posted By Hagane
Attention 2000 SL2 with no-start situation. Need extra brains on this!!!

Hello everyone, I have been kind of lurking on these boards for the last week and now have decided to join. I'm having trouble.

I drove through a deep patch of water, only not knowing exactly how...
Showing results 1 to 10 of 10

 
Forum Jump

All times are GMT -4. The time now is 09:42 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.