SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 152
Search took 0.15 seconds.
Search: Posts Made By: UsNsUbSoNaR
Forum: S-Series Tech 03-11-2012, 09:43 PM
Replies: 7
Views: 791
Posted By UsNsUbSoNaR
Re: Doing an engine swap

Roger that, I thought about that too. You would think that a comp check would be standard but I'm finding that is not the case!
Forum: S-Series Tech 03-11-2012, 09:31 PM
Replies: 7
Views: 791
Posted By UsNsUbSoNaR
Re: Doing an engine swap

Thanks NUC, I'll search that topic iI read somewhere on here that somebody posted a topic about pulling the engine and tranny during lunch or something. Any idea where I can find that? I searched it...
Forum: S-Series Tech 03-11-2012, 04:55 PM
Replies: 7
Views: 791
Posted By UsNsUbSoNaR
Re: Doing an engine swap

Will definitely change the water pump and thermostat as well. I plan on taking and posting pics for others to use.
Forum: S-Series Tech 03-11-2012, 04:10 PM
Replies: 7
Views: 791
Posted By UsNsUbSoNaR
Doing an engine swap

It looks like I'm going to go ahead and swap the engine in my 95 SL2. I have a friend of the family that works for LKQ auto parts that's going to find me an engine tomorrow. I'm obviously looking for...
Forum: S-Series Tech 02-27-2012, 01:53 PM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

I know that the LuK Clutch is one of the best for replacement but is there a difference between the hydraulic systems? I cant remember which one I used last time.
Forum: S-Series Tech 02-27-2012, 01:23 PM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

The engine that's nearby is a 97. The only thing on the 97 that I'm not sure about is the fact that it doesnt have the second coolant temp sensor. Is there a location for me to put the second sensor...
Forum: S-Series Tech 02-27-2012, 01:19 PM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

What's the benefit to the 98 cover?
Forum: S-Series Tech 02-27-2012, 10:31 AM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

Ok, I put the new filter on. The old one was actually a fram, not too cheap. Pulled plugs, and PCM b fuse. Cranked it a few times and the light stayed on. Pulled the new filter and it was dry as a...
Forum: S-Series Tech 02-27-2012, 12:47 AM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

I never noticed the light taking any time to go out. I'm pretty sure it's not the sending unit because the motor was tapping like it really wasn't getting oil. Not knocking or anything just tapping. ...
Forum: S-Series Tech 02-27-2012, 12:21 AM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

Should I put some oil in the cylinders before I crank it?

If I go through the trouble of removing the pump and all I figure I should go ahead and pull the motor and re-ring the pistons and drill...
Forum: S-Series Tech 02-27-2012, 12:09 AM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

Funny you should ask, now that I'm thinking about it I think it's a cheapo filter that came with the 10w 30 oil I bought at advanced. I usually use the longer motorcraft filter that goes on some of...
Forum: S-Series Tech 02-26-2012, 11:28 PM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Re: Oil Pump Quit

I did check the oil level and it was full. I keep up on it all the time as it requires a quart per tank of gas. I just assumed it was the pump. I suppose it could be plugged. I've got a few extra...
Forum: S-Series Tech 02-26-2012, 10:51 PM
Replies: 15
Views: 1,441
Posted By UsNsUbSoNaR
Oil Pump Quit

So my oil pump apparently quit on me last month. I got in my 95 SL2 one morning and the light was on. Motor was ticking like it was dry. Shut it off and left it there. I have been looking for another...
Forum: S-Series Tech 05-18-2011, 08:07 PM
Replies: 9
Views: 941
Posted By UsNsUbSoNaR
Re: No coolant pressure

Thanks for the help shipmate. BTW, "OldNuc" on the forums is a former Nuke.~ STS1(SS)
Forum: S-Series Tech 05-18-2011, 08:05 PM
Replies: 9
Views: 941
Posted By UsNsUbSoNaR
Re: No coolant pressure

Thanks for the advice everyone! I'll pick up a cap this weekend and start there. If that doesn't work, I'll give it the warm up test and look for leaks/mist.
Forum: S-Series Tech 05-18-2011, 06:38 AM
Replies: 9
Views: 941
Posted By UsNsUbSoNaR
Re: No coolant pressure

Oh BTW, it's the 95.
Forum: S-Series Tech 05-18-2011, 06:37 AM
Replies: 9
Views: 941
Posted By UsNsUbSoNaR
Re: No coolant pressure

Thanks, I'll give it a shot.

Yes, I was a Sonarman in the Navy.
Forum: S-Series Tech 05-17-2011, 09:54 PM
Replies: 9
Views: 941
Posted By UsNsUbSoNaR
No coolant pressure

I have to fill my coolant reservoir more than my oil...... which is a lot. LOL. Anyway, there is no pressure in the system even immediately after a long road trip. I am assuming that there is a leak...
Forum: S-Series Tech 05-28-2010, 09:32 AM
Replies: 6
Views: 799
Posted By UsNsUbSoNaR
Re: Wheel Bearing? No.....

I was thinking about getting the wheel bearing removal kit from harbor freight, that will just remove and re-install the bearing while the knuckle is on right? I noticed that they sell the hub and...
Forum: S-Series Tech 05-28-2010, 09:30 AM
Replies: 6
Views: 799
Posted By UsNsUbSoNaR
Re: Wheel Bearing? No.....

Awesome, Thank you! Now I feel better about just replacing it, I was going to start throwing parts at it...... I hate doing that!
Forum: S-Series Tech 05-28-2010, 09:20 AM
Replies: 6
Views: 799
Posted By UsNsUbSoNaR
Re: Wheel Bearing? No.....

BTW, the noise gets louder with speed and when the steering wheel is turned, it is like a pulsing through the steering wheel and audibly as well. I rotated the tires and that had no effect on it.
Forum: S-Series Tech 05-28-2010, 09:06 AM
Replies: 6
Views: 799
Posted By UsNsUbSoNaR
Wheel Bearing? No.....

My 95 SL2 has just reached 180,000 miles and has gotten extremely noisy when driving. I think it has gotten progressively worse. It sounds like road noise but I started noticing that when I turn, the...
Forum: S-Series Tech 10-30-2009, 06:13 PM
Replies: 21
Views: 7,786
Posted By UsNsUbSoNaR
Re: Blower Motor Resistor?

Sweet, thanks for the info! I really don't want to change the motor out so I'm going to try to put a lower fuse in. Hopefully that will work!
Forum: S-Series Tech 10-29-2009, 01:15 PM
Replies: 21
Views: 7,786
Posted By UsNsUbSoNaR
Re: Blower Motor Resistor?

Here we go again! A/C worked fine this morning then this afternoon, the same problem happened again. I fried another resistor 3 months after replacing the old one. Ordered another one a few minutes...
Forum: S-Series Tech 07-29-2009, 05:48 PM
Replies: 21
Views: 7,786
Posted By UsNsUbSoNaR
Re: Blower Motor Resistor?

I checked the relay and fuses, checked all connections I could get to and everything was fine. The resistor came in the mail today and I replaced it and it works! Thank god, it is hot here! Thanks...
Showing results 1 to 25 of 152

 
Forum Jump

All times are GMT -5. The time now is 04:35 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.