SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 500
Search took 1.04 seconds.
Search: Posts Made By: Chazberry
Forum: S-Series General 02-19-2019, 09:44 PM
Replies: 76
Views: 4,482
Posted By Chazberry
Re: I'm a Saturn owner. I'm cheap and I'm proud!

Well there's ME for one! My '95 SW2 still going strong at 184k :yes:
Forum: S-Series Tech 02-15-2019, 12:17 PM
Replies: 8
Views: 231
Posted By Chazberry
Forum: S-Series Tech 02-02-2019, 07:02 PM
Replies: 41
Views: 735
Posted By Chazberry
Re: Does 2002 SL2 have traction control?

This isn't true. My '95 SW2 - with ABS and rear drums - does in fact have Traction Control.
Forum: Vue General 02-01-2019, 08:15 AM
Replies: 6
Views: 280
Posted By Chazberry
Re: 07 VUE V6 AWD Oil Change and transmission questions

That is the correct filter. The drain plug is at the back of the oil pan, facing the rear - 17mm wrench.



Here's a thread on the ATF drain and fill - you want to get some genuine Honda DW-1 ....
Forum: S-Series General 02-01-2019, 12:08 AM
Replies: 9
Views: 250
Posted By Chazberry
Re: Special Forces still rebuild valve bodies?

OldNuc is referring to Central. Not all rebuilders do the same rebuild.
Forum: S-Series General 01-30-2019, 01:14 AM
Replies: 9
Views: 250
Posted By Chazberry
Re: Special Forces still rebuild valve bodies?

I believe so. You can PM him from this thread . . .
Special Forces by PM > http://www.saturnfans.com/forums/showpost.php?p=2132998&postcount=18

Or try these other trusted rebuilders:...
Forum: Vue Tech 01-30-2019, 01:08 AM
Replies: 2
Views: 180
Posted By Chazberry
Re: Well Another tranny swap thread.. 2.2 5-speed manual-to?

I don't recall anyone going from manual to automatic - it's usually VTi to manual or AF23. Here's those threads in case they are some help . . .

VTi to AF23 Swap ...
Forum: Vue General 01-26-2019, 08:01 PM
Replies: 222
Views: 19,800
Posted By Chazberry
Re: What did you do to your VUE today ?

Well - it happened very fast. Temp was about 21F - roads a little slushy - doing about 50mph (obviously too fast :yes:). I was in the center lane following tracks of bare pavement. (Fortunately...
Forum: Vue General 01-26-2019, 06:03 PM
Replies: 222
Views: 19,800
Posted By Chazberry
Re: What did you do to your VUE today ?

Thanks - I'm still very pissed at myself. :upset:
At least I still had collision on it ($500 deductible).
Travelers said it was worth $5,000, so I got a check for $4,500.
And I got a good deal on...
Forum: Vue General 01-20-2019, 09:57 PM
Replies: 222
Views: 19,800
Posted By Chazberry
Re: What did you do to your VUE today ?

Totalled it - but walked away without a scratch! :yes:
Forum: S-Series Tech 01-17-2019, 08:56 PM
Replies: 34
Views: 2,307
Posted By Chazberry
Re: Coolant Temp

Fwiw - this is my '95 SW2 cluster . . .
Forum: Vue General 01-10-2019, 12:32 PM
Replies: 13
Views: 984
Posted By Chazberry
Re: 2003 VUE 6 CYL FWD - Won't Start

Sadly, way too many threads left unresolved. :(
It doesn't look like the ignition has to be on. There's always B+ to Pin 87 on that Relay....
Forum: Vue General 01-09-2019, 07:32 PM
Replies: 4
Views: 795
Posted By Chazberry
Re: 2005 Vue V6 3.5L coolant hose connection help

The Upper Radiator Hose goes to the forward connection - the one closest to the Radiator.
Forum: Vue General 01-09-2019, 06:43 PM
Replies: 13
Views: 984
Posted By Chazberry
Re: 2003 VUE 6 CYL FWD - Won't Start

Sorry to hear you're back in this club. There's a bunch of ECM troubleshooting towards the end of this thread - hope it helps . . .
http://www.saturnfans.com/forums/showthread.php?t=236117
Forum: Vue General 01-02-2019, 09:14 PM
Replies: 12
Views: 429
Posted By Chazberry
Re: Slow/Sluggish acceleration

No - that's just a delayed shift.
Forum: Vue General 01-02-2019, 08:45 PM
Replies: 12
Views: 429
Posted By Chazberry
Re: Slow/Sluggish acceleration

So is the tranny obviously slipping? RPMs going high without the expected acceleration?

PS - I'm not that much of an expert since I can't even get mine running. ;)
Forum: Vue General 01-02-2019, 04:39 PM
Replies: 12
Views: 429
Posted By Chazberry
Re: Slow/Sluggish acceleration

Not a common failure item. Can you post all the trouble codes?
Has the ATF ever been changed? How does it look and did you check the level correctly (see attached)?
Forum: Vue General 01-02-2019, 01:33 PM
Replies: 12
Views: 429
Posted By Chazberry
Re: Slow/Sluggish acceleration

Welcome Max - how many miles on this '03?
Forum: S-Series Tech 12-29-2018, 05:31 PM
Replies: 16
Views: 598
Posted By Chazberry
Re: Serpentine belt & pulley replacement?

With the Tensioner, nothing usually goes wrong with the Pulley - either the spring loses tension or the bearing fails. On mine, the spring got weak which resulted in some belt squeal after start-up...
Forum: Vue Tech 12-28-2018, 09:09 PM
Replies: 1
Views: 250
Posted By Chazberry
Re: Need the VTI to M43 bible

Do you mean the 4T45E swap? If so, maybe some info in this thread . . .
http://www.saturnfans.com/forums/showthread.php?p=1920091
Forum: S-Series Tech 12-28-2018, 10:42 AM
Replies: 11
Views: 334
Posted By Chazberry
Re: How do u replace wheel studs 95 sl1 no clearance ?

The Bearing is pressed in, but isn't the Hub held in with a snap ring?
Forum: S-Series Tech 12-27-2018, 05:42 PM
Replies: 9
Views: 226
Posted By Chazberry
Re: Flex pipe OD?

[QUOTE=saturny;2289012]What is the OD of the flex pipe on a 2002 SL2? I need a butt joint sleeve and not sure if I need the 2" or 2.25".

Once upon a time, I installed a ROL 520010 Flex which is...
Forum: S-Series Tech 12-22-2018, 09:18 AM
Replies: 16
Views: 598
Posted By Chazberry
Re: Serpentine belt & pulley replacement?

I got an ACDelco 21007457 Idler for $24.
Forum: S-Series Tech 12-19-2018, 04:32 PM
Replies: 16
Views: 598
Posted By Chazberry
Re: Serpentine belt & pulley replacement?

Fwiw - my OE Tensioner failed at 125k and my Idler at 182k mi.
Forum: Vue Tech 12-15-2018, 10:36 PM
Replies: 90
Views: 1,403
Posted By Chazberry
Re: Urgent! Fuel issue!

Seems like 400-500 Ohms. Mine measures 900-1000. But my bad one measured in the MegOhms.
Showing results 1 to 25 of 500

 
Forum Jump

All times are GMT -4. The time now is 06:05 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.