SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 65
Search took 0.14 seconds.
Search: Posts Made By: 94sl2guy
Forum: S-Series Tech 06-17-2017, 08:38 AM
Replies: 4
Views: 497
Posted By 94sl2guy
Re: Key stuck in ignition

Thanks for your answer, I'll take a look at that.
I should have added the fact that this is on a manual transmission as well.
Thanks!
Forum: S-Series Tech 06-17-2017, 12:16 AM
Replies: 4
Views: 497
Posted By 94sl2guy
Key stuck in ignition

Have a 1999 SL1. My son called to say it sounded like a cylinder was not firing. Took a look at the car and determined #2 plug was not firing. Replaced the plug but when I went to start the car, the...
Forum: S-Series Tech 04-21-2015, 01:51 AM
Replies: 12
Views: 1,207
Posted By 94sl2guy
Re: Bad Wheel Bearing?

BTW, on some of those cars, I had to use a chisel to separate the hub from the knuckle if it is tight. Does not do the old bearing/hub any good but it is shot already and is much, much quicker than...
Forum: S-Series Tech 04-21-2015, 01:48 AM
Replies: 12
Views: 1,207
Posted By 94sl2guy
Re: Bad Wheel Bearing?

I notice that most of the how-to instructions for hub replacement require disassembly of the knuckle, tie rod and strut. On other cars I have worked on (Saab, Cavalier, Volvo) I was able to remove...
Forum: S-Series Tech 09-20-2014, 07:54 PM
Replies: 3
Views: 291
Posted By 94sl2guy
Re: '96 SL1 - oil in coolant

Just took it ourfor a spin and the alternator dies so I think that addresses my dilemna. I'm fixing it up for my son but I also have a 99 SL1 (yes, I am an addict - owned a 94 SL2 that ended it's...
Forum: S-Series Tech 09-20-2014, 06:35 PM
Replies: 3
Views: 291
Posted By 94sl2guy
'96 SL1 - oil in coolant

My daughters 96 SL1 is getting oil into the coolant as well as loosing significant amounts of oil. I've drained and cleaned out the cooling system. I'm not intending to spend a lot of time or a...
Forum: S-Series Tech 03-16-2009, 07:19 AM
Replies: 8
Views: 3,280
Posted By 94sl2guy
Re: P0420 and P1404 codes

Mileage is 171,000 km.
Forum: S-Series Tech 03-16-2009, 12:07 AM
Replies: 8
Views: 3,280
Posted By 94sl2guy
Re: P0420 and P1404 codes

Are the two codes related? I have seen posts which mention both codes happeniing at the same time.
Forum: S-Series Tech 03-15-2009, 08:21 PM
Replies: 8
Views: 3,280
Posted By 94sl2guy
P0420 and P1404 codes

I have a 1999 SL1 that I have just purchased. After driving for one day two P0420 codes were captured. I cleared them and they returned. Cleared again, took out the car for a long drive at 110 kmh to...
Forum: S-Series Tech 01-27-2009, 03:09 PM
Replies: 8
Views: 1,143
Posted By 94sl2guy
Re: 1999 SC1 with P0410 code

I have an '01 SC2 and this code came up last weekend immediately after filling with gas that contained ethanol vs. the non-ethanol content I usually purchase. I read the codes, cleared them, then...
Forum: S-Series Tech 11-05-2008, 02:17 PM
Replies: 28
Views: 1,109
Posted By 94sl2guy
Re: Another oil ?

As far as synthetics vs. dino oil, I'm not totally convinced that synthetics will extend the life of a motor - lab testing is one thing, actually on the road performance with all the challenges that...
Forum: S-Series Tech 11-05-2008, 01:25 PM
Replies: 0
Views: 1,559
Posted By 94sl2guy
2001 SC2 no start/fuel problem - solution

Just thought I'd post this for the benefit of other members who might encounter a similar problem. The other day I drove over a railroad trackat about 95 km/hr and as soon as I went over the bumps,...
Forum: S-Series Tech 07-07-2008, 12:34 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Re: Canadian ECTS

No, I didn't see any appreciable build up of anything on the sensor probe. The tip was cracked but nothing else. However, my car has 240,000 km so the cooling system may have been drained and...
Forum: S-Series Tech 07-06-2008, 02:32 PM
Replies: 6
Views: 893
Posted By 94sl2guy
Rough running - problem solved - I am a dork!

I have finally figured out the rough running problem on my 2001 SC2! And I am ashamed to say that I am officially a bonehead!
My car has been running rough for about 3 weeks now - started fine, ran...
Forum: S-Series Tech 07-06-2008, 02:04 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Re: Canadian ECTS

Problem solved! And, yes, I am a Dork. Checked the TPS, MAP sensor, cleaned the EGR valve (it was replaced 3 months ago after some poor running and throwing out an EGR-related code). Still running...
Forum: S-Series Tech 07-03-2008, 12:01 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Re: Canadian ECTS

Replaced the ECTS on my '01 SC2 with the WT5029 from Parts Source (parts supplier here in Canada). I've checked the Borg Warner site and other sites that cross-reference part numbers and they all...
Forum: S-Series Tech 06-30-2008, 08:14 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Re: Canadian ECTS

I should clarify my post - my user name is 94sl2guy but I retired that old girl in 2003 with 450,000 km. I am now driving a 2001 SC2 - I picked up the sensor (the WT5029) on the way home today - it...
Forum: S-Series Tech 06-30-2008, 06:11 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Re: Canadian ECTS

You have my curiosity peaked - I gave the parts counter the year of my car and my understanding is that the newer SC cars only have the one sensor (the two contact variety vs. the older one wire type...
Forum: S-Series Tech 06-30-2008, 05:31 PM
Replies: 12
Views: 1,299
Posted By 94sl2guy
Canadian ECTS

Replacing my ECTS - dealer here in Winnipeg, Canada wants $37.00! Parts Source (division of Cdn Tire) wants $14.99 - part #WT5029. Anyone ever used a Parts Source ECTS and has it worked OK for you?...
Forum: S-Series Tech 04-09-2008, 09:49 PM
Replies: 1,257
Views: 479,919
Posted By 94sl2guy
Re: how many miles do you have on your saturn?

My '94 SL2 had 282,000 mi (454,000 km) when I retired her in 2005. Still looked great and still on the original clutch, engine, etc. although the motor was using 1 liter of oil per 400 km by the time...
Forum: S-Series Tech 02-02-2008, 06:44 PM
Replies: 3
Views: 826
Posted By 94sl2guy
High Beams now working!

Both lamps were getting voltage and both lamps were burnt out! Replaced them and will watch as it is very odd that both would burn out literally at once. Hoping I don't have a short or something that...
Forum: S-Series Tech 02-02-2008, 11:24 AM
Replies: 3
Views: 826
Posted By 94sl2guy
High Beams not working

I have a 2001 SL2 and the high beams are not working. Dashboard high beam indicator lights up but neither high beam turns on. Low beams are fine. As well, daytime running lights do not turn on and...
Forum: Ion General 12-03-2007, 10:20 PM
Replies: 3
Views: 938
Posted By 94sl2guy
Re: 2003 Ion 2 - What to watch for when buying

Thanks for your input. I'm taking the car for a test drive in the next day or two so I'll listen for the bushing in the front end (supposed to be -29C on Wed here in Winnipeg, Canada so if there is a...
Forum: Ion General 12-03-2007, 04:35 PM
Replies: 3
Views: 938
Posted By 94sl2guy
Wrench 2003 Ion 2 - What to watch for when buying

My wife's car (2000 Intrepid) was recently in an accident and written off so I am looking to replace it. I have had a '94 SL2 (450,000 km) and presently have a 2001 SL2 with 230,000 km (I get my...
Forum: S-Series Tech 12-21-2005, 11:08 AM
Replies: 12
Views: 2,026
Posted By 94sl2guy
Re: Wheel bearing

I don't ride the brakes so overheating shouldn't be an issue. However, in Winnipeg our roads, compared to the roads of other cities I have travelled in, are horrific - deep potholes are commonplace....
Showing results 1 to 25 of 65

 
Forum Jump

All times are GMT -4. The time now is 04:48 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.