SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 95
Search took 0.04 seconds.
Search: Posts Made By: JBushman
Forum: S-Series General 02-09-2018, 06:15 PM
Replies: 8
Views: 372
Posted By JBushman
Re: Saturn S Series Search Advice

Iíve got Ď94 SOHC manual trans. Gets 40 mpg after a rebuild. Look for rust around the entry to the rear doors. Also likely to burn a lot of oil unless the pistons have been modified by drilling some...
Forum: S-Series General 02-03-2018, 05:39 PM
Replies: 8
Views: 478
Posted By JBushman
Re: SL Dies suddenly, cools off and starts. Whatís up?

I pulled the old CPS out again. Broke down and renewed my subscription to AllDataDIY to get the schematics of the PCM connectors and the CPS.

I tested the wire between the connector for the CPS...
Forum: S-Series General 02-03-2018, 12:06 PM
Replies: 8
Views: 478
Posted By JBushman
Re: SL Dies suddenly, cools off and starts. Whatís up?

I let it idle until it died. Then decided to check for spark. My son watched while I cranked. No spark between the coil towers.

I had a set of extra coils and an ICM. So first we put the new...
Forum: S-Series General 02-03-2018, 11:13 AM
Replies: 8
Views: 478
Posted By JBushman
Re: SL Dies suddenly, cools off and starts. Whatís up?

The car is starting just fine when itís cold.

I pulled the CPS and tested it for resistance. With the multimeter set to 20K, I got a reading of .79 when it was cold.

Put the CPS in a can...
Forum: S-Series General 02-01-2018, 08:17 PM
Replies: 8
Views: 478
Posted By JBushman
SL Dies suddenly, cools off and starts. Whatís up?

I have a Ď94 SL SOHC. Has an indeterminate number of miles (odometer was busted) but probably over 220,000. Engine was rebuilt a couple of years ago.

Over the summer, on a couple of days when...
Forum: S-Series General 07-21-2017, 12:07 PM
Replies: 2
Views: 242
Posted By JBushman
Re: Can you identify this noise?

The strut mount plate was replaced with the strut.

Forgot to mention that the wheel hubs are only a year old too.
Forum: S-Series General 07-21-2017, 11:47 AM
Replies: 2
Views: 242
Posted By JBushman
Can you identify this noise?

I have a 1994 SL, manual transmission, SOHC with manual steering.
Approximately 230K miles.

When I am moving at very low speed, as in pulling into a parking space, I hear a creaking noise...
Forum: S-Series General 04-29-2017, 08:56 AM
Replies: 0
Views: 295
Posted By JBushman
Aftermarket TPS

I have a 1994 SL SOHC with throttle body. A while back I rebuilt the throttle body and in the process replaced the IAC, injector and TPS.

I had consistent rough idle and ultimately tracked it...
Forum: S-Series General 05-05-2016, 07:06 PM
Replies: 0
Views: 261
Posted By JBushman
Over speedy odometer

I have a 1994 SL, SOHC, manual transmission vehicle. The odometer stopped working around 209,000, about 5 years ago. Just rebuilt the engine and bought new odometer gears to get that thing working....
Forum: S-Series General 04-28-2016, 08:54 PM
Replies: 9
Views: 796
Posted By JBushman
Re: EGR Mystery

Well, the light started coming back on after a couple of days of in-town driving.

So I got a brand new OEM EGR solenoid off eBay for $23 and put it on.

Light is still coming on!!!

I have a...
Forum: S-Series General 04-22-2016, 09:17 PM
Replies: 3
Views: 314
Posted By JBushman
Re: Where to get replacement rear door sills for my rusting car

Hey Oldnuc, thanks for the heads up on the match with the wagon. THere's a JY nearby that I am pretty sure has one. I was looking at it last time I was there and it looked really similar, but I...
Forum: S-Series General 04-22-2016, 03:30 PM
Replies: 3
Views: 314
Posted By JBushman
Where to get replacement rear door sills for my rusting car

I have a 1994 SL. The rear door sills, like many others, are rusting pretty badly and I need to cut them out and weld in some new ones.

Anyone know a good source for where I could get...
Forum: S-Series General 04-21-2016, 10:24 PM
Replies: 9
Views: 796
Posted By JBushman
Re: EGR Mystery

Been driving a couple of days. No SES light coming on. The stuck plunger in the EGR solenoid seems to have been the culprit.

Car is also running smoother at idle. I presume this is because the...
Forum: S-Series General 04-20-2016, 07:31 AM
Replies: 9
Views: 796
Posted By JBushman
Re: EGR Mystery

I took the EGR solenoid out and took it apart, per the instructions on this thread: http://www.saturnfans.com/forums/showthread.php?t=70004

After I had pulled the solenoid apart (a spring and a...
Forum: S-Series General 04-19-2016, 07:18 AM
Replies: 9
Views: 796
Posted By JBushman
Re: EGR Mystery

Did a little more on the car today.

First I tested continuity between the EGR solenoid connector terminal and the PCM. I had continuity. Then I put the key in the on position, with engine off,...
Forum: S-Series General 04-15-2016, 07:13 PM
Replies: 9
Views: 796
Posted By JBushman
EGR Mystery

I have a 1994 SL SOHC, Manual Transmission. Just rebuilt.

Keep getting code 32 - EGR malfunction.

The code sets if:

MAP is .25 - 2.6v
TPS is between 5 - 70% throttle
Throttle is constant...
Forum: S-Series General 04-11-2016, 09:53 PM
Replies: 1
Views: 303
Posted By JBushman
TBI Fuel Pressure Regulator Issue

I have a 1994 SL, SOHC, manual transmission, with approximately 230,000. Just finished rebuilding the engine, during which I also used a TBI rebuild kit.

I'm posting this, even though I figured...
Forum: S-Series General 04-07-2016, 06:53 AM
Replies: 8
Views: 1,036
Posted By JBushman
Re: Why no vacuum from TBI to EGR solenoid?

I think I found the problem. It was the hoses, I believe. After verifying that the EGR and solenoid and the MAP were good and knowing that the EGR passageways and TBI were clean and free of carbon...
Forum: S-Series General 04-05-2016, 11:03 AM
Replies: 8
Views: 1,036
Posted By JBushman
Re: Why no vacuum from TBI to EGR solenoid?

Fetchfido - thanks for posting those diagnostic flow charts. I'll have to work my way through those.

The passages from exhaust manifold and to the intake manifold are clean. I just had the...
Forum: S-Series General 04-05-2016, 09:30 AM
Replies: 8
Views: 1,036
Posted By JBushman
Re: Why no vacuum from TBI to EGR solenoid?

This morning I connected a vacuum pump directly to the EGR valve, pumped it up and put my finger underneath the valve. I could feel the diaphragm move up and it held. Very slowly it came back down,...
Forum: S-Series General 04-04-2016, 07:35 AM
Replies: 8
Views: 1,036
Posted By JBushman
Re: Why no vacuum from TBI to EGR solenoid?

Fdryer - great suggestion. I disconnected the hose from the TBI to the EGR solenoid at the Solenoid end. Then I manually twisted the throttle. As I did that I held a finger over the open end of the...
Forum: S-Series General 03-30-2016, 08:14 AM
Replies: 8
Views: 1,036
Posted By JBushman
Why no vacuum from TBI to EGR solenoid?

I have a 1994 SOHC SL, MT.

I got a code 32 the other day "EGR malfunction," so I decided to check the EGR by taking the vacuum hose that runs from the back of the TBI to the EGR solenoid and...
Forum: S-Series General 03-29-2016, 08:29 AM
Replies: 3
Views: 917
Posted By JBushman
Re: What's causing this rough idle?

I figured it out this morning.

Pulled off the air box and looked at the injector as it was running. Gas was both spraying in, per normal, but there were also these significant dribbles just...
Forum: S-Series General 03-29-2016, 12:10 AM
Replies: 3
Views: 917
Posted By JBushman
What's causing this rough idle?

Have a 1994 SL, SOHC. Just rebuilt. Replaced the following:
1. EGR valve
2. TPS
3. IAC
4. MAP sensor and connector
5. ECTS and connector
6. Got junk yard ICM and connectors and put...
Forum: S-Series General 03-06-2016, 09:50 PM
Replies: 61
Views: 2,402
Posted By JBushman
Re: Is this a sign of a bad oil pump, or something else?

So, I feel like an idiot.

I had reversed the connector on the MAP sensor, so that it was in backward.

Turned it around and the car started right up, no problem. Turned it off, started right...
Showing results 1 to 25 of 95

 
Forum Jump

All times are GMT -4. The time now is 09:13 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.