SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 149
Search took 0.15 seconds.
Search: Posts Made By: kevster0522
Forum: S-Series General 08-19-2016, 02:35 PM
Replies: 1,704
Views: 289,936
Posted By kevster0522
Re: Saturn Craigslist Deal of the Day!

220k miles for $1000 doesn't sound like a very good deal to me.
Forum: S-Series General 08-18-2016, 12:11 PM
Replies: 4
Views: 265
Posted By kevster0522
Re: Cylinder 3 Always Fouling Spark Plug

It's gotten pretty bad now. About 200/300 per quart.
Forum: S-Series General 08-18-2016, 12:04 PM
Replies: 4
Views: 265
Posted By kevster0522
Question Cylinder 3 Always Fouling Spark Plug

I drive a 95 sl1 manual.

This is something that's been happening more and more often and I'm wondering if anyone knows why. I seems that about every 3000 miles I'll start getting a slight hiccup...
Forum: S-Series General 01-03-2016, 03:24 PM
Replies: 3
Views: 930
Posted By kevster0522
Re: Missing when warm

Thank you for your reply. I checked the spark plugs and I've attached a picture of the bad plug that came out of cylinder #3. I'm not sure how a plug gets that bad especially after changing them not...
Forum: S-Series General 01-01-2016, 12:38 PM
Replies: 3
Views: 930
Posted By kevster0522
Re: Missing when warm

I read that it might be a fuel starvation issue so I got a tester and hooked it up. The needle was solid at 32 psi (not sure if that's a good pressure or not). It also didn't budge when I turned off...
Forum: S-Series General 12-31-2015, 06:53 PM
Replies: 3
Views: 930
Posted By kevster0522
Missing when warm

Hi everyone, I could really use some help with this problem. I haven't driven my car (95 sl1) since the summer time because I was away at school. Ever since I came back it's been missing at idle...
Forum: S-Series Tech 07-13-2015, 08:27 PM
Replies: 49
Views: 18,155
Posted By kevster0522
Re: OEM motor mounts OMG!!!

Gonna tell us where you found these?
Forum: S-Series General 06-24-2015, 08:15 PM
Replies: 1,704
Views: 289,936
Posted By kevster0522
Re: Saturn Craigslist Deal of the Day!

Not sure what loud noise they could be talking about. Maybe ran it out of oil? Otherwise good deal.

http://minneapolis.craigslist.org/hnp/cto/5085287688.html
Forum: S-Series General 06-05-2015, 10:58 AM
Replies: 8
Views: 1,045
Posted By kevster0522
Re: Exhaust Problems Advice

I just wanted to give an update. I believe I fixed the issue. I got a new gasket and sprayed it like oldnuc suggested but when I put everything back together it was still leaking up by the flange by...
Forum: S-Series General 06-04-2015, 12:31 PM
Replies: 8
Views: 1,045
Posted By kevster0522
Re: Exhaust Problems Advice

Sounds good. Thanks for the help!
Forum: S-Series General 06-04-2015, 12:27 PM
Replies: 8
Views: 1,045
Posted By kevster0522
Re: Exhaust Problems Advice

Thanks for the response OldNuc I will give that a try. Should I also put on the ultra copper gasket stuff again or would that be a bad idea?
Forum: S-Series General 06-04-2015, 11:28 AM
Replies: 8
Views: 1,045
Posted By kevster0522
Question Exhaust Problems Advice

Hello all. I was hoping to get some advice for the problems I've been having with my exhaust.

Ever since I got my 95 sl1 there has been a small leak in the flex pipe right before the braiding on...
Forum: S-Series Tech 03-19-2015, 11:19 AM
Replies: 4
Views: 757
Posted By kevster0522
Re: 95 SL1 Cruise Installation

Yes I did try. I went up to 45mph but it would not engage.
Forum: S-Series Tech 03-18-2015, 03:46 PM
Replies: 4
Views: 757
Posted By kevster0522
Re: 95 SL1 Cruise Installation

Just tried jumping that cable with a paperclip. It didn't have any affect on the cruise. Now I'm not sure what to do next.
Forum: S-Series Tech 03-18-2015, 03:29 PM
Replies: 4
Views: 757
Posted By kevster0522
Question 95 SL1 Cruise Installation

Hey everyone! I wanted to take up a project to install cruise in my 95 sl1. I recently ran to the junkyard and grabbed a cruise module from a 94 sl1 and the steering switches from a 97 sl1. I plugged...
Forum: S-Series General 10-05-2014, 05:05 PM
Replies: 88
Views: 7,332
Posted By kevster0522
Re: 96-98 1.9 DOHC Saturn OEM GM reman. engines available IL, IN, OH, MI, IA, WI w/ p

What I'm getting from a quick look around is I'd need not only the harness but also a fuel rail, injectors, pcm, and possibly the correct speedo. Unfortunatly it doesn't seem to be a nice plug and...
Forum: S-Series General 10-05-2014, 04:13 PM
Replies: 88
Views: 7,332
Posted By kevster0522
Re: 96-98 1.9 DOHC Saturn OEM GM reman. engines available IL, IN, OH, MI, IA, WI w/ p

I'd love to take it but I feel like it'd be too much work to get everything working right in my 95 sl1
Forum: S-Series General 05-21-2014, 12:52 PM
Replies: 1
Views: 267
Posted By kevster0522
Question Did I get a bad alignment?

Hello everyone I decided to conquer my weird unstable steering today and take a look under the car. I wanted to see if the subframe is misaligned from when I replaced it last year. The first two...
Forum: S-Series Tech 01-24-2014, 08:25 PM
Replies: 8
Views: 10,286
Posted By kevster0522
Re: engine running rough, loss of power, white smoke.

Solved! Thanks everyone for your input. I hadn't had an issue this entire winter break until today when I was driving home and starting getting the symptoms of losing power and rough engine. This...
Forum: S-Series Tech 12-18-2013, 08:06 PM
Replies: 8
Views: 10,286
Posted By kevster0522
Re: engine running rough, loss of power, white smoke.

Update: I just took the car out for a drive tonight. There was no evidence of a problem at all. I think it can make it home but I will do some tests when I get home with my tools.
Forum: S-Series Tech 12-17-2013, 04:48 PM
Replies: 8
Views: 10,286
Posted By kevster0522
Re: engine running rough, loss of power, white smoke.

I usually get home about once a month to drive it. Never thought of that. It does sit in a garage for that time if that makes a difference. My problem is I drove it around for an hour perfectly fine....
Forum: S-Series Tech 12-17-2013, 02:06 PM
Replies: 8
Views: 10,286
Posted By kevster0522
Re: engine running rough, loss of power, white smoke.

There were no lights. I really hope it wasn't the head. We recently just changed the thermostat and the coolant too so I have been watching coolant levels and it doesn't look like its going down....
Forum: S-Series Tech 12-17-2013, 01:44 PM
Replies: 8
Views: 10,286
Posted By kevster0522
Question engine running rough, loss of power, white smoke.

Hey friends I really need your help this time. I took my car to school so I could drive it home after my finals but I'm afraid I might not make it home. I was driving around campus last night and...
Forum: S-Series Tech 11-19-2013, 04:50 PM
Replies: 22
Views: 3,790
Posted By kevster0522
Re: Revs High when Clutch is pushed in

The fact that it only happens when the engine is cold and not when it is warm says that it is engine temp related. It could very well be my driving style also. I usually only give the engine a split...
Forum: S-Series Tech 11-19-2013, 12:38 PM
Replies: 22
Views: 3,790
Posted By kevster0522
Re: Revs High when Clutch is pushed in

Haha sorry that's a typo I meant to say it still revs when I push the clutch in.
Showing results 1 to 25 of 149

 
Forum Jump

All times are GMT -5. The time now is 12:19 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.