SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 426
Search took 0.38 seconds.
Search: Posts Made By: SalemCat
Forum: S-Series Tech 08-15-2019, 05:52 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Ok - Gorgeous day in Salem -The Witch City

Cold Busch in the frig - NO EXCUSES.

So I replaced the CPS . VROOM VROOM.

THAT WAS IT !

Tool List:
Forum: S-Series Tech 08-14-2019, 09:48 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

It's a good thing I'm retired, and my wife has a reliable vehicle.

Since the Starting Fluid blew the corrugated intake tube in two, I'm using very little.

I drove to the Supermarket Sunday with...
Forum: S-Series Tech 07-30-2019, 09:09 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Dammit.

I've been buying AC Delco because I thought it was the best, and guys on this forum would scold me for buying the cheap stuff.

Shoulda' just asked first.

:hmm:
Forum: S-Series Tech 07-30-2019, 04:07 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Why does AC Delco list two different CPS for a 1996 DOHC Engine ?

https://i.imgur.com/HtQclGK.png
Forum: S-Series Tech 07-30-2019, 04:04 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Once the car starts, I can run errands all day, and as long as I'm not in the store too long, the car will start instantly time and time again.

So something is "sticking" when the engine refuses...
Forum: S-Series Tech 07-30-2019, 03:54 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

The wires are, of course, oily - but they look like everyday wires.

I could take a voltage reading from the two contacts inside the connector socket, with the Ignition on Accessory.

Would that...
Forum: S-Series Tech 07-29-2019, 11:25 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

A new AC Delco ICM is under $100.

I will try that after the CPS.
Forum: S-Series Tech 07-29-2019, 11:21 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I put in a new AC Delco ETCS on Saturday.

Sprayed the connector with CRC. Other than a bit of oil there was no corrosion.

The connector is original.

Keeping the pedal down while cranking...
Forum: S-Series Tech 07-29-2019, 09:09 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I just the thing that puzzles me so much is that once it does start, it runs very well.

And will re-start with no problems unless it has been sitting for a couple of hours.
Forum: S-Series Tech 07-28-2019, 11:05 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I don't know what live-data is.

Will a 1996 Saturn SW2 support that ?

Oddly, there is no "Service Engine Soon" displayed.
Forum: S-Series Tech 07-28-2019, 10:40 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Forum: S-Series Tech 07-28-2019, 09:59 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Replacing the ETCS took me no more than 1/2 hour - and I work slow.

Next step: CPS.
Forum: S-Series Tech 07-28-2019, 09:54 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Well, it has been unreliable for the last month.

Half the time it starts right up, half the time I need to give it a shot of ether.

As usual, once it starts it runs perfectly, and if I stop for...
Forum: S-Series Tech 06-22-2019, 09:53 AM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Best place to buy these ?
Forum: S-Series Tech 06-21-2019, 11:00 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Well, there's no arguing with experience.

I'll pass on the grease.
Forum: S-Series Tech 06-21-2019, 07:35 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

What is Dielectric Grease for ?

I first encountered it in my 1980 Chevrolet Citation (not a bad car), when I separated a Multi-Contact Connector and was surprised to see it packed with transparent...
Forum: S-Series Tech 06-21-2019, 07:04 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Holding the gas pedal to the floor has no effect.

The Mechanic that looked at it did remove the Plugs, said they were fine, and made no mention of anything unusual.
Forum: S-Series Tech 06-21-2019, 07:02 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I ordered a 21025106 Coolant Temperature Sensor

Before I bother to install it, I'll just remove the Connector, spray it and the current CTS with Electronic Cleaner, install some Dielectric Grease,...
Forum: S-Series Tech 06-21-2019, 03:39 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I replaced the ECTS years ago with the brass one. I recall the '96 takes two.

I think I will replace them both again. It's so easy and they are cheap.

What do you think of the ACDELCO 1550360...
Forum: S-Series Tech 06-21-2019, 03:37 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I've been driving it all day, running errands, and it has been running and starting perfectly every time.

I only had to use the Starting Fluid the very first time today - which worked the first...
Forum: S-Series Tech 06-21-2019, 01:07 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I walked the mile (literally) to Advance, and bought a can of Starting Fluid.

My Saturn started right up, and 20 minutes later is still running.

What does that tell me ? Please.

CPS still ?
Forum: S-Series Tech 06-20-2019, 08:03 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I did not think of that !

A nice '95 Valve Cover Gasket is on the way from Rock Auto for $20 shipped.
Forum: S-Series Tech 06-20-2019, 06:56 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Roll Eyes Re: 96 SW2 turns but NO START

It certainly has been cool in eastern Massachusetts lately. Not warm at all. Cool today, too.

But as I understand it, it still could be the CPS.

As for cost, $25 shipped for an AC Delco is...
Forum: S-Series Tech 06-20-2019, 05:08 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

Well, could the CPS be failing just from age ?
Forum: S-Series Tech 06-20-2019, 02:58 PM
Replies: 56
Views: 1,190
Posted By SalemCat
Re: 96 SW2 turns but NO START

I was planning on scrapping my 1995 SW2 (the exhaust is shot and I figure fixing it properly with welding is a waste of $500).

The Aluminum Cover from it should fit, right ?

And I do have a new...
Showing results 1 to 25 of 426

 
Forum Jump

All times are GMT -4. The time now is 01:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.