SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 6 of 6
Search took 0.07 seconds.
Search: Posts Made By: Gary F.
Forum: Astra General 03-15-2011, 02:00 PM
Replies: 14
Views: 5,061
Posted By Gary F.
Re: Horn

My Astra horn has not been working for a few months. Last week finally took it in to local authorized service dealer, since state safety inspection is due soon. On first visit they ordered a part,...
Forum: Astra Tech 10-22-2010, 07:44 PM
Replies: 59
Views: 16,459
Posted By Gary F.
Re: Alternator Pulley? Saturn Doesn't Have the Tool? HELP!

An update on the "chirp" noise...took our 2008 Astra XR to the local Saturn authorized service center along with a copy of the service bulletin 10-06-01-001: Chirp Noise from Accessory Drive Belt...
Forum: Astra Tech 08-01-2010, 09:01 PM
Replies: 59
Views: 16,459
Posted By Gary F.
Re: Alternator Pulley? Saturn Doesn't Have the Tool? HELP!

Following this thread with interest, as I experience this same noise when starting to drive. Originally I thought, as some others have opined, that it was a slipping serpentine belt. But after...
Forum: L-Series General 07-13-2010, 11:17 AM
Replies: 22
Views: 11,047
Posted By Gary F.
Re: Youtube Video on a 2000 Saturn LW2

Wow, that's a fantastic video production. I really, really enjoyed it from beginning to end. Now do a 2008 Astra XR for us! Thanks, it was great stuff in the highest tradition of Saturn...
Forum: S-Series Tech 07-13-2010, 10:35 AM
Replies: 1,257
Views: 479,078
Posted By Gary F.
Re: how many miles do you have on your saturn?

Our 1993 SW2 had about 300K when I gave it to my son. He then made 3 or 4 trips from Dayton, Ohio to Miami and 2 trips to Montana, before it was hit while parked on the street. Unfortunately was a...
Forum: Astra Tech 07-13-2010, 10:19 AM
Replies: 17
Views: 2,961
Posted By Gary F.
Re: Clatter on startup

I have same issue, apparently a slight belt slippage at startup and during the first few accelerations when you drive, then it goes away. Only does it, or does it more, with air conditioning on. ...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -4. The time now is 02:28 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.