SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 7 of 7
Search took 0.05 seconds.
Search: Posts Made By: Appalachian
Forum: S-Series Tech 01-09-2014, 12:49 AM
Replies: 6
Views: 659
Posted By Appalachian
Re: I think I killed it. Frozen coolant. 95 SL1

Thanks all. will check it out tomorrow.
Forum: S-Series Tech 01-08-2014, 09:35 AM
Replies: 6
Views: 659
Posted By Appalachian
I think I killed it. Frozen coolant. 95 SL1

95 SL1 is my daily driver. 310k miles. Never had any problems except water pump, alternator, and ects, but all that was over the years, nothing recent.

One problem I have is it's always so dang...
Forum: S-Series Tech 12-04-2011, 01:31 PM
Replies: 1
Views: 484
Posted By Appalachian
95 SL1 Cranking too slow

Hey guys,

My 95 SL1 is having starting issues. When you try to crank the engine, the starter will sometimes slow down REAALLY low, and sometimes just stop. Advance Auto says my battery is fine. ...
Forum: S-Series Tech 05-01-2010, 01:30 PM
Replies: 4
Views: 1,150
Posted By Appalachian
Re: Cranks, won't fire

That did it. Thanks so much. Where do I send the check? :)
Forum: S-Series Tech 04-01-2010, 01:46 PM
Replies: 13
Views: 2,073
Posted By Appalachian
Re: 95 sl2 cranks but won't start

Ok, so the O2 sensor lets it breathe through its (now vacant) hole, and the cat convertor collapsed or something to stop up the exhaust in the first place.

right?
J
Forum: S-Series Tech 03-31-2010, 09:02 AM
Replies: 13
Views: 2,073
Posted By Appalachian
Re: 95 sl2 cranks but won't start

Can someone explain this to me? How does removing the O2 sensor "un-plug" the exhaust? And how the heck did it get plugged to begin with?

Thanks,
J
Forum: S-Series Tech 03-24-2010, 11:02 AM
Replies: 4
Views: 1,150
Posted By Appalachian
Cranks, won't fire

I hate to start another one of these threads, but this one's got me stumped.

95 SL1.

couple months ago it started rough a few times in the cold. Seemed fine once it warmed up. Then a couple...
Showing results 1 to 7 of 7

 
Forum Jump

All times are GMT -5. The time now is 05:11 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.