SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 467
Search took 0.09 seconds.
Search: Posts Made By: wscreate
Forum: S-Series Tech 06-05-2014, 07:01 PM
Replies: 2
Views: 409
Posted By wscreate
Re: 94 SC2 Transmission Hard shift

20 years on one transmission is not bad. I'll suck it up and get a good used one. Thanks for your reply.
Forum: S-Series Tech 06-02-2014, 09:19 AM
Replies: 2
Views: 409
Posted By wscreate
94 SC2 Transmission Hard shift

I tired searching the forum this morning, but got a 'pardon our dust' message and the search didn't go through. So, I thought I would just create this thread.

I have a 1994 SC2 with an automatic...
Forum: S-Series Tech 05-22-2014, 07:18 PM
Replies: 2
Views: 310
Posted By wscreate
Re: 1994 SC2 front hub compatibility

Thank you for your help on this. I was hoping that was the case. there are some newer model Saturns in the junk yard which I can pick from.
Forum: S-Series Tech 05-20-2014, 11:24 AM
Replies: 2
Views: 310
Posted By wscreate
1994 SC2 front hub compatibility

I looked through the forums before asking this and I also looked at the swap guide but did not see a clear answer to this question.

I have a 1994 SC2 and I am wondering what models or years use...
Forum: S-Series Tech 05-11-2014, 05:44 PM
Replies: 9
Views: 811
Posted By wscreate
Re: Cooling Fan wiring issue

Having tested as i've mentioned, I believed the problem to be the wiring from the junction box to the fan. Because it was very tedious to follow the wiring through the engine compartment back to the...
Forum: S-Series Tech 05-10-2014, 09:04 AM
Replies: 9
Views: 811
Posted By wscreate
Re: Cooling Fan wiring issue

Yes, there is power at that pin.
Forum: S-Series Tech 05-10-2014, 12:34 AM
Replies: 9
Views: 811
Posted By wscreate
Re: Cooling Fan wiring issue

I did jump 30 and 87 and have done it before to turn on the fan. This time, it did not turn the fan on. Nothing happened.
Forum: S-Series Tech 05-10-2014, 12:33 AM
Replies: 9
Views: 811
Posted By wscreate
Re: Cooling Fan wiring issue

I see where you are going with this. Where would the ground be for the fan?
Forum: S-Series Tech 05-09-2014, 05:30 PM
Replies: 9
Views: 811
Posted By wscreate
Cooling Fan wiring issue

So, i have a 94 Saturn SC 2 and the cooling fan stopped working. I pulled the fan out and was getting ready to replace it but decided to check it. I applied dc voltage and the fan worked. ...
Forum: S-Series Tech 05-01-2014, 09:57 AM
Replies: 8
Views: 868
Posted By wscreate
Re: I thought it was a power steering pump...

I'll keep that in mind next time.
Forum: S-Series Tech 05-01-2014, 09:56 AM
Replies: 8
Views: 868
Posted By wscreate
Re: I thought it was a power steering pump...

I don't have much luck with Chinese made aftermarket parts. I had to get one that day so it was Autozone (Chinese part) or junk yard and a (hopefully) oem part.
Forum: S-Series Tech 04-29-2014, 09:30 PM
Replies: 8
Views: 868
Posted By wscreate
I thought it was a power steering pump...

I noticed a loud sound coming from the passenger side of the engine compartment for the past month or two. I thought it was a power steering pump and so I decided to change it out this past weekend....
Forum: S-Series Tech 02-16-2012, 06:10 PM
Replies: 6
Views: 5,588
Posted By wscreate
Re: Noisy wheel bearing or noisy brake pads?

Bought new pads and hardware today for the front. I took off the wheel on the noisy side and this is what I found.

#1. Loose lug nuts. It seems I made a huge mistake and did not torque them...
Forum: S-Series Tech 02-15-2012, 04:29 PM
Replies: 6
Views: 5,588
Posted By wscreate
Re: Noisy wheel bearing or noisy brake pads?

Thanks. About two years ago, I had a new Timken bearing pressed into a new hub at a local shop since I do not have a press. No, I did not back up the nut. I'm pretty sure that I greased the caliper...
Forum: S-Series Tech 02-15-2012, 03:17 PM
Replies: 6
Views: 5,588
Posted By wscreate
Noisy wheel bearing or noisy brake pads?

I replaced the front wheel hubs and bearing on my 1994 SC2 almost 2 years ago. I've put about 20000 miles on the car since then. I noticed a few weeks ago that my brake pads seem to be making a...
Forum: S-Series Tech 02-08-2012, 03:16 PM
Replies: 40
Views: 5,132
Posted By wscreate
Re: Delphi or Silla water pump????

I just replaced the same exact water pump on my car after only 11 months and 24 days. Yes, it had 6 days left on the free replacement warranty.
Forum: S-Series Tech 02-08-2012, 02:04 PM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

I cranked the car with the new water pump installed and the loud, roaring sound is gone. The old water pump was defective and making an awful racket. Now the car is quiet again. Took the car for a...
Forum: S-Series Tech 02-07-2012, 11:41 AM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

Think about how I feel. I am anxious to find out if this will work. lol
Forum: S-Series Tech 02-07-2012, 11:18 AM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

I replaced the water pump with a new one. The permatex tube said to wait 24 hours for the gasket to seal properly. I'll crank it tomorrow and hopefully the new pump will work fine and the roaring...
Forum: S-Series Tech 02-06-2012, 10:07 PM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

I think it is the water pump. I have the free replacement one from Autozone and will install it in the morning. I'll update this thread after I crank the car. Hopefully the grinding noise will be...
Forum: S-Series Tech 02-06-2012, 05:32 PM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

I just checked and I have a warranty on my water pump until Feb 16th. I'll find out after I replace it if it is defective.
Forum: S-Series Tech 02-06-2012, 04:55 PM
Replies: 9
Views: 1,496
Posted By wscreate
Re: Roaring sound at idle in engine bay, front passenger side... I'm thinking...

I heard it again and it seems like it is the water pump. Going to head to AZ to check out if I have the warranty.
Forum: S-Series Tech 02-06-2012, 03:06 PM
Replies: 9
Views: 1,496
Posted By wscreate
Roaring sound at idle in engine bay, front passenger side... I'm thinking...

... water pump. I took the belt off and ran the car for 10 seconds and the sound is not there. I put the belt back on and listened again and it is coming from the front of the car near the belts......
Forum: S-Series Tech 01-29-2012, 09:12 AM
Replies: 29
Views: 2,006
Posted By wscreate
Re: Stupid mistake with wrong oil filter

lol, it seems so. I learned a long time ago to put down kitty litter under the oil pan when I change the oil to protect the floor of my garage. It saved me a lot of clean up this time. If I have...
Forum: S-Series Tech 01-28-2012, 08:30 PM
Replies: 29
Views: 2,006
Posted By wscreate
Re: Stupid mistake with wrong oil filter

Thanks. I have *not heard good things about Fram filters.
Showing results 1 to 25 of 467

 
Forum Jump

All times are GMT -4. The time now is 05:13 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.