SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Search Forums
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Showing results 1 to 25 of 245
Search took 0.08 seconds.
Search: Posts Made By: kickarse
Forum: L-Series Tech 07-11-2011, 08:23 AM
Replies: 5
Views: 1,119
Posted By kickarse
Re: It lives... err... it dies :( Help!

... just updating everyone. Fortunately it didn't take three years to figure it out (only about a week or three).

And no, NO ONE posted on my thread in 3 years rofl. Show's how many people are...
Forum: L-Series Tech 07-11-2011, 08:21 AM
Replies: 5
Views: 1,033
Posted By kickarse
Re: Clogged Catalytics Converter and O2 Sensor

Thanks for the info Jerry!

I just verified the sticker under the hood for catalyst controls. It says that it conforms to California emissions for the 2001 year.

The sticker also said something...
Forum: L-Series Tech 07-10-2011, 12:04 PM
Replies: 5
Views: 1,033
Posted By kickarse
Re: Clogged Catalytics Converter and O2 Sensor

Are you sure about that Jerry? I've also noticed that they ask about it with Exhaust manifold gaskets too.

I know the SL's didn't come with cali/non-cali emissions.
Forum: L-Series Tech 07-10-2011, 06:59 AM
Replies: 5
Views: 1,119
Posted By kickarse
Re: It lives... err... it dies :( Help!

The coil pack did indeed fix the dieing issue.
Forum: L-Series Tech 07-10-2011, 06:56 AM
Replies: 9
Views: 3,221
Posted By kickarse
Re: 2002 L200 - hard or no cold starts

The starter did indeed fix the issues with it starting. But unrelated the issue with the RPMs was the TPS.
Forum: L-Series Tech 07-10-2011, 06:49 AM
Replies: 5
Views: 1,033
Posted By kickarse
Re: Clogged Catalytics Converter and O2 Sensor

Anyone?

Also, I found this at JCWhitney.com and was wondering if anyone else had tried it before...

http://www.jcwhitney.com/catalytic-converter-cleaner-and-deodorizer/p2000760.jcwx?filterid=j1
Forum: L-Series Tech 07-08-2011, 09:34 AM
Replies: 5
Views: 1,033
Posted By kickarse
Clogged Catalytics Converter and O2 Sensor

The other day I noticed my car had reduced power in at all RPM's and noticeably quieter at idle. I thought it was probably a clogged catcon but needed a second opinion and diagnostics. They found...
Forum: L-Series General 10-26-2009, 10:24 AM
Replies: 5
Views: 606
Posted By kickarse
Re: New tire deal i got!

Got some Cooper Weather-Masters 4 for $80. Winter tires are much larger than stock though, 205/70/15 compared to 195/65/15.
Forum: L-Series Tech 12-14-2008, 08:07 PM
Replies: 1
Views: 810
Posted By kickarse
Re: 02 L 2.2 raw gas smell

I would check for any leaks for air pressure lines going from the TB.

Also the EVAP solenoid might be going bad, it's a tall tale sign that it might be going.
Forum: L-Series General 12-12-2008, 06:01 PM
Replies: 18
Views: 1,455
Posted By kickarse
Re: New L-Series Owner!

Do you know how many quarts and what type of transmission fluid it calls for?
Forum: L-Series Tech 12-12-2008, 10:32 AM
Replies: 9
Views: 3,221
Posted By kickarse
Re: 2002 L200 - hard or no cold starts

So it's been starting this whole week. However, I have been having some interesting things happen to me. Mostly when at a stop will it gurgle a little and drop the revs. Also once in a while during...
Forum: L-Series General 12-12-2008, 10:25 AM
Replies: 18
Views: 1,455
Posted By kickarse
Re: New L-Series Owner!

Not to thread stomp but does anyone have a how-to on the transmission flush and new filter installation? I don't think my haynes shows that.
Forum: L-Series General 12-07-2008, 08:50 PM
Replies: 18
Views: 1,455
Posted By kickarse
Re: New L-Series Owner!

I have a 02 and have a similar issue with the dash lights. What is your mileage?
Forum: L-Series Tech 12-07-2008, 06:11 PM
Replies: 9
Views: 3,221
Posted By kickarse
Re: 2002 L200 - hard or no cold starts

I had the starter tested today at Autozone and it tested fine. The guy said it sounded like it started a bit slow. He also said a post was loose, which he said might not help the situation. But I...
Forum: L-Series Tech 12-07-2008, 12:24 PM
Replies: 9
Views: 3,221
Posted By kickarse
Re: 2002 L200 - hard or no cold starts

Thanks for the advice.

The battery was just bought two weeks ago (750 or 800 cold cranking amps I believe). I'm going to pull the starter and have Autozone test it. I'll also check for corrosion...
Forum: L-Series Tech 12-07-2008, 08:38 AM
Replies: 9
Views: 3,221
Posted By kickarse
Re: 2002 L200 - hard or no cold starts

The cars been running fine since the summer cleaning. I've had absolutely no problems. And actually it wasn't the summer it was more like April/May if I remember correctly.

I actually took the...
Forum: L-Series Tech 12-06-2008, 11:01 AM
Replies: 6
Views: 2,071
Posted By kickarse
Re: 2000 Saturn LS Missing at idle

Any updates on this?
Forum: L-Series Tech 12-06-2008, 10:47 AM
Replies: 9
Views: 3,221
Posted By kickarse
2002 L200 - hard or no cold starts

So I've been having a problem for a couple weeks now. Now that the nice cold winter days have started I'm having issues with cold starts. (2.2l 4cyl, 116kmi)

Things I've replaced -
- Alternator...
Forum: L-Series Tech 12-06-2008, 09:32 AM
Replies: 5
Views: 556
Posted By kickarse
Re: Since it got cold I keep getting the same 2 codes

Frank,

How'd the testing go with this?
Forum: L-Series Tech 06-13-2008, 10:58 AM
Replies: 1
Views: 821
Posted By kickarse
Replacement suspension bushings

So I'm curious if anyone has replaced their bushings yet? I'm about ready to myself and need sizing advice.

Anyone??
Forum: L-Series Tech 05-09-2008, 01:16 PM
Replies: 5
Views: 1,119
Posted By kickarse
Re: It lives... err... it dies :( Help!

I'm going to be getting fuel pressure tester to see how my PSI is on my rails to see whats what. We'll see if the coil pack fixes it though.
Forum: L-Series Tech 05-09-2008, 10:54 AM
Replies: 5
Views: 1,119
Posted By kickarse
Re: It lives... err... it dies :( Help!

So the schrader valve did spray a good stream about two feet away. Seems healthy to me. I did notice that after the engine is not used for a little bit that the FPR seems to let the gas back into the...
Forum: L-Series Tech 05-09-2008, 10:09 AM
Replies: 5
Views: 1,119
Posted By kickarse
It lives... err... it dies :( Help!

So I've been having intermittent issues with my car. Various things failing and what not. (In my signature 2002 L200 4cyl) NO SES or SW lights.

First off, I've replaced the fuel, air and oil (and...
Forum: L-Series General 05-09-2008, 09:22 AM
Replies: 2
Views: 732
Posted By kickarse
Re: 1992 automatic tranny in a 1999 sl1

Hey Danny! Welcome to the boards and a common mistake is that the SL is an L series. I would post this on the SL section of the forums.
Forum: L-Series Tech 05-09-2008, 08:35 AM
Replies: 7
Views: 1,058
Posted By kickarse
Re: Random Dying

Not to beat an old dog but the Haynes manual I have doesn't show where the Fuel Pump Relay is. Does anyone have an idea?
Showing results 1 to 25 of 245

 
Forum Jump

All times are GMT -5. The time now is 07:42 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.